summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-07-12 15:49:20 -0600
committerMark Wagie2023-07-12 15:49:20 -0600
commite1bd10b0506756756b7e15680f6b658c559e71e7 (patch)
treec91fdf5c6dc24535daf2ededed806e4dcebf0a92
parent984e3c3dc843e0fa449310ce4cc8c2c0a8ce0c86 (diff)
downloadaur-e1bd10b0506756756b7e15680f6b658c559e71e7.tar.gz
2.6.0
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f3df8c59766..f63c025a51a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jamesdsp
pkgdesc = An audio effect processor for PipeWire clients
- pkgver = 2.5.1
+ pkgver = 2.6.0
pkgrel = 1
url = https://github.com/Audio4Linux/JDSP4Linux
arch = x86_64
@@ -18,11 +18,12 @@ pkgbase = jamesdsp
replaces = jdsp4linux
replaces = jdsp4linux-gui
replaces = gst-plugin-jamesdsp
+ options = !strip
source = git+https://github.com/Audio4Linux/JDSP4Linux.git
source = git+https://github.com/ThePBone/GraphicEQWidget.git
source = git+https://github.com/ThePBone/FlatTabWidget.git
source = git+https://github.com/ThePBone/LiquidEqualizerWidget.git
- source = git+https://github.com/ThePBone/EELEditor.git
+ source = git+https://github.com/ThePBone/LiveprogIDE.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 27261ca3f0e8..63d530d2f5f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=jamesdsp
_app_id=me.timschneeberger.jdsp4linux
-pkgver=2.5.1
+pkgver=2.6.0
pkgrel=1
pkgdesc="An audio effect processor for PipeWire clients"
arch=('x86_64')
@@ -12,12 +12,13 @@ depends=('glibmm' 'hicolor-icon-theme' 'libarchive' 'libportal-qt5' 'libpipewire
makedepends=('git')
conflicts=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
replaces=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
-_commit=8352d5117d66fb3d146c7610ee430e9af5386854 # tags/2.5.1^0
+options=('!strip')
+_commit=7868e4389a3ba97019d50d7d316507f2b131720e # tags/2.6.0^0
source=('git+https://github.com/Audio4Linux/JDSP4Linux.git'
'git+https://github.com/ThePBone/GraphicEQWidget.git'
'git+https://github.com/ThePBone/FlatTabWidget.git'
'git+https://github.com/ThePBone/LiquidEqualizerWidget.git'
- 'git+https://github.com/ThePBone/EELEditor.git')
+ 'git+https://github.com/ThePBone/LiveprogIDE.git')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -32,7 +33,7 @@ sha256sums=('SKIP'
prepare() {
cd "$srcdir/JDSP4Linux"
- for submodule in EELEditor GraphicEQWidget FlatTabWidget LiquidEqualizerWidget; do
+ for submodule in GraphicEQWidget FlatTabWidget LiquidEqualizerWidget LiveprogIDE; do
git submodule init
git config submodule.src/subprojects/"$submodule".url "$srcdir/$submodule"
git -c protocol.file.allow=always submodule update
@@ -47,12 +48,17 @@ build() {
pushd build
qmake-qt5 ..
make
+ strip --strip-unneeded src/jamesdsp
popd
}
package() {
cd "$srcdir/JDSP4Linux"
- install -Dm755 build/src/jamesdsp -t "$pkgdir/usr/bin/"
+
+ pushd build
+ make INSTALL_ROOT="$pkgdir" install
+ popd
+
install -Dm644 resources/icons/icon.png \
"$pkgdir/usr/share/pixmaps/${_app_id}.png"
install -Dm644 resources/icons/icon.svg \