summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-12-09 16:59:54 -0700
committerMark Wagie2023-12-09 16:59:54 -0700
commit5b9d4f916fb032747d1854e4bf6e6d8ebc127756 (patch)
treef929d2cb071bd2fbd5cff909ef7320a4db2e97ec
parentbd76f8917d2235afceaa906a71dc22491577b352 (diff)
downloadaur-5b9d4f916fb032747d1854e4bf6e6d8ebc127756.tar.gz
2.7.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4417447d79b4..e3a9c66187d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = jamesdsp-pulse
pkgdesc = An audio effect processor for PulseAudio clients
- pkgver = 2.6.1
+ pkgver = 2.7.0
pkgrel = 1
url = https://github.com/Audio4Linux/JDSP4Linux
arch = x86_64
license = GPL3
makedepends = git
depends = glibmm
- depends = gst-plugins-good
depends = hicolor-icon-theme
depends = libarchive
- depends = libpulse
- depends = qt5-svg
+ depends = libpipewire
+ depends = qt6-svg
provides = jamesdsp
conflicts = jamesdsp
conflicts = jdsp4linux
@@ -21,7 +20,7 @@ pkgbase = jamesdsp-pulse
replaces = jdsp4linux-gui
replaces = gst-plugin-jamesdsp
options = !strip
- source = git+https://github.com/Audio4Linux/JDSP4Linux.git#commit=e8c5f0af4c3b60cb70d5f92628d4de46a4ca2128
+ source = git+https://github.com/Audio4Linux/JDSP4Linux.git#commit=30a30aa5ce90f97ea2c93bc372c0a67c8e3c54c8
source = git+https://github.com/ThePBone/GraphicEQWidget.git
source = git+https://github.com/ThePBone/FlatTabWidget.git
source = git+https://github.com/ThePBone/LiquidEqualizerWidget.git
diff --git a/PKGBUILD b/PKGBUILD
index 04f0abd6c9a3..967e47334973 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=jamesdsp-pulse
_app_id=me.timschneeberger.jdsp4linux.pulse
-pkgver=2.6.1
+pkgver=2.7.0
pkgrel=1
pkgdesc="An audio effect processor for PulseAudio clients"
arch=('x86_64')
url="https://github.com/Audio4Linux/JDSP4Linux"
license=('GPL3')
-depends=('glibmm' 'gst-plugins-good' 'hicolor-icon-theme' 'libarchive' 'libpulse'
- 'qt5-svg')
+depends=('glibmm' 'hicolor-icon-theme' 'libarchive' 'libpipewire' 'qt6-svg')
makedepends=('git')
provides=('jamesdsp')
conflicts=('jamesdsp' 'jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
replaces=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
options=('!strip')
-_commit=e8c5f0af4c3b60cb70d5f92628d4de46a4ca2128 # tags/2.6.1^0
+_commit=30a30aa5ce90f97ea2c93bc372c0a67c8e3c54c8 # tags/2.7.0^0
source=("git+https://github.com/Audio4Linux/JDSP4Linux.git#commit=$_commit"
'git+https://github.com/ThePBone/GraphicEQWidget.git'
'git+https://github.com/ThePBone/FlatTabWidget.git'
@@ -47,7 +46,7 @@ build() {
cd "$srcdir/JDSP4Linux"
pushd build
- qmake-qt5 .. "CONFIG += USE_PULSEAUDIO"
+ qmake6 ..
make
strip --strip-unneeded src/jamesdsp
popd