summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-07-12 15:49:03 -0600
committerMark Wagie2023-07-12 15:49:03 -0600
commit9d8f55324e559abf3b292a6b089c4ff248887392 (patch)
treefd52924c58848174dfbf59dd2b971bde5c81c08e
parent0a621e9f265caf60d96f542c222196d3a6a426f3 (diff)
downloadaur-9d8f55324e559abf3b292a6b089c4ff248887392.tar.gz
2.6.0
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22ca10b99506..7ee1774df741 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jamesdsp-pulse
pkgdesc = An audio effect processor for PulseAudio clients
- pkgver = 2.5.1
+ pkgver = 2.6.0
pkgrel = 1
url = https://github.com/Audio4Linux/JDSP4Linux
arch = x86_64
@@ -20,11 +20,12 @@ pkgbase = jamesdsp-pulse
replaces = jdsp4linux
replaces = jdsp4linux-gui
replaces = gst-plugin-jamesdsp
+ options = !strip
source = git+https://github.com/Audio4Linux/JDSP4Linux.git
source = git+https://github.com/ThePBone/GraphicEQWidget.git
source = git+https://github.com/ThePBone/FlatTabWidget.git
source = git+https://github.com/ThePBone/LiquidEqualizerWidget.git
- source = git+https://github.com/ThePBone/EELEditor.git
+ source = git+https://github.com/ThePBone/LiveprogIDE.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 117e9875eed5..d0495fa0822d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=jamesdsp-pulse
_app_id=me.timschneeberger.jdsp4linux.pulse
-pkgver=2.5.1
+pkgver=2.6.0
pkgrel=1
pkgdesc="An audio effect processor for PulseAudio clients"
arch=('x86_64')
@@ -13,12 +13,13 @@ makedepends=('git')
provides=('jamesdsp')
conflicts=('jamesdsp' 'jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
replaces=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
-_commit=8352d5117d66fb3d146c7610ee430e9af5386854 # tags/2.5.1^0
+options=('!strip')
+_commit=7868e4389a3ba97019d50d7d316507f2b131720e # tags/2.6.0^0
source=('git+https://github.com/Audio4Linux/JDSP4Linux.git'
'git+https://github.com/ThePBone/GraphicEQWidget.git'
'git+https://github.com/ThePBone/FlatTabWidget.git'
'git+https://github.com/ThePBone/LiquidEqualizerWidget.git'
- 'git+https://github.com/ThePBone/EELEditor.git')
+ 'git+https://github.com/ThePBone/LiveprogIDE.git')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -33,7 +34,7 @@ sha256sums=('SKIP'
prepare() {
cd "$srcdir/JDSP4Linux"
- for submodule in EELEditor GraphicEQWidget FlatTabWidget LiquidEqualizerWidget; do
+ for submodule in GraphicEQWidget FlatTabWidget LiquidEqualizerWidget LiveprogIDE; do
git submodule init
git config submodule.src/subprojects/"$submodule".url "$srcdir/$submodule"
git -c protocol.file.allow=always submodule update
@@ -48,12 +49,17 @@ build() {
pushd build
qmake-qt5 .. "CONFIG += USE_PULSEAUDIO"
make
+ strip --strip-unneeded src/jamesdsp
popd
}
package() {
cd "$srcdir/JDSP4Linux"
- install -Dm755 build/src/jamesdsp -t "$pkgdir/usr/bin/"
+
+ pushd build
+ make INSTALL_ROOT="$pkgdir" install
+ popd
+
install -Dm644 resources/icons/icon.png \
"$pkgdir/usr/share/pixmaps/${_app_id}.png"
install -Dm644 resources/icons/icon.svg \