summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-05-29 10:20:12 -0600
committerMark Wagie2022-05-29 10:20:12 -0600
commitab2e21710f3ec77fc71173aab6a11824044277dc (patch)
treed83987aa48bc821bee350bb90e74751506997455
parentb19cd76ed810b489b993163dffc00191f6f9ef47 (diff)
downloadaur-ab2e21710f3ec77fc71173aab6a11824044277dc.tar.gz
use git commit hash instead of tag
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 289c5a426ca6..4e1292406026 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jamesdsp-pulse
pkgdesc = An audio effect processor for PulseAudio clients
pkgver = 2.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Audio4Linux/JDSP4Linux
arch = x86_64
license = GPL3
@@ -18,7 +18,7 @@ pkgbase = jamesdsp-pulse
replaces = jdsp4linux
replaces = jdsp4linux-gui
replaces = gst-plugin-jamesdsp
- source = git+https://github.com/Audio4Linux/JDSP4Linux.git#tag=2.3
+ source = git+https://github.com/Audio4Linux/JDSP4Linux.git#commit=1f49c84c222a02d9e9e2e1a4a2fb04397ce7017b
source = git+https://github.com/ThePBone/EELEditor.git
source = git+https://github.com/ThePBone/GraphicEQWidget.git
source = git+https://github.com/ThePBone/FlatTabWidget.git
diff --git a/PKGBUILD b/PKGBUILD
index 629e1a21a0cf..13362d9b3680 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=jamesdsp-pulse
pkgver=2.3
-pkgrel=2
+pkgrel=3
pkgdesc="An audio effect processor for PulseAudio clients"
arch=('x86_64')
url="https://github.com/Audio4Linux/JDSP4Linux"
@@ -11,7 +11,8 @@ makedepends=('git')
provides=('jamesdsp')
conflicts=('jamesdsp' 'jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
replaces=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
-source=("git+https://github.com/Audio4Linux/JDSP4Linux.git#tag=$pkgver"
+_commit=1f49c84c222a02d9e9e2e1a4a2fb04397ce7017b
+source=("git+https://github.com/Audio4Linux/JDSP4Linux.git#commit=$_commit"
'git+https://github.com/ThePBone/EELEditor.git'
'git+https://github.com/ThePBone/GraphicEQWidget.git'
'git+https://github.com/ThePBone/FlatTabWidget.git'
@@ -24,6 +25,11 @@ sha256sums=('SKIP'
'SKIP'
'c6496e6981471aa3f8d1593673991e422d243ff3efe595b3230de713588599c3')
+pkgver() {
+ cd "$srcdir/JDSP4Linux"
+ git describe --tags | sed 's/-/+/g'
+}
+
prepare() {
cd "$srcdir/JDSP4Linux"