summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-12-30 10:44:05 -0700
committerMark Wagie2021-12-30 10:44:05 -0700
commite6b50494a4d81b3fcdbd3a82474b4a99c0971c11 (patch)
tree4c34150c62a0f8c017c9b68435243a62bc47dc5b
parent162c2bec3130340dccad3baa0056e3f7c643c6ba (diff)
downloadaur-e6b50494a4d81b3fcdbd3a82474b4a99c0971c11.tar.gz
2.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aab02f101133..81120b814fd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jamesdsp-pulse
pkgdesc = An audio effect processor for PulseAudio clients
- pkgver = 2.2
- pkgrel = 2
+ pkgver = 2.3
+ pkgrel = 1
url = https://github.com/Audio4Linux/JDSP4Linux
arch = x86_64
license = GPL3
@@ -18,11 +18,17 @@ pkgbase = jamesdsp-pulse
replaces = jdsp4linux
replaces = jdsp4linux-gui
replaces = gst-plugin-jamesdsp
- source = git+https://github.com/Audio4Linux/JDSP4Linux.git#tag=2.2
+ source = git+https://github.com/Audio4Linux/JDSP4Linux.git#tag=2.3
source = git+https://github.com/ThePBone/EELEditor.git
+ source = git+https://github.com/ThePBone/GraphicEQWidget.git
+ source = git+https://github.com/ThePBone/FlatTabWidget.git
+ source = git+https://github.com/ThePBone/LiquidEqualizerWidget.git
source = jamesdsp.desktop
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = c6496e6981471aa3f8d1593673991e422d243ff3efe595b3230de713588599c3
pkgname = jamesdsp-pulse
diff --git a/PKGBUILD b/PKGBUILD
index 318fdc649c64..9eda29ef06e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=jamesdsp-pulse
-pkgver=2.2
-pkgrel=2
+pkgver=2.3
+pkgrel=1
pkgdesc="An audio effect processor for PulseAudio clients"
arch=('x86_64')
url="https://github.com/Audio4Linux/JDSP4Linux"
@@ -13,16 +13,25 @@ conflicts=('jamesdsp' 'jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
replaces=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
source=("git+https://github.com/Audio4Linux/JDSP4Linux.git#tag=$pkgver"
'git+https://github.com/ThePBone/EELEditor.git'
+ 'git+https://github.com/ThePBone/GraphicEQWidget.git'
+ 'git+https://github.com/ThePBone/FlatTabWidget.git'
+ 'git+https://github.com/ThePBone/LiquidEqualizerWidget.git'
'jamesdsp.desktop')
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'c6496e6981471aa3f8d1593673991e422d243ff3efe595b3230de713588599c3')
prepare() {
cd "$srcdir/JDSP4Linux"
- git submodule init src/subprojects/EELEditor
- git config submodule.EELEditor.url "$srcdir/EELEditor"
- git submodule update
+
+ for submodule in EELEditor GraphicEQWidget FlatTabWidget LiquidEqualizerWidget; do
+ git submodule init
+ git config submodule.src/subprojects/"$submodule".url "$srcdir/$submodule"
+ git submodule update
+ done
mkdir -p build
}