summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-06-16 13:11:49 -0600
committerMark Wagie2023-06-16 13:11:49 -0600
commitf0424af2b53c1141475607c23f22cb7371b89db3 (patch)
tree8c3d87c708e65de9f36959305436397611bdc57a
parent23c190f94b3adc2dc873b1a08d2261a95897bcb0 (diff)
downloadaur-f0424af2b53c1141475607c23f22cb7371b89db3.tar.gz
2.5.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f67f03077608..f88b49681ae0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jamesdsp-pulse
pkgdesc = An audio effect processor for PulseAudio clients
- pkgver = 2.4
+ pkgver = 2.5.0
pkgrel = 1
url = https://github.com/Audio4Linux/JDSP4Linux
arch = x86_64
@@ -8,6 +8,8 @@ pkgbase = jamesdsp-pulse
makedepends = git
depends = glibmm
depends = gst-plugins-good
+ depends = hicolor-icon-theme
+ depends = libarchive
depends = libpulse
depends = qt5-svg
provides = jamesdsp
@@ -18,17 +20,15 @@ pkgbase = jamesdsp-pulse
replaces = jdsp4linux
replaces = jdsp4linux-gui
replaces = gst-plugin-jamesdsp
- source = git+https://github.com/Audio4Linux/JDSP4Linux.git#commit=49994d2856b66e6c6a9a8752ac47dd338a45166c
- source = git+https://github.com/ThePBone/EELEditor.git
+ source = git+https://github.com/Audio4Linux/JDSP4Linux.git
source = git+https://github.com/ThePBone/GraphicEQWidget.git
source = git+https://github.com/ThePBone/FlatTabWidget.git
source = git+https://github.com/ThePBone/LiquidEqualizerWidget.git
- source = jamesdsp.desktop
+ source = git+https://github.com/ThePBone/EELEditor.git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = c6496e6981471aa3f8d1593673991e422d243ff3efe595b3230de713588599c3
pkgname = jamesdsp-pulse
diff --git a/PKGBUILD b/PKGBUILD
index b65689e09146..dca3228b04ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=jamesdsp-pulse
-pkgver=2.4
+_app_id=me.timschneeberger.jdsp4linux.pulse
+pkgver=2.5.0
pkgrel=1
pkgdesc="An audio effect processor for PulseAudio clients"
arch=('x86_64')
url="https://github.com/Audio4Linux/JDSP4Linux"
license=('GPL3')
-depends=('glibmm' 'gst-plugins-good' 'libpulse' 'qt5-svg')
+depends=('glibmm' 'gst-plugins-good' 'hicolor-icon-theme' 'libarchive' 'libpulse'
+ 'qt5-svg')
makedepends=('git')
provides=('jamesdsp')
conflicts=('jamesdsp' 'jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
replaces=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
-_commit=49994d2856b66e6c6a9a8752ac47dd338a45166c
-source=("git+https://github.com/Audio4Linux/JDSP4Linux.git#commit=$_commit"
- 'git+https://github.com/ThePBone/EELEditor.git'
+_commit=c320ee34e05bc2ac6413226b2ab755448901f893 # tags/2.5.0^0
+source=('git+https://github.com/Audio4Linux/JDSP4Linux.git'
'git+https://github.com/ThePBone/GraphicEQWidget.git'
'git+https://github.com/ThePBone/FlatTabWidget.git'
'git+https://github.com/ThePBone/LiquidEqualizerWidget.git'
- 'jamesdsp.desktop')
+ 'git+https://github.com/ThePBone/EELEditor.git')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'c6496e6981471aa3f8d1593673991e422d243ff3efe595b3230de713588599c3')
+ 'SKIP')
pkgver() {
cd "$srcdir/JDSP4Linux"
@@ -55,8 +55,11 @@ package() {
cd "$srcdir/JDSP4Linux"
install -Dm755 build/src/jamesdsp -t "$pkgdir/usr/bin/"
install -Dm644 resources/icons/icon.png \
- "$pkgdir/usr/share/pixmaps/jamesdsp.png"
+ "$pkgdir/usr/share/pixmaps/${_app_id}.png"
install -Dm644 resources/icons/icon.svg \
- "$pkgdir/usr/share/icons/hicolor/scalable/apps/jamesdsp.svg"
- install -Dm644 "$srcdir/jamesdsp.desktop" -t "$pkgdir/usr/share/applications/"
+ "$pkgdir/usr/share/icons/hicolor/scalable/apps/${_app_id}.svg"
+ install -Dm644 "meta/flatpak/${_app_id}.desktop" -t \
+ "$pkgdir/usr/share/applications/"
+ install -Dm644 "meta/flatpak/${_app_id}.metainfo.xml" -t \
+ "$pkgdir/usr/share/metainfo/"
}