summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSenya2020-07-25 15:00:39 +0300
committerSenya2020-07-25 15:00:39 +0300
commit1c150c9e64e731fc39f266c580ba8fe651a9cf4d (patch)
tree43aa0d45ffa758da64d094e8d1ba40f25bda68b4
downloadaur-1c150c9e64e731fc39f266c580ba8fe651a9cf4d.tar.gz
initial commit for jami-gnome-git
-rw-r--r--.SRCINFO35
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD47
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4eb99db30f3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = jami-gnome-git
+ pkgdesc = Free and universal communication platform which preserves the users’ privacy and freedoms (GNOME client)
+ pkgver = 1.0.0.r773.g50fc0a5
+ pkgrel = 1
+ url = https://jami.net
+ arch = x86_64
+ groups = jami
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = libjamiclient-git
+ depends = jami-daemon-git
+ depends = gtk3
+ depends = dconf
+ depends = clutter
+ depends = clutter-gtk
+ depends = webkit2gtk
+ depends = qrencode
+ depends = qt5-base
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = libnotify
+ depends = libcanberra
+ depends = libnm
+ provides = ring-gnome
+ conflicts = ring-gnome
+ conflicts = jami-gnome
+ replaces = ring-gnome
+ source = git+https://git.jami.net/savoirfairelinux/ring-client-gnome.git
+ source = git+https://git.jami.net/savoirfairelinux/ring-lrc.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = jami-gnome-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfc0877dfe68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Senya <senya at riseup.net>
+# Contributor: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+# Contributor: Bruno Pagani <archange@archlinux.org>
+
+pkgname=jami-gnome-git
+pkgver=1.0.0.r773.g50fc0a5
+pkgrel=1
+pkgdesc="Free and universal communication platform which preserves the users’ privacy and freedoms (GNOME client)"
+arch=(x86_64)
+url="https://jami.net"
+license=(GPL3)
+groups=(jami)
+depends=(libjamiclient-git jami-daemon-git
+ gtk3 dconf clutter clutter-gtk webkit2gtk qrencode qt5-base
+ gtk-update-icon-cache desktop-file-utils libnotify libcanberra libnm)
+makedepends=(git cmake)
+provides=(ring-gnome)
+conflicts=(ring-gnome jami-gnome)
+replaces=(ring-gnome)
+source=(
+ "git+https://git.jami.net/savoirfairelinux/ring-client-gnome.git"
+ "git+https://git.jami.net/savoirfairelinux/ring-lrc.git"
+)
+md5sums=(SKIP SKIP)
+
+pkgver() {
+ cd ring-client-gnome
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p build
+ mv ring-lrc lrc
+}
+
+build() {
+ cd build
+ cmake ../ring-client-gnome \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}