summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Econopouly2020-12-24 21:14:29 -0500
committerNick Econopouly2020-12-24 21:14:29 -0500
commit2826841adfe3f701917cfe217330ff2397ecda35 (patch)
treee262171becadcb54846554b6dedbce6e5d04993a
downloadaur-2826841adfe3f701917cfe217330ff2397ecda35.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--0000.patch376
-rw-r--r--PKGBUILD44
3 files changed, 439 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b78749fabd6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = jami-client-qt-git
+ pkgdesc = Free and universal communication platform which preserves the users’ privacy and freedoms (QT client)
+ pkgver = r271.7168d9f
+ pkgrel = 1
+ url = https://git.jami.net/savoirfairelinux/jami-client-qt
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = jami-daemon-git
+ depends = libjamiclient-git
+ depends = qt5-base
+ provides = jami-client-qt
+ source = git+https://git.jami.net/savoirfairelinux/jami-client-qt.git
+ source = 0000.patch
+ sha512sums = SKIP
+ sha512sums = 5f0c26009723ef24867cc140c6284fc0e432a9817358e2ce4f912ab9471c5b5c818af7d3b90103659959c8fa810da5dd500722079ad7b99e4666d501b7080a55
+
+pkgname = jami-client-qt-git
+
diff --git a/0000.patch b/0000.patch
new file mode 100644
index 000000000000..87a65f21cb29
--- /dev/null
+++ b/0000.patch
@@ -0,0 +1,376 @@
+diff --git a/jami-qt.pro b/jami-qt.pro
+index 57df532..a205896 100644
+--- a/jami-qt.pro
++++ b/jami-qt.pro
+@@ -102,12 +102,12 @@ unix {
+ INCLUDEPATH += $${LRC}/include/libringclient
+ LIBDIR = $${LRC}/lib
+ } else {
+- INCLUDEPATH += $${LRC}/src
+- isEmpty(LRCBUILD) {
+- LIBDIR = $${LRC}/build
+- } else {
+- LIBDIR = $${LRCBUILD}
+- }
++ INCLUDEPATH += $${LRC}
++ isEmpty(LRCBUILD) {
++ LIBDIR = $${LRC}
++ } else {
++ LIBDIR = $${LRCBUILD}
++ }
+ }
+ QMAKE_RPATHDIR += $${LIBDIR}
+
+diff --git a/resources.qrc b/resources.qrc
+index 5e7aab5..d71a17d 100644
+--- a/resources.qrc
++++ b/resources.qrc
+@@ -1,141 +1,141 @@
+ <RCC>
+ <qresource prefix="/">
+- <file>images/icons/outline-info-24px.svg</file>
+- <file>images/icons/baseline-camera_alt-24px.svg</file>
+- <file>images/icons/baseline-refresh-24px.svg</file>
+- <file>images/jami_rolling_spinner.gif</file>
+- <file>images/icons/baseline-close-24px.svg</file>
+- <file>images/icons/baseline-done-24px.svg</file>
+- <file>images/icons/baseline-error_outline-24px.svg</file>
+- <file>projectcredits.html</file>
+- <file>images/ajax-loader.gif</file>
+- <file>images/default_avatar_overlay.svg</file>
+- <file>images/FontAwesome.otf</file>
+- <file>images/qrcode.png</file>
+- <file>images/jami.ico</file>
+- <file>images/jami.png</file>
+- <file>images/spike.png</file>
+- <file>images/waiting.gif</file>
+- <file>images/icons/ic_add_black_18dp_2x.png</file>
+- <file>images/icons/info-24px.svg</file>
+- <file>images/icons/backup-24px.svg</file>
+- <file>images/icons/check_box_outline_blank-24px.svg</file>
+- <file>images/icons/check_box-24px.svg</file>
+- <file>images/icons/devices-24px.svg</file>
+- <file>images/icons/ic_arrow_back_24px.svg</file>
+- <file>images/icons/ic_arrow_back_white_24dp.png</file>
+- <file>images/icons/ic_arrow_drop_down_black_9dp_2x.png</file>
+- <file>images/icons/ic_arrow_drop_down_black_18dp_2x.png</file>
+- <file>images/icons/ic_arrow_drop_up_black_9dp_2x.png</file>
+- <file>images/icons/ic_arrow_drop_up_black_18dp_2x.png</file>
+- <file>images/icons/ic_arrow_forward_white_48dp_2x.png</file>
+- <file>images/icons/ic_arrow_tab_next_black_9dp_2x.png</file>
+- <file>images/icons/ic_arrow_tab_previous_black_9dp_2x.png</file>
+- <file>images/icons/ic_block_24px.svg</file>
+- <file>images/icons/delete_forever-24px.svg</file>
+- <file>images/icons/phone_forwarded-24px.svg</file>
+- <file>images/icons/ic_chat_black_24dp_2x.png</file>
+- <file>images/icons/ic_chat_white_24dp.png</file>
+- <file>images/icons/more_vert-24px.svg</file>
+- <file>images/icons/ic_check_white_18dp_2x.png</file>
+- <file>images/icons/ic_clear_24px.svg</file>
+- <file>images/icons/ic_close_white_24dp.png</file>
+- <file>images/icons/ic_content_copy.svg</file>
+- <file>images/icons/ic_delete_black_18dp_2x.png</file>
+- <file>images/icons/ic_done_white_24dp.png</file>
+- <file>images/icons/ic_keypad.svg</file>
+- <file>images/icons/open_in_full-24px.svg</file>
+- <file>images/icons/close_fullscreen-24px.svg</file>
+- <file>images/icons/ic_group_add_white_24dp.png</file>
+- <file>images/icons/ic_mic_off_white_24dp.png</file>
+- <file>images/icons/pause_circle_outline-24px.svg</file>
+- <file>images/icons/play_circle_outline-24px.svg</file>
+- <file>images/icons/ic_pause_white_100px.png</file>
+- <file>images/icons/ic_phone_24px.svg</file>
+- <file>images/icons/groups-24px.svg</file>
+- <file>images/icons/ic_photo_camera_white_24dp_2x.png</file>
+- <file>images/icons/ic_baseline-search-24px.svg</file>
+- <file>images/icons/ic_send_24px.svg</file>
+- <file>images/icons/ic_send_white_24dp.png</file>
+- <file>images/icons/ic_settings_white_48dp_2x.png</file>
+- <file>images/icons/ic_share_black_48dp_2x.png</file>
+- <file>images/icons/ic_video_call_24px.svg</file>
+- <file>images/icons/ic_videocam_off_white_24dp.png</file>
+- <file>images/icons/ic_videocam_white.png</file>
+- <file>images/icons/ic_voicemail_white_24dp_2x.png</file>
+- <file>images/icons/ic_call_end_white_24px.svg</file>
+- <file>images/icons/round-add-24px.svg</file>
+- <file>images/icons/round-arrow_drop_down-24px.svg</file>
+- <file>images/icons/round-arrow_drop_up-24px.svg</file>
+- <file>images/icons/round-arrow_right-24px.svg</file>
+- <file>images/icons/round-close-24px.svg</file>
+- <file>images/icons/round-edit-24px.svg</file>
+- <file>images/icons/round-folder-24px.svg</file>
+- <file>images/icons/round-remove_circle-24px.svg</file>
+- <file>images/icons/round-settings-24px.svg</file>
+- <file>images/icons/round-undo-24px.svg</file>
+- <file alias="chatview.css">../lrc/src/web-chatview/chatview.css</file>
+- <file alias="chatview.html">../lrc/src/web-chatview/chatview.html</file>
+- <file alias="chatview.js">../lrc/src/web-chatview/chatview.js</file>
+- <file alias="linkify.js">../lrc/src/web-chatview/linkify.js</file>
+- <file alias="linkify-html.js">../lrc/src/web-chatview/linkify-html.js</file>
+- <file alias="linkify-string.js">../lrc/src/web-chatview/linkify-string.js</file>
+- <file alias="qwebchannel.js">../lrc/src/web-chatview/qwebchannel.js</file>
+- <file alias="chatview-windows.css">../lrc/src/web-chatview/chatview-windows.css</file>
+- <file>images/icons/round-check_circle-24px.svg</file>
+- <file>images/icons/round-error-24px.svg</file>
+- <file>images/icons/round-save_alt-24px.svg</file>
+- <file>images/jami_eclipse_spinner.gif</file>
+- <file>images/icons/ic_hide_password.png</file>
+- <file>images/icons/ic_show_password.png</file>
+- <file>images/icons/baseline-desktop_windows-24px.svg</file>
+- <file>images/icons/baseline-people-24px.svg</file>
+- <file>images/icons/ic_high_quality_24px.svg</file>
+- <file>images/icons/insert_photo-24px.svg</file>
+- <file>images/icons/screen_share-24px.svg</file>
+- <file>images/icons/round-add_a_photo-24px.svg</file>
+- <file>images/icons/ic_mic_white_24dp.png</file>
+- <file>images/icons/ic_play_white_24dp.png</file>
+- <file>images/icons/ic_voicemail_black_24dp_2x_.png</file>
+- <file>images/icons/av_icons/delete-24px.svg</file>
+- <file>images/icons/av_icons/fiber_manual_record-24px.svg</file>
+- <file>images/icons/av_icons/play_circle_outline-24px.svg</file>
+- <file>images/icons/av_icons/re-record-24px.svg</file>
+- <file>images/icons/av_icons/stop-24px-red.svg</file>
+- <file>images/icons/av_icons/pause-24px.svg</file>
+- <file>images/icons/av_icons/send-24px.svg</file>
+- <file>images/icons/av_icons/stop-24px.svg</file>
+- <file>images/icons/av_icons/mic-24px.svg</file>
+- <file>images/icons/ic_close_black_24dp.png</file>
+- <file>images/icons/extension_24dp.svg</file>
+- <file>images/icons/settings_backup_restore-black-18dp.svg</file>
+- <file>images/icons/person-24px.svg</file>
+- <file>images/icons/drafts-24px.svg</file>
+- <file>images/icons/person_add-24px.svg</file>
+- <file>images/icons/router-24px.svg</file>
+- <file>images/icons/insert_drive_file-24dp.svg</file>
+- <file>images/icons/arrow_back-white-24dp.svg</file>
+- <file>images/icons/keyboard_voice-24px.svg</file>
+- <file>images/icons/videocam-24px.svg</file>
+- <file>images/icons/qr_code-24px.svg</file>
+- <file>images/icons/content_copy-24px.svg</file>
+- <file>images/icons/videocam_off-24px.svg</file>
+- <file>images/icons/check-24px.svg</file>
+- <file>images/icons/mic_off-24px.svg</file>
+- <file>images/icons/mic-24px.svg</file>
+- <file>images/icons/group_add-24px.svg</file>
+- <file>images/icons/chat-24px.svg</file>
+- <file>images/icons/phone_paused-24px.svg</file>
+- <file>images/icons/pause-24px.svg</file>
+- <file>images/icons/arrow_drop_up-24px.svg</file>
+- <file>images/icons/arrow_drop_down-24px.svg</file>
+- <file>images/icons/expand_less-24px.svg</file>
+- <file>images/icons/expand_more-24px.svg</file>
+- <file>images/icons/delete-24px.svg</file>
+- <file>images/icons/settings_backup_restore-24px.svg</file>
+- <file>images/logo-jami-standard-coul.svg</file>
+- <file>images/logo-jami-standard-coul-white.svg</file>
+- <file>images/icons/moderator.svg</file>
+- <file>images/icons/star_outline-24px.svg</file>
++ <file>images/icons/outline-info-24px.svg</file>
++ <file>images/icons/baseline-camera_alt-24px.svg</file>
++ <file>images/icons/baseline-refresh-24px.svg</file>
++ <file>images/jami_rolling_spinner.gif</file>
++ <file>images/icons/baseline-close-24px.svg</file>
++ <file>images/icons/baseline-done-24px.svg</file>
++ <file>images/icons/baseline-error_outline-24px.svg</file>
++ <file>projectcredits.html</file>
++ <file>images/ajax-loader.gif</file>
++ <file>images/default_avatar_overlay.svg</file>
++ <file>images/FontAwesome.otf</file>
++ <file>images/qrcode.png</file>
++ <file>images/jami.ico</file>
++ <file>images/jami.png</file>
++ <file>images/spike.png</file>
++ <file>images/waiting.gif</file>
++ <file>images/icons/ic_add_black_18dp_2x.png</file>
++ <file>images/icons/info-24px.svg</file>
++ <file>images/icons/backup-24px.svg</file>
++ <file>images/icons/check_box_outline_blank-24px.svg</file>
++ <file>images/icons/check_box-24px.svg</file>
++ <file>images/icons/devices-24px.svg</file>
++ <file>images/icons/ic_arrow_back_24px.svg</file>
++ <file>images/icons/ic_arrow_back_white_24dp.png</file>
++ <file>images/icons/ic_arrow_drop_down_black_9dp_2x.png</file>
++ <file>images/icons/ic_arrow_drop_down_black_18dp_2x.png</file>
++ <file>images/icons/ic_arrow_drop_up_black_9dp_2x.png</file>
++ <file>images/icons/ic_arrow_drop_up_black_18dp_2x.png</file>
++ <file>images/icons/ic_arrow_forward_white_48dp_2x.png</file>
++ <file>images/icons/ic_arrow_tab_next_black_9dp_2x.png</file>
++ <file>images/icons/ic_arrow_tab_previous_black_9dp_2x.png</file>
++ <file>images/icons/ic_block_24px.svg</file>
++ <file>images/icons/delete_forever-24px.svg</file>
++ <file>images/icons/phone_forwarded-24px.svg</file>
++ <file>images/icons/ic_chat_black_24dp_2x.png</file>
++ <file>images/icons/ic_chat_white_24dp.png</file>
++ <file>images/icons/more_vert-24px.svg</file>
++ <file>images/icons/ic_check_white_18dp_2x.png</file>
++ <file>images/icons/ic_clear_24px.svg</file>
++ <file>images/icons/ic_close_white_24dp.png</file>
++ <file>images/icons/ic_content_copy.svg</file>
++ <file>images/icons/ic_delete_black_18dp_2x.png</file>
++ <file>images/icons/ic_done_white_24dp.png</file>
++ <file>images/icons/ic_keypad.svg</file>
++ <file>images/icons/open_in_full-24px.svg</file>
++ <file>images/icons/close_fullscreen-24px.svg</file>
++ <file>images/icons/ic_group_add_white_24dp.png</file>
++ <file>images/icons/ic_mic_off_white_24dp.png</file>
++ <file>images/icons/pause_circle_outline-24px.svg</file>
++ <file>images/icons/play_circle_outline-24px.svg</file>
++ <file>images/icons/ic_pause_white_100px.png</file>
++ <file>images/icons/ic_phone_24px.svg</file>
++ <file>images/icons/groups-24px.svg</file>
++ <file>images/icons/ic_photo_camera_white_24dp_2x.png</file>
++ <file>images/icons/ic_baseline-search-24px.svg</file>
++ <file>images/icons/ic_send_24px.svg</file>
++ <file>images/icons/ic_send_white_24dp.png</file>
++ <file>images/icons/ic_settings_white_48dp_2x.png</file>
++ <file>images/icons/ic_share_black_48dp_2x.png</file>
++ <file>images/icons/ic_video_call_24px.svg</file>
++ <file>images/icons/ic_videocam_off_white_24dp.png</file>
++ <file>images/icons/ic_videocam_white.png</file>
++ <file>images/icons/ic_voicemail_white_24dp_2x.png</file>
++ <file>images/icons/ic_call_end_white_24px.svg</file>
++ <file>images/icons/round-add-24px.svg</file>
++ <file>images/icons/round-arrow_drop_down-24px.svg</file>
++ <file>images/icons/round-arrow_drop_up-24px.svg</file>
++ <file>images/icons/round-arrow_right-24px.svg</file>
++ <file>images/icons/round-close-24px.svg</file>
++ <file>images/icons/round-edit-24px.svg</file>
++ <file>images/icons/round-folder-24px.svg</file>
++ <file>images/icons/round-remove_circle-24px.svg</file>
++ <file>images/icons/round-settings-24px.svg</file>
++ <file>images/icons/round-undo-24px.svg</file>
++ <file alias="chatview.css">/usr/include/libringclient/web-chatview/chatview.css</file>
++ <file alias="chatview.html">/usr/include/libringclient/web-chatview/chatview.html</file>
++ <file alias="chatview.js">/usr/include/libringclient/web-chatview/chatview.js</file>
++ <file alias="linkify.js">/usr/include/libringclient/web-chatview/linkify.js</file>
++ <file alias="linkify-html.js">/usr/include/libringclient/web-chatview/linkify-html.js</file>
++ <file alias="linkify-string.js">/usr/include/libringclient/web-chatview/linkify-string.js</file>
++ <file alias="qwebchannel.js">/usr/include/libringclient/web-chatview/qwebchannel.js</file>
++ <file alias="chatview-gnome.css">/usr/include/libringclient/web-chatview/chatview-gnome.css</file>
++ <file>images/icons/round-check_circle-24px.svg</file>
++ <file>images/icons/round-error-24px.svg</file>
++ <file>images/icons/round-save_alt-24px.svg</file>
++ <file>images/jami_eclipse_spinner.gif</file>
++ <file>images/icons/ic_hide_password.png</file>
++ <file>images/icons/ic_show_password.png</file>
++ <file>images/icons/baseline-desktop_windows-24px.svg</file>
++ <file>images/icons/baseline-people-24px.svg</file>
++ <file>images/icons/ic_high_quality_24px.svg</file>
++ <file>images/icons/insert_photo-24px.svg</file>
++ <file>images/icons/screen_share-24px.svg</file>
++ <file>images/icons/round-add_a_photo-24px.svg</file>
++ <file>images/icons/ic_mic_white_24dp.png</file>
++ <file>images/icons/ic_play_white_24dp.png</file>
++ <file>images/icons/ic_voicemail_black_24dp_2x_.png</file>
++ <file>images/icons/av_icons/delete-24px.svg</file>
++ <file>images/icons/av_icons/fiber_manual_record-24px.svg</file>
++ <file>images/icons/av_icons/play_circle_outline-24px.svg</file>
++ <file>images/icons/av_icons/re-record-24px.svg</file>
++ <file>images/icons/av_icons/stop-24px-red.svg</file>
++ <file>images/icons/av_icons/pause-24px.svg</file>
++ <file>images/icons/av_icons/send-24px.svg</file>
++ <file>images/icons/av_icons/stop-24px.svg</file>
++ <file>images/icons/av_icons/mic-24px.svg</file>
++ <file>images/icons/ic_close_black_24dp.png</file>
++ <file>images/icons/extension_24dp.svg</file>
++ <file>images/icons/settings_backup_restore-black-18dp.svg</file>
++ <file>images/icons/person-24px.svg</file>
++ <file>images/icons/drafts-24px.svg</file>
++ <file>images/icons/person_add-24px.svg</file>
++ <file>images/icons/router-24px.svg</file>
++ <file>images/icons/insert_drive_file-24dp.svg</file>
++ <file>images/icons/arrow_back-white-24dp.svg</file>
++ <file>images/icons/keyboard_voice-24px.svg</file>
++ <file>images/icons/videocam-24px.svg</file>
++ <file>images/icons/qr_code-24px.svg</file>
++ <file>images/icons/content_copy-24px.svg</file>
++ <file>images/icons/videocam_off-24px.svg</file>
++ <file>images/icons/check-24px.svg</file>
++ <file>images/icons/mic_off-24px.svg</file>
++ <file>images/icons/mic-24px.svg</file>
++ <file>images/icons/group_add-24px.svg</file>
++ <file>images/icons/chat-24px.svg</file>
++ <file>images/icons/phone_paused-24px.svg</file>
++ <file>images/icons/pause-24px.svg</file>
++ <file>images/icons/arrow_drop_up-24px.svg</file>
++ <file>images/icons/arrow_drop_down-24px.svg</file>
++ <file>images/icons/expand_less-24px.svg</file>
++ <file>images/icons/expand_more-24px.svg</file>
++ <file>images/icons/delete-24px.svg</file>
++ <file>images/icons/settings_backup_restore-24px.svg</file>
++ <file>images/logo-jami-standard-coul.svg</file>
++ <file>images/logo-jami-standard-coul-white.svg</file>
++ <file>images/icons/moderator.svg</file>
++ <file>images/icons/star_outline-24px.svg</file>
+ </qresource>
+ </RCC>
+diff --git a/src/accountadapter.cpp b/src/accountadapter.cpp
+index bb1bb7c..e200832 100644
+--- a/src/accountadapter.cpp
++++ b/src/accountadapter.cpp
+@@ -28,7 +28,6 @@
+ #include <QtConcurrent/QtConcurrent>
+
+ #undef REGISTERED
+-#include "../daemon/src/dring/account_const.h"
+
+ AccountAdapter::AccountAdapter(QObject* parent)
+ : QmlAdapterBase(parent)
+@@ -131,10 +130,8 @@ AccountAdapter::createJamiAccount(QString registeredName,
+
+ QtConcurrent::run([settings] {
+ QMap<QString, QString> additionalAccountConfig;
+- additionalAccountConfig.insert(DRing::Account::ConfProperties::Ringtone::PATH,
+- Utils::GetRingtonePath());
+- additionalAccountConfig.insert(DRing::Account::ConfProperties::ISRENDEZVOUS,
+- settings["isRendezVous"].toString());
++ additionalAccountConfig.insert("Account.ringtonePath", Utils::GetRingtonePath());
++ additionalAccountConfig.insert("Account.rendezVous", settings["isRendezVous"].toString());
+
+ LRCInstance::accountModel().createNewAccount(lrc::api::profile::Type::RING,
+ settings["alias"].toString(),
+@@ -172,8 +169,7 @@ AccountAdapter::createSIPAccount(const QVariantMap& settings)
+
+ QtConcurrent::run([settings] {
+ QMap<QString, QString> additionalAccountConfig;
+- additionalAccountConfig.insert(DRing::Account::ConfProperties::Ringtone::PATH,
+- Utils::GetRingtonePath());
++ additionalAccountConfig.insert("Account.ringtonePath", Utils::GetRingtonePath());
+
+ LRCInstance::accountModel().createNewAccount(lrc::api::profile::Type::SIP,
+ settings["alias"].toString(),
+@@ -205,8 +201,7 @@ AccountAdapter::createJAMSAccount(const QVariantMap& settings)
+
+ QtConcurrent::run([settings] {
+ QMap<QString, QString> additionalAccountConfig;
+- additionalAccountConfig.insert(DRing::Account::ConfProperties::Ringtone::PATH,
+- Utils::GetRingtonePath());
++ additionalAccountConfig.insert("Account.ringtonePath", Utils::GetRingtonePath());
+
+ LRCInstance::accountModel().connectToAccountManager(settings["username"].toString(),
+ settings["password"].toString(),
+diff --git a/src/lrcinstance.h b/src/lrcinstance.h
+index fc0efe9..e06d9d1 100644
+--- a/src/lrcinstance.h
++++ b/src/lrcinstance.h
+@@ -30,7 +30,7 @@
+ #include "appsettingsmanager.h"
+ #include "utils.h"
+
+-#include "api/account.h"
++#include <api/account.h>
+ #include "api/avmodel.h"
+ #include "api/pluginmodel.h"
+ #include "api/behaviorcontroller.h"
+diff --git a/src/messagesadapter.cpp b/src/messagesadapter.cpp
+index 819285b..08b20b2 100644
+--- a/src/messagesadapter.cpp
++++ b/src/messagesadapter.cpp
+@@ -27,6 +27,7 @@
+ #include "qtutils.h"
+ #include "utils.h"
+ #include "webchathelpers.h"
++#include "api/chatview.h"
+
+ #include <QApplication>
+ #include <QClipboard>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac7eefbc0f88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Nick Econopouly <wry at mm dot st>
+pkgname=jami-client-qt-git
+pkgver=r271.7168d9f
+pkgrel=1
+pkgdesc="Free and universal communication platform which preserves the users’ privacy and freedoms (QT client)"
+arch=('x86_64')
+provides=('jami-client-qt')
+url="https://git.jami.net/savoirfairelinux/jami-client-qt"
+license=('GPL3')
+depends=('jami-daemon-git' 'libjamiclient-git' 'qt5-base')
+makedepends=('git' )
+source=("git+$url.git" '0000.patch' )
+sha512sums=(SKIP 5f0c26009723ef24867cc140c6284fc0e432a9817358e2ce4f912ab9471c5b5c818af7d3b90103659959c8fa810da5dd500722079ad7b99e4666d501b7080a55 )
+
+pkgver() {
+ cd $srcdir/jami-client-qt
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+# git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $srcdir/jami-client-qt
+ git apply ../0000.patch
+ mkdir -p build
+}
+
+build() {
+ cd jami-client-qt/build
+ /usr/bin/qmake-qt5 ../jami-qt.pro "LRC=/usr/include/libringclient/"
+ make -j4
+}
+
+
+# package() {
+# cd "$srcdir/${pkgname%-VCS}"
+# make DESTDIR="$pkgdir/" install
+# }
+
+package() {
+ cd jami-client-qt/build
+ # make DESTDIR="${pkgdir}/" install # waiting on upstream fixes
+ install -Dm755 ./jami-qt "$pkgdir/usr/bin/jami-qt"
+ install -Dm644 ../License.rtf "$pkgdir/usr/share/licenses/jami-client-qt/LICENSE" # waiting on an upstream rename
+}