summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Econopouly2021-11-19 11:49:14 -0500
committerNick Econopouly2021-11-19 11:49:14 -0500
commitbcaacb6a5574fa6b963572fc44e5451307f27567 (patch)
tree504500130b9538de6fd510f96689e870d89a25ac
parentea94ce2e50c0ce0183c26d9f3c992f3de5bbca4a (diff)
downloadaur-bcaacb6a5574fa6b963572fc44e5451307f27567.tar.gz
Rename to jami-qt, use cmake arguments instead of shell commands
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ebbb35476d8..cfbb1a09aee5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jami-client-qt-git
pkgdesc = A free and private communication platform (QT client)
- pkgver = r683.3dd206e
+ pkgver = r701.0a7aaa5
pkgrel = 1
url = https://git.jami.net/savoirfairelinux/jami-client-qt
arch = x86_64
@@ -15,9 +15,10 @@ pkgbase = jami-client-qt-git
depends = qt5-quickcontrols2
depends = qt5-svg
depends = qt5-webengine
- provides = jami-client-qt
+ provides = jami-qt
conflicts = jami-gnome-git
conflicts = jami-gnome
+ conflicts = jami-qt
source = git+https://git.jami.net/savoirfairelinux/jami-client-qt.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 01d6a0766812..8d634c844e18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Nick Econopouly <wry at mm dot st>
pkgname=jami-client-qt-git
-pkgver=r683.3dd206e
+pkgver=r701.0a7aaa5
pkgrel=1
pkgdesc="A free and private communication platform (QT client)"
arch=('x86_64')
-provides=('jami-client-qt')
+provides=('jami-qt')
url="https://git.jami.net/savoirfairelinux/jami-client-qt"
license=('GPL3')
depends=('jami-daemon-git' 'libjamiclient-git' 'qt5-base' 'libnm' 'qrencode' 'libnotify' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-webengine')
makedepends=('git' )
-conflicts=('jami-gnome-git' 'jami-gnome')
+conflicts=('jami-gnome-git' 'jami-gnome' 'jami-qt')
source=("git+$url.git")
sha512sums=(SKIP)
@@ -19,15 +19,13 @@ pkgver() {
}
build() {
- cd jami-client-qt
- mkdir -p build
- cd build
- # /usr is necessary for Arch; see https://archlinux.org/news/binaries-move-to-usrbin-requiring-update-intervention/
- cmake .. -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
- make -j`nproc` # -j`nproc` uses as many cores as possible to speed up the build
+ cmake -B build -S jami-client-qt \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None \
+ -Wno-dev
+ make -C build -j`nproc` # -j`nproc` uses as many cores as possible to speed up the build
}
package() {
- cd jami-client-qt/build
- make install
+ make -C build DESTDIR="${pkgdir}" install
}