summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Stalder2020-11-23 11:12:58 +0100
committerNicolas Stalder2020-11-23 11:13:39 +0100
commit4fd93174cb01083adc7df9db4477b19808a8746c (patch)
treea8722190bb1f35939de4315a87d16d412f99bfc9
parentb2ea1ec8d86eab73e1558db5a9716c419af619e4 (diff)
downloadaur-4fd93174cb01083adc7df9db4477b19808a8746c.tar.gz
:bookmark: jamm-bin 0.5.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile17
-rw-r--r--PKGBUILD12
3 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 693189f1a157..02ed4d060084 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jamm-bin
pkgdesc = Jamm is a lightweight video collaboration app for remote teams
- pkgver = 0.3.59
+ pkgver = 0.5.0
pkgrel = 1
url = https://jamm.app/download
arch = x86_64
@@ -22,8 +22,8 @@ pkgbase = jamm-bin
depends = libappindicator-gtk3
provides = jamm
conflicts = jamm
- source = jamm-0.3.59.pacman::https://jamm.app/api/download/pacman?channel=alpha
- sha256sums = a0b9999ce9385844b93d841a787e7b80f2166b03fcf38f858eab4e3383d929c5
+ source = jamm-0.5.0.pacman::https://jamm.app/api/download/pacman?channel=alpha
+ sha256sums = 224f2e492f39a09435bcd5d890d58f93f278cce4d1f48f8d5b28ef979d7d7279
pkgname = jamm-bin
diff --git a/Makefile b/Makefile
index 05f4e5651d0d..4573f5dda205 100644
--- a/Makefile
+++ b/Makefile
@@ -1,10 +1,17 @@
+PKG := jamm
+
+build:
+ makepkg -f
+
+install:
+ yes | makepkg -i
+
+clean:
+ rm -rf pkg src
+ rm -rf $(PKG)*
+
update-srcinfo:
makepkg --printsrcinfo > .SRCINFO
generate-checksums:
makepkg -g -f -p PKGBUILD
-
-clean:
- rm -f *.pacman
- rm -f *.tar.*
- rm -rf pkg src
diff --git a/PKGBUILD b/PKGBUILD
index d2a4022e20b5..4dd38c29ad9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
# symlink in post_install, and hence does not remove it properly
# when it gets removed due to our conflicts entry.
pkgname=jamm-bin
-pkgver=0.3.59
+pkgver=0.5.0
pkgrel=1
pkgdesc="Jamm is a lightweight video collaboration app for remote teams"
-arch=('x86_64')
+arch=("x86_64")
url="https://jamm.app/download"
-license=('custom')
+license=("custom")
makedepends=("wget")
depends=(
"c-ares" ffmpeg gtk3 http-parser libevent libvpx libxslt libxss
@@ -19,11 +19,11 @@ provides=("jamm")
conflicts=("jamm")
DLAGENTS=("https::/usr/bin/wget --content-disposition %u")
source=(
- # -> "https://graffiti-app-one-tusk.s3-us-west-1.amazonaws.com/alpha/jamm-0.3.59.pacman"
- "jamm-0.3.59.pacman::https://jamm.app/api/download/pacman?channel=alpha"
+ # -> "https://graffiti-app-one-tusk.s3-us-west-1.amazonaws.com/alpha/jamm-${pkgver}.pacman"
+ "jamm-${pkgver}.pacman::https://jamm.app/api/download/pacman?channel=alpha"
)
sha256sums=(
- "a0b9999ce9385844b93d841a787e7b80f2166b03fcf38f858eab4e3383d929c5"
+ "224f2e492f39a09435bcd5d890d58f93f278cce4d1f48f8d5b28ef979d7d7279"
)
prepare() {