summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Stalder2020-10-15 11:17:27 +0200
committerNicolas Stalder2020-10-15 11:17:27 +0200
commitb2ea1ec8d86eab73e1558db5a9716c419af619e4 (patch)
tree93c8030bfbb82e1f08296658b9edf36f66784ac7
downloadaur-b2ea1ec8d86eab73e1558db5a9716c419af619e4.tar.gz
0.35.59-1
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore4
-rw-r--r--Makefile10
-rw-r--r--PKGBUILD40
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..693189f1a157
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = jamm-bin
+ pkgdesc = Jamm is a lightweight video collaboration app for remote teams
+ pkgver = 0.3.59
+ pkgrel = 1
+ url = https://jamm.app/download
+ arch = x86_64
+ license = custom
+ makedepends = wget
+ depends = c-ares
+ depends = ffmpeg
+ depends = gtk3
+ depends = http-parser
+ depends = libevent
+ depends = libvpx
+ depends = libxslt
+ depends = libxss
+ depends = minizip
+ depends = nss
+ depends = re2
+ depends = snappy
+ depends = libnotify
+ depends = libappindicator-gtk3
+ provides = jamm
+ conflicts = jamm
+ source = jamm-0.3.59.pacman::https://jamm.app/api/download/pacman?channel=alpha
+ sha256sums = a0b9999ce9385844b93d841a787e7b80f2166b03fcf38f858eab4e3383d929c5
+
+pkgname = jamm-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..834b23b44e5d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.*
+*.pacman
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..05f4e5651d0d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+update-srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+generate-checksums:
+ makepkg -g -f -p PKGBUILD
+
+clean:
+ rm -f *.pacman
+ rm -f *.tar.*
+ rm -rf pkg src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2a4022e20b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Nicolas Stalder <n+archlinux@stalder.io>
+#
+# Note that the upstream package creates the /usr/bin/jamm
+# symlink in post_install, and hence does not remove it properly
+# when it gets removed due to our conflicts entry.
+pkgname=jamm-bin
+pkgver=0.3.59
+pkgrel=1
+pkgdesc="Jamm is a lightweight video collaboration app for remote teams"
+arch=('x86_64')
+url="https://jamm.app/download"
+license=('custom')
+makedepends=("wget")
+depends=(
+ "c-ares" ffmpeg gtk3 http-parser libevent libvpx libxslt libxss
+ minizip nss re2 snappy libnotify "libappindicator-gtk3"
+)
+provides=("jamm")
+conflicts=("jamm")
+DLAGENTS=("https::/usr/bin/wget --content-disposition %u")
+source=(
+ # -> "https://graffiti-app-one-tusk.s3-us-west-1.amazonaws.com/alpha/jamm-0.3.59.pacman"
+ "jamm-0.3.59.pacman::https://jamm.app/api/download/pacman?channel=alpha"
+)
+sha256sums=(
+ "a0b9999ce9385844b93d841a787e7b80f2166b03fcf38f858eab4e3383d929c5"
+)
+
+prepare() {
+ # SUID chrome-sandbox for Electron 5+
+ chmod 4755 $srcdir/opt/Jamm/chrome-sandbox
+}
+
+package() {
+ cp -a $srcdir/opt $pkgdir
+ cp -a $srcdir/usr $pkgdir
+ mkdir $pkgdir/usr/bin
+ ln -s /opt/Jamm/jamm $pkgdir/usr/bin/jamm
+ echo
+}