summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Martin2017-06-04 21:14:51 -0500
committerStephen Martin2017-06-04 21:14:51 -0500
commit1ea970d2a93025a44881f80358f90adbcf8c68ff (patch)
tree364ec8b8db1f372d01934cc74d72a984d0a2af9a
downloadaur-1ea970d2a93025a44881f80358f90adbcf8c68ff.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD57
-rw-r--r--rinclude.patch28
3 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93453f870b42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Mon Jun 5 02:14:40 UTC 2017
+pkgbase = jamovi-git
+ pkgdesc = Open Source Software to bridge the gap between researcher and statistician
+ pkgver = r481.e08f52f
+ pkgrel = 1
+ arch = any
+ license = git
+ makedepends = boost
+ makedepends = npm
+ makedepends = cython
+ depends = electron
+ depends = python
+ depends = python-protobuf
+ depends = python-tornado
+ depends = python-nanomsg
+ depends = python-yaml
+ depends = boost-libs
+ provides = jamovi
+ conflicts = jamovi
+ source = git+https://github.com/jamovi/jamovi.git
+ source = rinclude.patch
+ md5sums = SKIP
+ md5sums = 60a8bd543e49debf6d917afde56f60c3
+
+pkgname = jamovi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c23616374417
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=jamovi-git # '-bzr', '-git', '-hg' or '-svn'
+_pkgname=jamovi
+pkgver=r481.e08f52f
+pkgrel=1
+pkgdesc="Open Source Software to bridge the gap between researcher and statistician"
+arch=('any')
+url=""
+license=('git')
+depends=('electron' 'python' 'python-protobuf' 'python-tornado' 'python-nanomsg' 'python-yaml' 'boost-libs')
+makedepends=('boost' 'npm' 'cython') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+https://github.com/jamovi/jamovi.git
+ "rinclude.patch")
+md5sums=('SKIP'
+ '60a8bd543e49debf6d917afde56f60c3')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 <$srcdir/rinclude.patch
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ # Electron
+ cd electron
+ npm install
+ # Server
+ cd ../server
+ python setup.py build_ext --inplace
+ # Client
+ cd ../client
+ npm install
+ # Engine
+ cd ../engine
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p $pkgdir/usr/lib/$_pkgname/bin
+ mkdir -p $pkgdir/usr/lib/$_pkgname/Resources
+}
diff --git a/rinclude.patch b/rinclude.patch
new file mode 100644
index 000000000000..e64bbc709957
--- /dev/null
+++ b/rinclude.patch
@@ -0,0 +1,28 @@
+diff --git a/engine/Makefile b/engine/Makefile
+index da42f79..83fd006 100644
+--- a/engine/Makefile
++++ b/engine/Makefile
+@@ -36,7 +36,7 @@ else
+ ifeq ($(os),Linux)
+ R_HOME = /usr/lib/R
+ INCLUDES += -I/usr/share/R/include
+- LIBS = -L$(R_HOME)/library/RInside/lib -L$(R_HOME)/site-library/RInside/lib \
++ LIBS = -L$(R_HOME)/library/RInside/lib -L$(R_HOME)/site-library/RInside/lib -L$(R_HOME)/lib \
+ -lboost_filesystem \
+ -lboost_system \
+ -lpthread \
+@@ -53,12 +53,13 @@ endif
+ endif
+
+ INCLUDES += \
++ -I/usr/include/R \
+ -I$(SRCDIR)/../../include \
+ -I$(SRCDIR)/../../../include \
+ -I$(SRCDIR)/../server/jamovi/common \
+ -I$(R_HOME)/include \
+ -I$(R_HOME)/library/RInside/include -I$(R_HOME)/site-library/RInside/include \
+- -I$(R_HOME)/library/Rcpp/include -I$(R_HOME)/site-library/Rcpp/include
++ -I$(R_HOME)/library/Rcpp/include -I$(R_HOME)/site-library/Rcpp/include
+
+ LIBS += -lR -lnanomsg -lprotobuf -lRInside
+