summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Martin2017-11-14 21:12:55 -0600
committerStephen Martin2017-11-14 21:12:55 -0600
commit230d164eff975209359cef24e319d0373e747719 (patch)
tree1a904180c90c0488f14d9312046054b35d87de16
parent410b9eccd667f74cec0e9171215c85e24d56432f (diff)
downloadaur-230d164eff975209359cef24e319d0373e747719.tar.gz
Fixed errors in compilation.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--rinclude.patch23
3 files changed, 25 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62edb6b0fc53..586278f76333 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Nov 13 18:07:08 UTC 2017
+# Wed Nov 15 03:12:44 UTC 2017
pkgbase = jamovi-git
pkgdesc = Open Source Software to bridge the gap between researcher and statistician
- pkgver = r659.a85996f
+ pkgver = r664.c538fa4
pkgrel = 1
url = https://www.jamovi.org/
arch = any
@@ -31,7 +31,7 @@ pkgbase = jamovi-git
md5sums = SKIP
md5sums = 207b3012a3235d9f9a0ec12fa4027694
md5sums = 38fec18885de4ecbb91aef1f201c20d7
- md5sums = 0981857a116ed685d3b7d91214efd6a9
+ md5sums = f873dbb9ac296cd6f563ed03f018fe97
pkgname = jamovi-git
diff --git a/PKGBUILD b/PKGBUILD
index 2107e8803062..d00802057f1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stephen Martin <stephenSRMMartin at gmail dot com>
pkgname=jamovi-git
_pkgname=jamovi
-pkgver=r659.a85996f
+pkgver=r664.c538fa4
pkgrel=1
pkgdesc="Open Source Software to bridge the gap between researcher and statistician"
arch=('any')
@@ -19,7 +19,7 @@ source=(git+https://github.com/jamovi/jamovi.git
md5sums=('SKIP'
'207b3012a3235d9f9a0ec12fa4027694'
'38fec18885de4ecbb91aef1f201c20d7'
- '0981857a116ed685d3b7d91214efd6a9')
+ 'f873dbb9ac296cd6f563ed03f018fe97')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -93,4 +93,8 @@ package() {
# Version
cp version $pkgdir/usr/lib/$_pkgname/Resources/jamovi
+
+# # Add link to R home
+# mkdir $pkgdir/usr/lib/$_pkgname/lib
+# ln -s /usr/lib/R $pkgdir/usr/lib/$_pkgname/lib
}
diff --git a/rinclude.patch b/rinclude.patch
index 0a00c5e822f6..d4a8ac71155a 100644
--- a/rinclude.patch
+++ b/rinclude.patch
@@ -1,15 +1,24 @@
diff --git a/engine/Makefile b/engine/Makefile
-index 040936b..741fce2 100644
+index e7dce5b..7ec569f 100644
--- a/engine/Makefile
+++ b/engine/Makefile
-@@ -36,8 +36,8 @@ ifeq ($(os),OSX)
+@@ -35,9 +35,9 @@ ifeq ($(os),OSX)
+
else
ifeq ($(os),Linux)
- R_HOME = /usr/lib/R
-- INCLUDES += -I/usr/share/R/include
-- LIBS = -L$(SRCDIR)/../../modules/base/R/RInside/lib \
-+ INCLUDES += -I/usr/share/R/include -I/usr/include/R
-+ LIBS = -L$(SRCDIR)/../../modules/base/R/RInside/lib -L$(R_HOME)/lib -L$(R_HOME)/library/RInside/lib \
+- R_HOME = $(SRCDIR)/../../../lib/R
++ R_HOME = /usr/lib/R
+ LIBS = -L$(R_HOME)/lib \
+- -L$(SRCDIR)/../../modules/base/R/RInside/lib \
++ -L$(R_HOME)/library/RInside/lib \
-lboost_filesystem \
-lboost_system \
-lpthread \
+@@ -65,6 +65,7 @@ INCLUDES += \
+ -I$(SRCDIR)/../../../include \
+ -I$(SRCDIR)/../server/jamovi/common \
+ -I$(R_HOME)/include \
++ -I /usr/include/R \
+ -I$(SRCDIR)/../../modules/base/R/RInside/include \
+ -I$(SRCDIR)/../../modules/base/R/Rcpp/include \
+ -I$(R_HOME)/library/RInside/include \