summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Martin2017-09-25 22:14:53 -0500
committerStephen Martin2017-09-25 22:14:53 -0500
commit92faa2bd56199d2ab5e51c59eb8813a4fb084e74 (patch)
tree975d930db08a07ba3a1e99786badc2876988064d
parentb90658eb9601a3da53dd236f73e06b113e2029e7 (diff)
downloadaur-92faa2bd56199d2ab5e51c59eb8813a4fb084e74.tar.gz
Fixed compile bug
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--rinclude.patch27
3 files changed, 12 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8be8fe3653c0..ca43ee081852 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Sep 7 17:22:57 UTC 2017
+# Tue Sep 26 03:14:44 UTC 2017
pkgbase = jamovi-git
pkgdesc = Open Source Software to bridge the gap between researcher and statistician
- pkgver = r609.e7d98db
+ pkgver = r623.387b8be
pkgrel = 1
url = https://www.jamovi.org/
arch = any
@@ -29,7 +29,7 @@ pkgbase = jamovi-git
md5sums = SKIP
md5sums = 207b3012a3235d9f9a0ec12fa4027694
md5sums = 38fec18885de4ecbb91aef1f201c20d7
- md5sums = 60a8bd543e49debf6d917afde56f60c3
+ md5sums = 0981857a116ed685d3b7d91214efd6a9
pkgname = jamovi-git
diff --git a/PKGBUILD b/PKGBUILD
index 6c0119842fb7..2e27ab55b41a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stephen Martin <stephenSRMMartin at gmail dot com>
pkgname=jamovi-git
_pkgname=jamovi
-pkgver=r609.e7d98db
+pkgver=r623.387b8be
pkgrel=1
pkgdesc="Open Source Software to bridge the gap between researcher and statistician"
arch=('any')
@@ -19,7 +19,7 @@ source=(git+https://github.com/jamovi/jamovi.git
md5sums=('SKIP'
'207b3012a3235d9f9a0ec12fa4027694'
'38fec18885de4ecbb91aef1f201c20d7'
- '60a8bd543e49debf6d917afde56f60c3')
+ '0981857a116ed685d3b7d91214efd6a9')
pkgver() {
cd "$srcdir/${pkgname%-git}"
diff --git a/rinclude.patch b/rinclude.patch
index e64bbc709957..0a00c5e822f6 100644
--- a/rinclude.patch
+++ b/rinclude.patch
@@ -1,28 +1,15 @@
diff --git a/engine/Makefile b/engine/Makefile
-index da42f79..83fd006 100644
+index 040936b..741fce2 100644
--- a/engine/Makefile
+++ b/engine/Makefile
-@@ -36,7 +36,7 @@ else
+@@ -36,8 +36,8 @@ ifeq ($(os),OSX)
+ else
ifeq ($(os),Linux)
R_HOME = /usr/lib/R
- INCLUDES += -I/usr/share/R/include
-- LIBS = -L$(R_HOME)/library/RInside/lib -L$(R_HOME)/site-library/RInside/lib \
-+ LIBS = -L$(R_HOME)/library/RInside/lib -L$(R_HOME)/site-library/RInside/lib -L$(R_HOME)/lib \
+- INCLUDES += -I/usr/share/R/include
+- LIBS = -L$(SRCDIR)/../../modules/base/R/RInside/lib \
++ INCLUDES += -I/usr/share/R/include -I/usr/include/R
++ LIBS = -L$(SRCDIR)/../../modules/base/R/RInside/lib -L$(R_HOME)/lib -L$(R_HOME)/library/RInside/lib \
-lboost_filesystem \
-lboost_system \
-lpthread \
-@@ -53,12 +53,13 @@ endif
- endif
-
- INCLUDES += \
-+ -I/usr/include/R \
- -I$(SRCDIR)/../../include \
- -I$(SRCDIR)/../../../include \
- -I$(SRCDIR)/../server/jamovi/common \
- -I$(R_HOME)/include \
- -I$(R_HOME)/library/RInside/include -I$(R_HOME)/site-library/RInside/include \
-- -I$(R_HOME)/library/Rcpp/include -I$(R_HOME)/site-library/Rcpp/include
-+ -I$(R_HOME)/library/Rcpp/include -I$(R_HOME)/site-library/Rcpp/include
-
- LIBS += -lR -lnanomsg -lprotobuf -lRInside
-