summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commitea3d49fa0b256aedc334fb858e8b88a8b38d9888 (patch)
treefd71f4fa469c8eb400421b3bbea8c72eb90329bc
downloadaur-ea3d49fa0b256aedc334fb858e8b88a8b38d9888.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.AURINFO18
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
3 files changed, 66 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..489200206c8c
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,18 @@
+pkgbase = janet
+ pkgdesc = A Digital life assistant (DLA) that provides a framework allowing various components to communicate, inspired by Iron Man's JARVIS
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = http://sites.google.com/site/projectjanet
+ arch = i686
+ arch = x86_64
+ license = CCPL:by-nc
+ license = GPL
+ depends = monodevelop
+ depends = festival
+ depends = simon
+ optdepends = htk: For customizing simon
+ source = http://sourceforge.net/projects/project-janet/files/Binaries/Bin.tar.gz
+ sha256sums = f0281fa070afc61d7f2ca2f8eac0cba782b5167b2de93a6267b29242ee40877b
+
+pkgname = janet
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..489200206c8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = janet
+ pkgdesc = A Digital life assistant (DLA) that provides a framework allowing various components to communicate, inspired by Iron Man's JARVIS
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = http://sites.google.com/site/projectjanet
+ arch = i686
+ arch = x86_64
+ license = CCPL:by-nc
+ license = GPL
+ depends = monodevelop
+ depends = festival
+ depends = simon
+ optdepends = htk: For customizing simon
+ source = http://sourceforge.net/projects/project-janet/files/Binaries/Bin.tar.gz
+ sha256sums = f0281fa070afc61d7f2ca2f8eac0cba782b5167b2de93a6267b29242ee40877b
+
+pkgname = janet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c42cd8b7482
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Cody Lee <platinummonkey at archlinux dot us>
+
+pkgname=janet
+pkgver=0.2.4
+pkgrel=1
+pkgdesc="A Digital life assistant (DLA) that provides a framework allowing various components to communicate, inspired by Iron Man's JARVIS"
+arch=('i686' 'x86_64')
+url="http://sites.google.com/site/projectjanet"
+license=('CCPL:by-nc' 'GPL')
+depends=('monodevelop' 'festival' 'simon')
+optdepends=('htk: For customizing simon')
+source=(http://sourceforge.net/projects/project-janet/files/Binaries/Bin.tar.gz)
+sha256sums=('f0281fa070afc61d7f2ca2f8eac0cba782b5167b2de93a6267b29242ee40877b')
+
+package() {
+ cd "${srcdir}"
+
+ mkdir -p /usr/share/$pkgname/scripts
+ cp -R ./* /usr/share/$pkgname/.
+
+# create jaNET launcher script
+ cat <<EOF >>/usr/bin/$pkgname
+#!/bin/sh
+/usr/bin/mono /usr/share/$pkgname/jaNET.exe "\$\@"
+EOF
+
+ chmod a+x /usr/bin/$pkgname
+ echo -e 'Take a look at the http://wiki.archlinux.org/index.php/JaNET, to see voice festival and simon settings'
+}