summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrayJack2020-05-20 00:14:57 -0300
committerGrayJack2020-05-20 00:14:57 -0300
commite7a2a3546276805ff08e7906a0654945e9ceb437 (patch)
treee4454352911a61875951eca1bd749478debae8fe
parent58ecbeda47fd49f51d67f9cc91db5287ee8b4c4f (diff)
downloadaur-e7a2a3546276805ff08e7906a0654945e9ceb437.tar.gz
Remove patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--dynamic_link.patch11
3 files changed, 4 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7703e93591f..81d5bdb4f457 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = janet-lang-git
pkgdesc = A dynamic Lisp dialect and bytecode vm
- pkgver = 1.10.0.r2144.b7cfc08
+ pkgver = 1.10.0.r2157.6173384
pkgrel = 1
url = https://janet-lang.org/
arch = arm
@@ -16,9 +16,7 @@ pkgbase = janet-lang-git
options = staticlibs
options = !strip
source = git+https://github.com/janet-lang/janet.git
- source = dynamic_link.patch
sha256sums = SKIP
- sha256sums = e7798771a8622d7ecaa1097c389365cbd4c4eb4b52c8fbce91c697a89a62b6dd
pkgname = janet-lang-git
diff --git a/PKGBUILD b/PKGBUILD
index 62099bcbb304..4a0d10fe23f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=janet
pkgname=janet-lang-git
-pkgver=1.10.0.r2144.b7cfc08
+pkgver=1.10.0.r2157.6173384
pkgrel=1
pkgdesc="A dynamic Lisp dialect and bytecode vm"
arch=('arm' 'armv6h' 'armv7h' 'i686' 'x86_64' 'aarch64')
@@ -12,10 +12,8 @@ depends=()
makedepends=('git')
provides=('janet')
conflicts=('janet-lang')
-source=("git+https://github.com/janet-lang/janet.git"
- "dynamic_link.patch")
-sha256sums=('SKIP'
- 'e7798771a8622d7ecaa1097c389365cbd4c4eb4b52c8fbce91c697a89a62b6dd')
+source=("git+https://github.com/janet-lang/janet.git")
+sha256sums=('SKIP')
options=('staticlibs' '!strip')
pkgver() {
@@ -30,11 +28,6 @@ build() {
make PREFIX="/usr" $janet_build
make PREFIX="/usr" build/janet.pc
make PREFIX="/usr" docs
-
- # Very very very ugly patch
- # Temporary till I (or anyone) find the reason why the static linking isn't
- # working as expected
- patch jpm ../dynamic_link.patch
}
package() {
diff --git a/dynamic_link.patch b/dynamic_link.patch
deleted file mode 100644
index 1d8baa85239a..000000000000
--- a/dynamic_link.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Source/janet/jpm 2020-05-17 00:07:03.713960777 -0300
-+++ /bin/jpm 2020-05-19 01:39:24.817855624 -0300
-@@ -423,7 +423,7 @@
- (error "cannot find libpath: provide --libpath or JANET_LIBPATH"))
- (string (dyn :libpath JANET_LIBPATH)
- sep
-- (if is-win "libjanet.lib" "libjanet.a")))
-+ (if is-win "libjanet.lib" "libjanet.so")))
-
- (defn- win-import-library
- "On windows, an import library is needed to link to a dll statically."