summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Chung2020-05-11 15:29:21 +1000
committerCaleb Maclennan2020-05-11 14:23:16 +0300
commitaeb3c47be1f54397150aa23e962dc6f918b66d4b (patch)
tree6f4bf3a7ad77a17b9f032527402a60aee73cae3b
parenta117eab02aa3178e83f649a05c6c8b70586a9bee (diff)
downloadaur-aeb3c47be1f54397150aa23e962dc6f918b66d4b.tar.gz
Dependencies cleanup + assorted tweaks
* Enable most features in configure * Don't create HOME
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD49
-rw-r--r--janus.conf2
3 files changed, 57 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4246023986a5..96bb1e95c6e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,46 +1,59 @@
pkgbase = janus-gateway
pkgdesc = Janus WebRTC Server
pkgver = 0.9.4
- pkgrel = 2
+ pkgrel = 3
url = http://janus.conf.meetecho.com
arch = x86_64
arch = i686
license = GPL3
- makedepends = cmake
+ makedepends = curl
+ makedepends = ffmpeg
makedepends = gengetopt
- depends = curl
- depends = ffmpeg
+ makedepends = libogg
+ makedepends = librabbitmq-c
+ makedepends = libwebsockets
+ makedepends = lua
+ makedepends = nanomsg
+ makedepends = opus
+ makedepends = paho-mqtt-c-git
+ makedepends = sofia-sip
depends = glib2
depends = jansson
depends = libconfig
depends = libmicrohttpd
depends = libnice
- depends = libogg
- depends = librabbitmq-c
depends = libsrtp
depends = libusrsctp-git
- depends = libwebsockets
- depends = lua
- depends = nanomsg
- depends = paho-mqtt-c-git
depends = openssl
- depends = opus
- depends = sofia-sip
+ optdepends = libwebsockets: WebSockets support for Janus API
+ optdepends = librabbitmq-c: RabbitMQ support for the Janus API or events
+ optdepends = paho-mqtt-c-git: MQTT support for the Janus API or events
+ optdepends = nanomsg: Nanomsg support for the Janus API
+ optdepends = curl: TURN REST API support, RTSP support in Streaming/Event Handler plugin
+ optdepends = sofia-sip: SIP plugin
+ optdepends = opus: Bridge plugin
+ optdepends = libogg: Voicemail plugin and/or post-processor
+ optdepends = ffmpeg: Post-processor
+ optdepends = lua: Lua plugin
source = janus-gateway-0.9.4.tar.gz::https://github.com/meetecho/janus-gateway/archive/v0.9.4.tar.gz
source = janus.service
source = janus.conf
sha256sums = 97f3653066748f4f2888b6571d28ecf400653c86523cb1c1ed42ba065649cba9
sha256sums = cf2b6c8fdcd60ccfa179c4cd207a23ee7edfee90588c2c3847aa6cda418bed7f
- sha256sums = 60f6aef6b082f6c3f15803f7f727a2a023d6d18668e309571af3dff55bce1e92
+ sha256sums = ad965a52fbe23e23a92b878bb08fa4c815b15a7569776882b21ff83c988dbd3e
pkgname = janus-gateway
backup = etc/janus/janus.eventhandler.mqttevh.jcfg
+ backup = etc/janus/janus.eventhandler.nanomsgevh.jcfg
backup = etc/janus/janus.eventhandler.rabbitmqevh.jcfg
backup = etc/janus/janus.eventhandler.sampleevh.jcfg
backup = etc/janus/janus.eventhandler.wsevh.jcfg
backup = etc/janus/janus.jcfg
+ backup = etc/janus/janus.logger.jsonlog.jcfg
backup = etc/janus/janus.plugin.audiobridge.jcfg
+ backup = etc/janus/janus.plugin.duktape.jcfg
backup = etc/janus/janus.plugin.echotest.jcfg
+ backup = etc/janus/janus.plugin.lua.jcfg
backup = etc/janus/janus.plugin.nosip.jcfg
backup = etc/janus/janus.plugin.recordplay.jcfg
backup = etc/janus/janus.plugin.sip.jcfg
@@ -51,6 +64,7 @@ pkgname = janus-gateway
backup = etc/janus/janus.plugin.voicemail.jcfg
backup = etc/janus/janus.transport.http.jcfg
backup = etc/janus/janus.transport.mqtt.jcfg
+ backup = etc/janus/janus.transport.nanomsg.jcfg
backup = etc/janus/janus.transport.pfunix.jcfg
backup = etc/janus/janus.transport.rabbitmq.jcfg
backup = etc/janus/janus.transport.websockets.jcfg
diff --git a/PKGBUILD b/PKGBUILD
index e6d0e1751236..bc07f1c96f53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,38 +5,46 @@
pkgname=janus-gateway
pkgver=0.9.4
-pkgrel=2
+pkgrel=3
pkgdesc="Janus WebRTC Server"
arch=('x86_64' 'i686')
url='http://janus.conf.meetecho.com'
license=('GPL3')
-depends=('curl' # TURN REST API support, RTSP support in Streaming/Event Handler plugin
- 'ffmpeg' # Post-processor
- 'glib2'
+depends=('glib2'
'jansson'
'libconfig'
'libmicrohttpd'
'libnice'
- 'libogg' # Voicemail plugin and/or post-processor
- 'librabbitmq-c' # RabbitMQ support for the Janus API or events
'libsrtp'
'libusrsctp-git'
- 'libwebsockets' # WebSockets support for Janus API
- 'lua' # Lua plugin
- 'nanomsg' # Nanomsg support for the Janus API
- 'paho-mqtt-c-git' # MQTT support for the Janus API or events
- 'openssl'
- 'opus' # Bridge plugin
- 'sofia-sip' # SIP plugin
-)
-makedepends=('cmake'
- 'gengetopt')
+ 'openssl')
+optdepends=('libwebsockets: WebSockets support for Janus API'
+ 'librabbitmq-c: RabbitMQ support for the Janus API or events'
+ 'paho-mqtt-c-git: MQTT support for the Janus API or events'
+ 'nanomsg: Nanomsg support for the Janus API'
+ 'curl: TURN REST API support, RTSP support in Streaming/Event Handler plugin'
+ 'sofia-sip: SIP plugin'
+ 'opus: Bridge plugin'
+ 'libogg: Voicemail plugin and/or post-processor'
+ 'ffmpeg: Post-processor'
+ 'lua: Lua plugin')
+makedepends=('curl'
+ 'ffmpeg'
+ 'gengetopt'
+ 'libogg'
+ 'librabbitmq-c'
+ 'libwebsockets'
+ 'lua'
+ 'nanomsg'
+ 'opus'
+ 'paho-mqtt-c-git'
+ 'sofia-sip')
source=("$pkgname-$pkgver.tar.gz::https://github.com/meetecho/janus-gateway/archive/v${pkgver}.tar.gz"
'janus.service'
'janus.conf')
sha256sums=('97f3653066748f4f2888b6571d28ecf400653c86523cb1c1ed42ba065649cba9'
'cf2b6c8fdcd60ccfa179c4cd207a23ee7edfee90588c2c3847aa6cda418bed7f'
- '60f6aef6b082f6c3f15803f7f727a2a023d6d18668e309571af3dff55bce1e92')
+ 'ad965a52fbe23e23a92b878bb08fa4c815b15a7569776882b21ff83c988dbd3e')
_userid=531
@@ -47,9 +55,11 @@ build() {
--prefix /usr \
--sysconfdir /etc \
--disable-docs \
- --enable-javascript-commonjs-module \
- --enable-post-processing \
+ --enable-json-logger \
--enable-mqtt \
+ --enable-plugin-duktape \
+ --enable-plugin-lua \
+ --enable-post-processing \
--enable-rabbit-mq
make
}
@@ -58,7 +68,6 @@ package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install configs
backup+=($(cd "$pkgdir" && echo "etc/janus/"*.jcfg))
- install -dm0700 -o "$_userid" -g "$_userid" "${pkgdir}/var/lib/janus"
install -Dm644 -t "$pkgdir/usr/lib/systemd/system/" "$srcdir/janus.service"
install -Dm644 -t "$pkgdir/usr/lib/sysusers.d/" "$srcdir/janus.conf"
}
diff --git a/janus.conf b/janus.conf
index b46568dac40e..a943c22efe6c 100644
--- a/janus.conf
+++ b/janus.conf
@@ -1 +1 @@
-u janus 531 "Janus WebRTC gateway user" /var/lib/janus /bin/bash
+u janus 531 "Janus WebRTC gateway user"