summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302021-04-07 00:34:04 +0200
committerM0Rf302021-04-07 00:34:04 +0200
commitdd9651476a4ea82c7a476c63ed6ba79b1b52f41e (patch)
tree3b247053f0b81b9ebf395a1f2c2970b849ac0b41
parentf2aa25a8e7350ab2c5876ef664dd01abf63f5fae (diff)
downloadaur-dd9651476a4ea82c7a476c63ed6ba79b1b52f41e.tar.gz
janus-gateway: 0.11.1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD154
2 files changed, 88 insertions, 88 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 762cb6f66992..db01a12346e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = janus-gateway
pkgdesc = An open source, general purpose, WebRTC server
- pkgver = 0.10.10
+ pkgver = 0.11.1
pkgrel = 1
url = https://janus.conf.meetecho.com
- arch = x86_64
arch = i686
+ arch = x86_64
license = GPL3
makedepends = curl
makedepends = ffmpeg
@@ -25,16 +25,16 @@ pkgbase = janus-gateway
depends = libsrtp
depends = libusrsctp
depends = openssl
- optdepends = libwebsockets: WebSockets support for Janus API
- optdepends = librabbitmq-c: RabbitMQ support for the Janus API or events
- optdepends = paho-mqtt-c-git: MQTT support for the Janus API or events
- optdepends = nanomsg: Nanomsg support for the Janus API
optdepends = curl: TURN REST API support, RTSP support in Streaming/Event Handler plugin
- optdepends = sofia-sip: SIP plugin
- optdepends = opus: Bridge plugin
- optdepends = libogg: Voicemail plugin and/or post-processor
optdepends = ffmpeg: Post-processor
+ optdepends = libogg: Voicemail plugin and/or post-processor
+ optdepends = librabbitmq-c: RabbitMQ support for the Janus API or events
+ optdepends = libwebsockets: WebSockets support for Janus API
optdepends = lua: Lua plugin
+ optdepends = nanomsg: Nanomsg support for the Janus API
+ optdepends = opus: Bridge plugin
+ optdepends = paho-mqtt-c-git: MQTT support for the Janus API or events
+ optdepends = sofia-sip: SIP plugin
backup = etc/janus/janus.eventhandler.gelfevh.jcfg
backup = etc/janus/janus.eventhandler.mqttevh.jcfg
backup = etc/janus/janus.eventhandler.nanomsgevh.jcfg
@@ -61,10 +61,10 @@ pkgbase = janus-gateway
backup = etc/janus/janus.transport.pfunix.jcfg
backup = etc/janus/janus.transport.rabbitmq.jcfg
backup = etc/janus/janus.transport.websockets.jcfg
- source = janus-gateway-0.10.10.tar.gz::https://github.com/meetecho/janus-gateway/archive/v0.10.10.tar.gz
+ source = janus-gateway-0.11.1.tar.gz::https://github.com/meetecho/janus-gateway/archive/v0.11.1.tar.gz
source = janus.service
source = janus.conf
- sha256sums = 21e2fc7dee4b20ed8d749a69577eccd961b0bfe5b863d42f39ddfcd2af903718
+ sha256sums = 8cc38f2598cd63306c7ba6d1bb5096ca9b322dde521586151da364d26658dbd0
sha256sums = cf2b6c8fdcd60ccfa179c4cd207a23ee7edfee90588c2c3847aa6cda418bed7f
sha256sums = bd6d7615e722adb64816fae3c5323f6aeb1b9561c39f1652568ed494ffdaa191
diff --git a/PKGBUILD b/PKGBUILD
index c35261efb04c..b87ca2f30eee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,93 +4,93 @@
# Contributor: Maurizio Porrato <maurizio.porrato@gmail.com>
pkgname=janus-gateway
-pkgver=0.10.10
+pkgver=0.11.1
pkgrel=1
pkgdesc="An open source, general purpose, WebRTC server"
-arch=('x86_64' 'i686')
+arch=('i686' 'x86_64')
url='https://janus.conf.meetecho.com'
license=('GPL3')
depends=('glib2'
- 'jansson'
- 'libconfig'
- 'libmicrohttpd'
- 'libnice'
- 'libsrtp'
- 'libusrsctp'
- 'openssl')
-optdepends=('libwebsockets: WebSockets support for Janus API'
- 'librabbitmq-c: RabbitMQ support for the Janus API or events'
- 'paho-mqtt-c-git: MQTT support for the Janus API or events'
- 'nanomsg: Nanomsg support for the Janus API'
- 'curl: TURN REST API support, RTSP support in Streaming/Event Handler plugin'
- 'sofia-sip: SIP plugin'
- 'opus: Bridge plugin'
- 'libogg: Voicemail plugin and/or post-processor'
- 'ffmpeg: Post-processor'
- 'lua: Lua plugin')
+ 'jansson'
+ 'libconfig'
+ 'libmicrohttpd'
+ 'libnice'
+ 'libsrtp'
+ 'libusrsctp'
+ 'openssl')
+optdepends=('curl: TURN REST API support, RTSP support in Streaming/Event Handler plugin'
+ 'ffmpeg: Post-processor'
+ 'libogg: Voicemail plugin and/or post-processor'
+ 'librabbitmq-c: RabbitMQ support for the Janus API or events'
+ 'libwebsockets: WebSockets support for Janus API'
+ 'lua: Lua plugin'
+ 'nanomsg: Nanomsg support for the Janus API'
+ 'opus: Bridge plugin'
+ 'paho-mqtt-c-git: MQTT support for the Janus API or events'
+ 'sofia-sip: SIP plugin')
makedepends=('curl'
- 'ffmpeg'
- 'gengetopt'
- 'libogg'
- 'librabbitmq-c'
- 'libwebsockets'
- 'lua'
- 'nanomsg'
- 'opus'
- 'paho-mqtt-c-git'
- 'sofia-sip')
+ 'ffmpeg'
+ 'gengetopt'
+ 'libogg'
+ 'librabbitmq-c'
+ 'libwebsockets'
+ 'lua'
+ 'nanomsg'
+ 'opus'
+ 'paho-mqtt-c-git'
+ 'sofia-sip')
backup=('etc/janus/janus.eventhandler.gelfevh.jcfg'
- 'etc/janus/janus.eventhandler.mqttevh.jcfg'
- 'etc/janus/janus.eventhandler.nanomsgevh.jcfg'
- 'etc/janus/janus.eventhandler.rabbitmqevh.jcfg'
- 'etc/janus/janus.eventhandler.sampleevh.jcfg'
- 'etc/janus/janus.eventhandler.wsevh.jcfg'
- 'etc/janus/janus.jcfg'
- 'etc/janus/janus.logger.jsonlog.jcfg'
- 'etc/janus/janus.plugin.audiobridge.jcfg'
- 'etc/janus/janus.plugin.duktape.jcfg'
- 'etc/janus/janus.plugin.echotest.jcfg'
- 'etc/janus/janus.plugin.lua.jcfg'
- 'etc/janus/janus.plugin.nosip.jcfg'
- 'etc/janus/janus.plugin.recordplay.jcfg'
- 'etc/janus/janus.plugin.sip.jcfg'
- 'etc/janus/janus.plugin.streaming.jcfg'
- 'etc/janus/janus.plugin.textroom.jcfg'
- 'etc/janus/janus.plugin.videocall.jcfg'
- 'etc/janus/janus.plugin.videoroom.jcfg'
- 'etc/janus/janus.plugin.voicemail.jcfg'
- 'etc/janus/janus.transport.http.jcfg'
- 'etc/janus/janus.transport.mqtt.jcfg'
- 'etc/janus/janus.transport.nanomsg.jcfg'
- 'etc/janus/janus.transport.pfunix.jcfg'
- 'etc/janus/janus.transport.rabbitmq.jcfg'
- 'etc/janus/janus.transport.websockets.jcfg')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/meetecho/janus-gateway/archive/v${pkgver}.tar.gz"
- 'janus.service'
- 'janus.conf')
-sha256sums=('21e2fc7dee4b20ed8d749a69577eccd961b0bfe5b863d42f39ddfcd2af903718'
- 'cf2b6c8fdcd60ccfa179c4cd207a23ee7edfee90588c2c3847aa6cda418bed7f'
- 'bd6d7615e722adb64816fae3c5323f6aeb1b9561c39f1652568ed494ffdaa191')
+ 'etc/janus/janus.eventhandler.mqttevh.jcfg'
+ 'etc/janus/janus.eventhandler.nanomsgevh.jcfg'
+ 'etc/janus/janus.eventhandler.rabbitmqevh.jcfg'
+ 'etc/janus/janus.eventhandler.sampleevh.jcfg'
+ 'etc/janus/janus.eventhandler.wsevh.jcfg'
+ 'etc/janus/janus.jcfg'
+ 'etc/janus/janus.logger.jsonlog.jcfg'
+ 'etc/janus/janus.plugin.audiobridge.jcfg'
+ 'etc/janus/janus.plugin.duktape.jcfg'
+ 'etc/janus/janus.plugin.echotest.jcfg'
+ 'etc/janus/janus.plugin.lua.jcfg'
+ 'etc/janus/janus.plugin.nosip.jcfg'
+ 'etc/janus/janus.plugin.recordplay.jcfg'
+ 'etc/janus/janus.plugin.sip.jcfg'
+ 'etc/janus/janus.plugin.streaming.jcfg'
+ 'etc/janus/janus.plugin.textroom.jcfg'
+ 'etc/janus/janus.plugin.videocall.jcfg'
+ 'etc/janus/janus.plugin.videoroom.jcfg'
+ 'etc/janus/janus.plugin.voicemail.jcfg'
+ 'etc/janus/janus.transport.http.jcfg'
+ 'etc/janus/janus.transport.mqtt.jcfg'
+ 'etc/janus/janus.transport.nanomsg.jcfg'
+ 'etc/janus/janus.transport.pfunix.jcfg'
+ 'etc/janus/janus.transport.rabbitmq.jcfg'
+ 'etc/janus/janus.transport.websockets.jcfg')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/meetecho/janus-gateway/archive/v${pkgver}.tar.gz"
+ 'janus.service'
+ 'janus.conf')
+sha256sums=('8cc38f2598cd63306c7ba6d1bb5096ca9b322dde521586151da364d26658dbd0'
+ 'cf2b6c8fdcd60ccfa179c4cd207a23ee7edfee90588c2c3847aa6cda418bed7f'
+ 'bd6d7615e722adb64816fae3c5323f6aeb1b9561c39f1652568ed494ffdaa191')
build() {
- cd "$pkgname-$pkgver"
- ./autogen.sh
- ./configure \
- --prefix /usr \
- --sysconfdir /etc \
- --disable-docs \
- --enable-json-logger \
- --enable-mqtt \
- --enable-plugin-duktape \
- --enable-plugin-lua \
- --enable-post-processing \
- --enable-rabbitmq
- make
+ cd "${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure \
+ --prefix /usr \
+ --sysconfdir /etc \
+ --disable-docs \
+ --enable-json-logger \
+ --enable-mqtt \
+ --enable-plugin-duktape \
+ --enable-plugin-lua \
+ --enable-post-processing \
+ --enable-rabbitmq
+ make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install configs
- install -Dm644 -t "$pkgdir/usr/lib/systemd/system/" "$srcdir/janus.service"
- install -Dm644 -t "$pkgdir/usr/lib/sysusers.d/" "$srcdir/janus.conf"
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install configs
+ install -Dm644 -t "${pkgdir}/usr/lib/systemd/system/" "${srcdir}/janus.service"
+ install -Dm644 -t "${pkgdir}/usr/lib/sysusers.d/" "${srcdir}/janus.conf"
}