summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Chung2020-09-15 01:08:09 +1000
committerThomas Chung2020-09-15 01:25:48 +1000
commitddc32cf12740947fb810b39ff3e0dd84a72e7572 (patch)
treec7d305eb41ab6b57b82eaf6f9eea08faf00e6246
parent7e64ee8084cda28b23a083c409dc5d8adc55ba34 (diff)
downloadaur-ddc32cf12740947fb810b39ff3e0dd84a72e7572.tar.gz
Updated to work on v0.10.5
-rw-r--r--.SRCINFO90
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD92
-rw-r--r--janus-gateway-git.install10
-rw-r--r--systemd.service15
-rw-r--r--sysusers.conf1
6 files changed, 145 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce9a2eba2ad7..c8342fcf9494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,75 @@
pkgbase = janus-gateway-git
- pkgdesc = WebRTC gateway.
- pkgver = 0.0.9.r0.gf500ae8
- pkgrel = 2
- url = http://janus.conf.meetecho.com/
- install = janus-gateway-git.install
- arch = i686
+ pkgdesc = An open source, general purpose, WebRTC server
+ pkgver = 0.10.5.r8.ge94612e6
+ pkgrel = 1
+ url = https://janus.conf.meetecho.com
arch = x86_64
+ arch = i686
license = GPL3
- makedepends = git
- makedepends = libtool
- makedepends = automake
- makedepends = autoconf
- makedepends = gcc
- makedepends = make
- makedepends = pkg-config
+ makedepends = curl
+ makedepends = ffmpeg
makedepends = gengetopt
- makedepends = patch
- depends = libmicrohttpd
+ makedepends = libogg
+ makedepends = librabbitmq-c
+ makedepends = libwebsockets
+ makedepends = lua
+ makedepends = nanomsg
+ makedepends = opus
+ makedepends = paho-mqtt-c-git
+ makedepends = sofia-sip
+ makedepends = git
+ depends = glib2
depends = jansson
+ depends = libconfig
+ depends = libmicrohttpd
depends = libnice
- depends = openssl
depends = libsrtp
- depends = sofia-sip
- depends = sctp-refimpl-svn
- depends = libwebsockets-git
- depends = libevent
- depends = librabbitmq-c
- depends = opus
- depends = libogg
- depends = glib2
- depends = ding-libs
+ depends = libusrsctp-git
+ depends = openssl
+ optdepends = libwebsockets: WebSockets support for Janus API
+ optdepends = librabbitmq-c: RabbitMQ support for the Janus API or events
+ optdepends = paho-mqtt-c-git: MQTT support for the Janus API or events
+ optdepends = nanomsg: Nanomsg support for the Janus API
+ optdepends = curl: TURN REST API support, RTSP support in Streaming/Event Handler plugin
+ optdepends = sofia-sip: SIP plugin
+ optdepends = opus: Bridge plugin
+ optdepends = libogg: Voicemail plugin and/or post-processor
+ optdepends = ffmpeg: Post-processor
+ optdepends = lua: Lua plugin
provides = janus-gateway
- backup = etc/janus/janus.cfg
+ conflicts = janus-gateway
source = git+https://github.com/meetecho/janus-gateway.git
- md5sums = SKIP
+ source = local://systemd.service
+ source = local://sysusers.conf
+ sha256sums = SKIP
+ sha256sums = cf2b6c8fdcd60ccfa179c4cd207a23ee7edfee90588c2c3847aa6cda418bed7f
+ sha256sums = bd6d7615e722adb64816fae3c5323f6aeb1b9561c39f1652568ed494ffdaa191
pkgname = janus-gateway-git
+ backup = etc/janus/janus.eventhandler.gelfevh.jcfg
+ backup = etc/janus/janus.eventhandler.mqttevh.jcfg
+ backup = etc/janus/janus.eventhandler.nanomsgevh.jcfg
+ backup = etc/janus/janus.eventhandler.rabbitmqevh.jcfg
+ backup = etc/janus/janus.eventhandler.sampleevh.jcfg
+ backup = etc/janus/janus.eventhandler.wsevh.jcfg
+ backup = etc/janus/janus.jcfg
+ backup = etc/janus/janus.logger.jsonlog.jcfg
+ backup = etc/janus/janus.plugin.audiobridge.jcfg
+ backup = etc/janus/janus.plugin.duktape.jcfg
+ backup = etc/janus/janus.plugin.echotest.jcfg
+ backup = etc/janus/janus.plugin.lua.jcfg
+ backup = etc/janus/janus.plugin.nosip.jcfg
+ backup = etc/janus/janus.plugin.recordplay.jcfg
+ backup = etc/janus/janus.plugin.sip.jcfg
+ backup = etc/janus/janus.plugin.streaming.jcfg
+ backup = etc/janus/janus.plugin.textroom.jcfg
+ backup = etc/janus/janus.plugin.videocall.jcfg
+ backup = etc/janus/janus.plugin.videoroom.jcfg
+ backup = etc/janus/janus.plugin.voicemail.jcfg
+ backup = etc/janus/janus.transport.http.jcfg
+ backup = etc/janus/janus.transport.mqtt.jcfg
+ backup = etc/janus/janus.transport.nanomsg.jcfg
+ backup = etc/janus/janus.transport.pfunix.jcfg
+ backup = etc/janus/janus.transport.rabbitmq.jcfg
+ backup = etc/janus/janus.transport.websockets.jcfg
diff --git a/.gitignore b/.gitignore
index e65007534e48..dba7481976f2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
src/
pkg/
-*.src.tar.*
*.pkg.tar.*
*.log
janus-gateway/
diff --git a/PKGBUILD b/PKGBUILD
index 7a45ee833e11..2752c7270804 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,77 @@
-# Maintainer: Maurizio Porrato <maurizio.porrato@gmail.com>
+# Maintainer: Thomas Chung <thomas@nomology.id.au>
+# Contributor: Maurizio Porrato <maurizio.porrato@gmail.com>
pkgname=janus-gateway-git
-pkgver=0.0.9.r0.gf500ae8
-pkgrel=2
-pkgdesc="WebRTC gateway."
-arch=('i686' 'x86_64')
-url="http://janus.conf.meetecho.com/"
+pkgver=0.10.5.r8.ge94612e6
+pkgrel=1
+pkgdesc="An open source, general purpose, WebRTC server"
+arch=('x86_64' 'i686')
+url='https://janus.conf.meetecho.com'
license=('GPL3')
-depends=('libmicrohttpd' 'jansson' 'libnice' 'openssl' 'libsrtp' 'sofia-sip' 'sctp-refimpl-svn' 'libwebsockets-git' 'libevent' 'librabbitmq-c' 'opus' 'libogg' 'glib2' 'ding-libs')
-makedepends=('git' 'libtool' 'automake' 'autoconf' 'gcc' 'make' 'pkg-config' 'gengetopt' 'patch')
+depends=('glib2'
+ 'jansson'
+ 'libconfig'
+ 'libmicrohttpd'
+ 'libnice'
+ 'libsrtp'
+ 'libusrsctp-git'
+ 'openssl')
+optdepends=('libwebsockets: WebSockets support for Janus API'
+ 'librabbitmq-c: RabbitMQ support for the Janus API or events'
+ 'paho-mqtt-c-git: MQTT support for the Janus API or events'
+ 'nanomsg: Nanomsg support for the Janus API'
+ 'curl: TURN REST API support, RTSP support in Streaming/Event Handler plugin'
+ 'sofia-sip: SIP plugin'
+ 'opus: Bridge plugin'
+ 'libogg: Voicemail plugin and/or post-processor'
+ 'ffmpeg: Post-processor'
+ 'lua: Lua plugin')
+makedepends=('curl'
+ 'ffmpeg'
+ 'gengetopt'
+ 'libogg'
+ 'librabbitmq-c'
+ 'libwebsockets'
+ 'lua'
+ 'nanomsg'
+ 'opus'
+ 'paho-mqtt-c-git'
+ 'sofia-sip'
+ 'git')
provides=(janus-gateway)
-backup=('etc/janus/janus.cfg')
-install=janus-gateway-git.install
-
-source=('git+https://github.com/meetecho/janus-gateway.git')
-md5sums=('SKIP')
-_gitname="janus-gateway"
+conflicts=(janus-gateway)
+source=('git+https://github.com/meetecho/janus-gateway.git'
+ 'local://systemd.service'
+ 'local://sysusers.conf')
+sha256sums=('SKIP'
+ 'cf2b6c8fdcd60ccfa179c4cd207a23ee7edfee90588c2c3847aa6cda418bed7f'
+ 'bd6d7615e722adb64816fae3c5323f6aeb1b9561c39f1652568ed494ffdaa191')
pkgver() {
- cd "$srcdir/${_gitname}"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
+ cd "janus-gateway"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$srcdir/${_gitname}"
- ./autogen.sh
- ./configure --prefix=/usr --sysconfdir=/etc --disable-docs
- DESTDIR="$pkgdir/" make
+ cd "janus-gateway"
+ ./autogen.sh
+ ./configure \
+ --prefix /usr \
+ --sysconfdir /etc \
+ --disable-docs \
+ --enable-json-logger \
+ --enable-mqtt \
+ --enable-plugin-duktape \
+ --enable-plugin-lua \
+ --enable-post-processing \
+ --enable-rabbitmq
+ make
}
-package() {
- cd "$srcdir/${_gitname}"
- DESTDIR="$pkgdir/" make install configs
- rm -f "$pkgdir/usr/share/janus/certs/mycert.{key,pem}"
-}
-
+package() {
+ cd "janus-gateway"
+ make DESTDIR="$pkgdir" install configs
+ backup+=($(cd "$pkgdir" && echo "etc/janus/"*.jcfg))
+ install -Dm644 "$srcdir/systemd.service" "$pkgdir/usr/lib/systemd/system/janus-gateway.service"
+ install -Dm644 "$srcdir/sysusers.conf" "$pkgdir/usr/lib/sysusers.d/janus-gateway.conf"
+}
diff --git a/janus-gateway-git.install b/janus-gateway-git.install
deleted file mode 100644
index 465776fe315b..000000000000
--- a/janus-gateway-git.install
+++ /dev/null
@@ -1,10 +0,0 @@
-post_install() {
- openssl req -x509 -batch -nodes -newkey rsa:1024 \
- -keyout /usr/share/janus/certs/mycert.key \
- -out /usr/share/janus/certs/mycert.pem
-}
-
-pre_remove() {
- rm -f /usr/share/janus/certs/mycert.{key,pem}
-}
-
diff --git a/systemd.service b/systemd.service
new file mode 100644
index 000000000000..f33e3e569371
--- /dev/null
+++ b/systemd.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Janus WebRTC Gateway
+Wants=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/janus
+User=janus
+Group=janus
+Restart=on-failure
+LimitNOFILE=65536
+TasksMax=infinity
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sysusers.conf b/sysusers.conf
new file mode 100644
index 000000000000..1b47572a4855
--- /dev/null
+++ b/sysusers.conf
@@ -0,0 +1 @@
+u janus - "Janus WebRTC gateway user"