summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPrzemysław Buczkowski2020-09-30 23:54:53 +0100
committerPrzemysław Buczkowski2020-09-30 23:54:53 +0100
commit6b6d630ffed30dc7b3fb80132c265df3ef3f22a3 (patch)
treed555136d6c3d2efb2ac8bf7ee849ae44c1f631ca
parente9f3c424210fdb7ccf6ffc310ef338086ab7d904 (diff)
downloadaur-6b6d630ffed30dc7b3fb80132c265df3ef3f22a3.tar.gz
Update to 9.0.9
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ade2d2173db5..b11793f14fb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
pkgname=jape
-pkgver=8.1.3
+pkgver=9.0.9
+_pkgfile=${pkgver//./_}
pkgrel=1
pkgdesc='A configurable, graphical proof assistant.'
arch=('x86_64')
url='http://japeforall.org.uk/'
license=('GPL')
-depends=('java-runtime')
+depends=('java-runtime>=9')
makedepends=('unzip')
source=('jape'
'jape.desktop')
sha256sums=('43cfa222c48f819c9c4508f4847212d4327f8c7aa49ba4f3bfc9dc4f0f330f8d'
'4677512343900e325f763cf79c8571ae3e493d7f074ebc7c68182ef487e6e579')
-source_x86_64=("http://www.cs.ox.ac.uk/people/bernard.sufrin/personal/jape.org/BUILDS/$pkgver/InstallLinuxjape.jar")
-noextract=('InstallLinuxjape.jar')
-sha256sums_x86_64=('768ab130d59c75ddab10a2b8dbaf10e0403c57b48a5b837f940af2c7182c72ce')
+source_x86_64=("https://github.com/RBornat/jape/releases/download/$pkgver/${_pkgfile}_InstallLinuxjape.jar")
+noextract=("${_pkgfile}_InstallLinuxjape.jar")
+sha256sums_x86_64=('dc001d7fde1e8808e474393e5a987f6c731b0915118a50e4c6750ccec534b00b')
package() {
cd "$srcdir"
- unzip InstallLinuxjape.jar || true # Invalid JAR file
+ unzip "${_pkgfile}_InstallLinuxjape.jar" || true # Invalid JAR file
install -d "$pkgdir/usr/share/jape"
install -m755 jape_engine "$pkgdir/usr/share/jape/"
- install -m644 README-UNIX README_encoder.txt "$pkgdir/usr/share/jape/"
+ install -m644 README-LINUX README_encoder.txt "$pkgdir/usr/share/jape/"
cp -dpr --no-preserve=ownership examples "$pkgdir/usr/share/jape/"
install -d "$pkgdir/usr/share/java/jape"