summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPrzemysław Buczkowski2019-08-02 17:24:59 +0100
committerPrzemysław Buczkowski2019-08-02 17:25:08 +0100
commite9f3c424210fdb7ccf6ffc310ef338086ab7d904 (patch)
tree6d4b1da0997e8f0bf4209ff2b21c951c4b0fb35b
parentb8e18a288d9d8eb46462c6cb92f6e0b7a58cb751 (diff)
downloadaur-e9f3c424210fdb7ccf6ffc310ef338086ab7d904.tar.gz
Update to Jape v8.1.3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cae62ebefceb..cc20c7d3e11a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = jape
pkgdesc = A configurable, graphical proof assistant.
- pkgver = 7_d14
+ pkgver = 8.1.3
pkgrel = 1
url = http://japeforall.org.uk/
- arch = i686
arch = x86_64
license = GPL
+ makedepends = unzip
depends = java-runtime
+ noextract = InstallLinuxjape.jar
source = jape
source = jape.desktop
sha256sums = 43cfa222c48f819c9c4508f4847212d4327f8c7aa49ba4f3bfc9dc4f0f330f8d
sha256sums = 4677512343900e325f763cf79c8571ae3e493d7f074ebc7c68182ef487e6e579
- source_i686 = http://www.cs.ox.ac.uk/people/bernard.sufrin/personal/jape.org/BUILDS/7_d14/Install32bitLinuxjape.jar
- sha256sums_i686 = ab00be7518d418a8ace5e1ccfe8101d52952a41e42d872e448647657d7c90e98
- source_x86_64 = http://www.cs.ox.ac.uk/people/bernard.sufrin/personal/jape.org/BUILDS/7_d14/InstallLinuxjape.jar
- sha256sums_x86_64 = d82a9dc50f4b2d9e0994db21bdc1979b28dd25ff88acb4f459d24c157329dca4
+ source_x86_64 = http://www.cs.ox.ac.uk/people/bernard.sufrin/personal/jape.org/BUILDS/8.1.3/InstallLinuxjape.jar
+ sha256sums_x86_64 = 768ab130d59c75ddab10a2b8dbaf10e0403c57b48a5b837f940af2c7182c72ce
pkgname = jape
diff --git a/PKGBUILD b/PKGBUILD
index 2a43c1eacb3c..ade2d2173db5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
pkgname=jape
-pkgver=7_d14
+pkgver=8.1.3
pkgrel=1
pkgdesc='A configurable, graphical proof assistant.'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://japeforall.org.uk/'
license=('GPL')
depends=('java-runtime')
+makedepends=('unzip')
source=('jape'
'jape.desktop')
sha256sums=('43cfa222c48f819c9c4508f4847212d4327f8c7aa49ba4f3bfc9dc4f0f330f8d'
'4677512343900e325f763cf79c8571ae3e493d7f074ebc7c68182ef487e6e579')
-source_i686=("http://www.cs.ox.ac.uk/people/bernard.sufrin/personal/jape.org/BUILDS/$pkgver/Install32bitLinuxjape.jar")
-sha256sums_i686=('ab00be7518d418a8ace5e1ccfe8101d52952a41e42d872e448647657d7c90e98')
source_x86_64=("http://www.cs.ox.ac.uk/people/bernard.sufrin/personal/jape.org/BUILDS/$pkgver/InstallLinuxjape.jar")
-sha256sums_x86_64=('d82a9dc50f4b2d9e0994db21bdc1979b28dd25ff88acb4f459d24c157329dca4')
+noextract=('InstallLinuxjape.jar')
+sha256sums_x86_64=('768ab130d59c75ddab10a2b8dbaf10e0403c57b48a5b837f940af2c7182c72ce')
package() {
cd "$srcdir"
+ unzip InstallLinuxjape.jar || true # Invalid JAR file
+
install -d "$pkgdir/usr/share/jape"
install -m755 jape_engine "$pkgdir/usr/share/jape/"
install -m644 README-UNIX README_encoder.txt "$pkgdir/usr/share/jape/"