summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Martin2015-08-20 19:15:45 -0500
committerStephen Martin2015-08-20 19:15:45 -0500
commit3d10bd8107531f1755093b2e0e837deec0880bd6 (patch)
treeb094e4ce1fed32909996cb7b717d088fd6987cfa
parent5ccb26c63c77a3216c3fe0df44df6c4644ec8e52 (diff)
downloadaur-3d10bd8107531f1755093b2e0e837deec0880bd6.tar.gz
Patched in SEM
-rw-r--r--PKGBUILD12
-rw-r--r--jasp-desktop-git.install8
-rw-r--r--sem.patch46
3 files changed, 63 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8050861b6e89..935a654c10c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=jasp-desktop-git
_pkgname=jasp-desktop
_buildname=jasp-build
pkgver=v0.7.1.7.r0.g4885971
-pkgrel=2
+pkgrel=4
pkgdesc="JASP, a low fat alternative to SPSS, a delicious alternative to R."
arch=('any')
url="http://jasp-stats.org"
@@ -12,9 +12,11 @@ depends=('qt5-base' 'boost' 'pcre' 'r' 'libarchive' 'zlib' 'boost-nowide' 'qt5-w
makedepends=('git' 'qtchooser' 'r')
provides=('jasp' 'jasp-desktop')
conflicts=('jasp' 'jasp-desktop')
+install=('jasp-desktop-git.install')
source=("$_pkgname::git+https://github.com/jasp-stats/$_pkgname.git#tag=v0.7.1.7"
"rbundle.R"
- "jasp-desktop.svg")
+ "jasp-desktop.svg"
+ "sem.patch")
pkgver() {
cd "$srcdir/$_pkgname"
@@ -25,6 +27,9 @@ pkgver() {
}
prepare() {
+ cd $srcdir/$_pkgname
+ patch -p1 < $srcdir/sem.patch
+ echo "Patching in the SEM feature. This feature is UNSUPPORTED by the developer currently"
mkdir -p $srcdir/$_buildname
cd $srcdir/$_buildname
@@ -88,4 +93,5 @@ EOF
}
md5sums=('SKIP'
'85087ac1d6e0ffa885f4887c40985982'
- 'bcaf403001283553bb63b72c268d0290')
+ 'bcaf403001283553bb63b72c268d0290'
+ '9e04c417faac1e36f7ddb9f8350620ab')
diff --git a/jasp-desktop-git.install b/jasp-desktop-git.install
new file mode 100644
index 000000000000..d3041d1cb53f
--- /dev/null
+++ b/jasp-desktop-git.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "JASP was built with simple SEM enabled. This feature is UNSUPPORTED by the developer currently."
+}
+
+post_upgrade() {
+ post_install
+}
+
diff --git a/sem.patch b/sem.patch
new file mode 100644
index 000000000000..531c50c5036e
--- /dev/null
+++ b/sem.patch
@@ -0,0 +1,46 @@
+diff --git a/JASP-Desktop/mainwindow.cpp b/JASP-Desktop/mainwindow.cpp
+index 80cd705..d8ccc6c 100644
+--- a/JASP-Desktop/mainwindow.cpp
++++ b/JASP-Desktop/mainwindow.cpp
+@@ -87,9 +87,7 @@ MainWindow::MainWindow(QWidget *parent) :
+ ui->tabBar->setFocusPolicy(Qt::NoFocus);
+ ui->tabBar->addTab("File");
+ ui->tabBar->addTab("Common");
+-#ifndef __linux__
+ ui->tabBar->addOptionsTab(); // no SEM under linux for now
+-#endif
+ ui->tabBar->addHelpTab();
+
+ connect(ui->tabBar, SIGNAL(currentChanged(int)), this, SLOT(tabChanged(int)));
+@@ -543,7 +541,6 @@ void MainWindow::tabChanged(int index)
+ {
+ ui->topLevelWidgets->setCurrentIndex(0);
+ }
+-#ifndef __linux__
+ else if (index == ui->tabBar->count() - 1)
+ {
+ if (_optionsForm == NULL)
+@@ -555,7 +552,6 @@ void MainWindow::tabChanged(int index)
+
+ ui->topLevelWidgets->setCurrentWidget(_optionsForm);
+ }
+-#endif
+ else
+ {
+ ui->topLevelWidgets->setCurrentIndex(1);
+@@ -789,15 +785,12 @@ void MainWindow::updateMenuEnabledDisabledStatus()
+
+ void MainWindow::updateUIFromOptions()
+ {
+-#ifdef __linux__
+ ui->tabBar->removeTab("SEM");
+-#else
+ QVariant sem = _settings.value("plugins/sem", false);
+ if (sem.canConvert(QVariant::Bool) && sem.toBool())
+ ui->tabBar->addTab("SEM");
+ else
+ ui->tabBar->removeTab("SEM");
+-#endif
+
+ QVariant rl = _settings.value("toolboxes/r11tLearn", false);
+ if (rl.canConvert(QVariant::Bool) && rl.toBool())