summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Tsanev2015-01-24 21:58:20 +0200
committerVladimir Tsanev2015-06-21 16:21:30 +0300
commit89c18c7a4b47046f37cc430ac6fc9ec075218c29 (patch)
treef01ff27c3de5bc32eea760c869340a4cdeb8d132
downloadaur-89c18c7a4b47046f37cc430ac6fc9ec075218c29.tar.gz
java-asm package
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore2
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD33
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18b1a70cbadf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = java-asm
+ pkgdesc = An all purpose Java bytecode manipulation and analysis framework
+ pkgver = 5.0.3
+ pkgrel = 1
+ url = http://asm.ow2.org/
+ arch = any
+ license = BSD
+ depends = java-runtime
+ source = http://download.forge.objectweb.org/asm/asm-5.0.3-bin.zip
+ source = LICENSE
+ md5sums = 82636e8a1b8eec18ee20e9b71a16441a
+ md5sums = de1a27d7c9e101090ae065f8fc643a0b
+ sha256sums = e50c38c908e4aacedecf49f405937069ce6411bef9806b9a4fc9d335d6bdb36f
+ sha256sums = daa45cc0832746afadb8778c1155bb5ba9079da624803a4a6bc3429ea52e7523
+
+pkgname = java-asm
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b26d2fb9c880
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.xz
+*.src.tar.gz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..75ad085e2b57
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+Copyright (c) 2000-2005 INRIA, France Telecom
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+3. Neither the name of the copyright holders nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
+THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a8f5bc3c790
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Vladimir Tsanev <tsachev@gmail.com>
+# Contributor: [Vitaliy Berdinskikh](mailto:ur6lad@archlinux.org.ua) aka UR6LAD
+
+pkgname=java-asm
+pkgver=5.0.3
+pkgrel=1
+pkgdesc="An all purpose Java bytecode manipulation and analysis framework"
+arch=('any')
+url="http://asm.ow2.org/"
+license=('BSD')
+depends=('java-runtime')
+source=(http://download.forge.objectweb.org/asm/asm-${pkgver}-bin.zip LICENSE)
+
+package() {
+ mkdir -p $pkgdir/usr/share/{java/asm,licenses/$pkgname}
+
+ cd $srcdir
+
+ install -m 644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname
+
+ cd asm-${pkgver}/lib
+
+ for i in *.jar; do
+ install -m 644 ${i} ${pkgdir}/usr/share/java/asm
+ _tmpfilename=${i##*\/}
+ ln -sf ${_tmpfilename} ${pkgdir}/usr/share/java/asm/${_tmpfilename/-[0-9]\.[0-9]\.[0-9]/}
+ done
+}
+
+md5sums=('82636e8a1b8eec18ee20e9b71a16441a'
+ 'de1a27d7c9e101090ae065f8fc643a0b')
+sha256sums=('e50c38c908e4aacedecf49f405937069ce6411bef9806b9a4fc9d335d6bdb36f'
+ 'daa45cc0832746afadb8778c1155bb5ba9079da624803a4a6bc3429ea52e7523')