summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 08:44:03 +0000
committerAntonio Rojas2021-05-08 08:44:03 +0000
commit56f8c4b04bca5b36b95ee614a35d2260e2b28e4a (patch)
treede05e85f92f37e19ce89c102dfb057122216a1c5
downloadaur-56f8c4b04bca5b36b95ee614a35d2260e2b28e4a.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD22
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5df23695c09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = java-bcel
+ pkgdesc = Java library to analyze, create, and manipulate (binary) Java class files
+ pkgver = 6.2
+ pkgrel = 2
+ url = https://commons.apache.org/proper/commons-bcel/
+ arch = any
+ license = APACHE
+ makedepends = apache-ant
+ makedepends = junit
+ depends = java-runtime-headless
+ source = https://archive.apache.org/dist/commons/bcel/binaries/bcel-6.2-bin.tar.gz
+ source = https://archive.apache.org/dist/commons/bcel/binaries/bcel-6.2-bin.tar.gz.asc
+ validpgpkeys = CD5464315F0B98C77E6E8ECD9DAADC1C9FCC82D0
+ validpgpkeys = 2DB4F1EF0FA761ECC4EA935C86FDC7E2A11262CB
+ sha256sums = e5963ed50ef1f243f852a27efaf898c050a3b39721d147ccda8418c0b7255955
+ sha256sums = SKIP
+
+pkgname = java-bcel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..378724ca1f84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
+_libname=bcel
+pkgname=java-${_libname}
+pkgver=6.2
+pkgrel=2
+pkgdesc="Java library to analyze, create, and manipulate (binary) Java class files"
+arch=('any')
+url='https://commons.apache.org/proper/commons-bcel/'
+license=('APACHE')
+depends=('java-runtime-headless')
+makedepends=('apache-ant' 'junit')
+source=(https://archive.apache.org/dist/commons/bcel/binaries/bcel-$pkgver-bin.tar.gz{,.asc})
+validpgpkeys=('CD5464315F0B98C77E6E8ECD9DAADC1C9FCC82D0' # Benedikt Ritter (CODE SIGNING KEY)
+ '2DB4F1EF0FA761ECC4EA935C86FDC7E2A11262CB') # Gary David Gregory (Code signing key) <ggregory@apache.org>
+sha256sums=('e5963ed50ef1f243f852a27efaf898c050a3b39721d147ccda8418c0b7255955'
+ 'SKIP')
+
+package() {
+ install -D -m 644 ${_libname}-${pkgver}/${_libname}-${pkgver}.jar \
+ -t "${pkgdir}"/usr/share/java
+ ln -s ${_libname}-${pkgver}.jar "${pkgdir}"/usr/share/java/${_libname}.jar
+}