summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Girotto2020-01-26 05:15:51 +0100
committerAndrea Girotto2020-01-26 05:19:18 +0100
commit7af1411ac1d0f91a6512f54d329c8baf7bc2a6f1 (patch)
tree4d85f71b007a7f3eccb225c98d1e392bce7fa3e6
parent43c2dff1df203d375336bd7615b1c95bbcf84bb6 (diff)
downloadaur-7af1411ac1d0f91a6512f54d329c8baf7bc2a6f1.tar.gz
Release 1.14 – 2019-12-30
Fix Hex: Allow encoding read-only ByteBuffer. Fixes CODEC-261. Fix Hex: Only use an available ByteBuffer backing array if the length equals the remaining byte count. Fixes CODEC-259. Update MurmurHash3: Deprecate hash64 methods and hash methods accepting a String that use the default encoding. Fixes CODEC-268. Fix BaseNCodec to expand buffer using overflow conscious code. Fixes CODEC-265. Fix Base32/64: Fixed decoding check that all the final trailing bits to discard are zero. Fixes CODEC-270. Add Add MurmurHash3.hash128x64 methods to fix sign extension error during seeding in hash128 methods. Fixes CODEC-264. Add Add MurmurHash3.hash32x86 methods and IncrementalHash32x86 to fix sign extension error in hash32 methods. Fixes CODEC-267. Fix Allow repeat calls to MurmurHash3.IncrementalHash32.end() to generate the same value. Fixes CODEC-269. Add Add RandomAccessFile digest methods #31. Fixes CODEC-272. Add Add Path APIs to org.apache.commons.codec.digest.DigestUtils similar to File APIs. Fixes CODEC-273. Add Add SHA-512/224 and SHA-512/256 to DigestUtils for Java 9 and up. Fixes CODEC-274. Add Add missing note in javadoc when sign extension error is present #34. Fixes CODEC-275. Fix Reliance on default encoding in MurmurHash2 and MurmurHash3. Fixes CODEC-276. Update Don't reload standard Charsets in org.apache.commons.codec.Charsets. Fixes CODEC-277.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab0d8b5ec6cc..1224f19982e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = java-commons-codec
pkgdesc = Implementations of common encoders and decoders such as Base64, Hex, Phonetic and URLs
- pkgver = 1.13
+ pkgver = 1.14
pkgrel = 1
url = http://commons.apache.org/codec/
arch = any
license = Apache
- depends = java-environment
- source = http://mirror.ibcp.fr/pub/apache//commons/codec/binaries/commons-codec-1.13-bin.tar.gz
- md5sums = 7258fcdf81f88724b8efb99056c5d5d3
+ depends = java-runtime
+ source = http://us.mirrors.quenda.co/apache//commons/codec/binaries/commons-codec-1.14-bin.tar.gz
+ md5sums = 0316536f09410b5369d54965af8afe07
pkgname = java-commons-codec
diff --git a/PKGBUILD b/PKGBUILD
index 6e565db6245e..5e5f68c89b8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Original packager: Francois Boulogne <fboulogne at april dot org>
# Maintainer: Andrea Girotto echo "naqern.tvebggb@tznvy.pbz" | tr '[a-z]' '[n-za-m]'
pkgname=java-commons-codec
-pkgver=1.13
+pkgver=1.14
pkgrel=1
pkgdesc='Implementations of common encoders and decoders such as Base64, Hex, Phonetic and URLs'
arch=(any)
url='http://commons.apache.org/codec/'
license=('Apache')
-depends=('java-environment')
-source=("http://mirror.ibcp.fr/pub/apache//commons/codec/binaries/commons-codec-${pkgver}-bin.tar.gz")
+depends=('java-runtime')
+source=(http://us.mirrors.quenda.co/apache//commons/codec/binaries/commons-codec-${pkgver}-bin.tar.gz)
+# source=("http://mirror.ibcp.fr/pub/apache//commons/codec/binaries/commons-codec-${pkgver}-bin.tar.gz")
# http://it.apache.contactlab.it//commons/codec/binaries/commons-codec-1.13-bin.tar.gz
-md5sums=('7258fcdf81f88724b8efb99056c5d5d3')
+md5sums=('0316536f09410b5369d54965af8afe07')
package() {
install -d -m755 ${pkgdir}/usr/share/java/commons-codec/ || return 1