summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Wieczorek2016-10-13 15:45:14 +0200
committerMarcin Wieczorek2016-10-13 15:45:14 +0200
commit41bda89f879461cdf9b52d60e6108726e6fe3a9e (patch)
tree1668fc2d5a64b23dfff21f5708d7cc2d8838efec
parentad78c55edd7382ece525ab5fa5704b84d78e18cd (diff)
downloadaur-41bda89f879461cdf9b52d60e6108726e6fe3a9e.tar.gz
Version 4.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e31c8828ee37..42b5d2e08445 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
-# Generated by makepkg 4.2.0
-# Wed Dec 31 23:23:30 UTC 2014
pkgbase = java-commons-collections
pkgdesc = Implementations of common collections
- pkgver = 4.0
+ pkgver = 4.1
pkgrel = 1
url = http://commons.apache.org/collections/
- arch = i686
- arch = x86_64
- license = apache
+ arch = any
+ license = APACHE
makedepends = apache-ant
makedepends = junit
depends = java-runtime
- source = http://www.apache.org/dist/commons/collections/source/commons-collections4-4.0-src.tar.gz
- md5sums = d0f1e679725945eaf3e2f0c0a33532a5
- sha512sums = 3e9ea6325878a288f5127e6135155436d26b862235d57aaf6ca2dcda6e72b12a9fce3e207a48f9f1bb1781237a026843dc1d0116b1a0c5859581d41868725ac6
+ source = http://www.apache.org/dist/commons/collections/source/commons-collections4-4.1-src.tar.gz
+ sha512sums = c5666f41b68c9fdba3731730595616b16f98579c077cf047f421a46729b5a65476a8707125a2c0b0c6c024ca94df8c2633123bd99e705149fcb1afadcd3bf68b
pkgname = java-commons-collections
diff --git a/PKGBUILD b/PKGBUILD
index 2aa06aab112f..1b4a7b53ca49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
-# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# Maintainer: Marcin (CTRL) Wieczorek <marcin@marcin.co>
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
pkgname=java-commons-collections
-pkgver=4.0
+pkgver=4.1
pkgrel=1
pkgdesc='Implementations of common collections'
-arch=(i686 x86_64)
+arch=('any')
url='http://commons.apache.org/collections/'
-license=(apache)
+license=('APACHE')
depends=(java-runtime)
makedepends=(apache-ant junit)
source=("http://www.apache.org/dist/commons/collections/source/commons-collections4-${pkgver}-src.tar.gz")
-md5sums=('d0f1e679725945eaf3e2f0c0a33532a5')
-sha512sums=('3e9ea6325878a288f5127e6135155436d26b862235d57aaf6ca2dcda6e72b12a9fce3e207a48f9f1bb1781237a026843dc1d0116b1a0c5859581d41868725ac6')
+sha512sums=('c5666f41b68c9fdba3731730595616b16f98579c077cf047f421a46729b5a65476a8707125a2c0b0c6c024ca94df8c2633123bd99e705149fcb1afadcd3bf68b')
build() {
- cd "commons-collections4-${pkgver}-src"
+ cd "${srcdir}/commons-collections4-${pkgver}-src"
ant jar
}
package() {
- cd "commons-collections4-${pkgver}-src/target/"
+ cd "${srcdir}/commons-collections4-${pkgver}-src/"
install -dm755 "${pkgdir}/usr/share/java/commons-collections/"
- install -m644 commons-collections4-${pkgver}-SNAPSHOT.jar \
- "${pkgdir}/usr/share/java/commons-collections/commons-collections4.jar"
+ install -D -m644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+ install -m644 "target/commons-collections4-${pkgver}.jar" "${pkgdir}/usr/share/java/commons-collections/commons-collections4.jar"
}