summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortomasstorck2015-08-09 16:03:27 +0200
committertomasstorck2015-08-09 16:03:27 +0200
commitf968809c53c214890fcffe4b0cee5d366dee2dba (patch)
treea6ed85693258042fe4cea9a8f168da7bd650f7f2
downloadaur-f968809c53c214890fcffe4b0cee5d366dee2dba.tar.gz
Initial commit based on AUR3 PKGBUILD by Devin J. Pohly
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..940832038542
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = java-commons-math
+ pkgdesc = Apache Commons Mathematics Library
+ pkgver = 3.5
+ pkgrel = 1
+ url = http://commons.apache.org/math/
+ arch = any
+ license = APACHE
+ depends = java-runtime
+ source = http://mirror.nyi.net/pub/apache/commons/math/binaries/commons-math3-3.5-bin.tar.gz
+ md5sums = d3e9e9a8d4b07d0894257cc6953cd2a1
+
+pkgname = java-commons-math
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52d16e8d34e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Tomas Storck <storcktomas@gmail.com
+# Contributor: Devin J. Pohly <djpohly+arch@gmail.com>
+pkgname=java-commons-math
+_shortname=commons-math
+pkgver=3.5
+pkgrel=1
+pkgdesc='Apache Commons Mathematics Library'
+arch=(any)
+url='http://commons.apache.org/math/'
+license=('APACHE')
+depends=('java-runtime')
+source=("http://mirror.nyi.net/pub/apache/commons/math/binaries/${_shortname}3-$pkgver-bin.tar.gz")
+md5sums=('d3e9e9a8d4b07d0894257cc6953cd2a1')
+
+package() {
+ install -Dm644 "$srcdir/${_shortname}3-$pkgver/${_shortname}3-$pkgver.jar" "$pkgdir/usr/share/java/$_shortname/$_shortname.jar"
+}
+# vim:set ts=2 sw=2 et: