summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2015-07-13 11:54:11 +0200
committerGiovanni Santini2015-07-13 11:54:11 +0200
commit9fae41f3b297af45f66f68de16baa1e909c86c4f (patch)
treec1d18647bccca0b30af3524c24f5f81a55475004
parentba6a963c1f243d3c08f828e79602c78ada2cd408 (diff)
downloadaur-9fae41f3b297af45f66f68de16baa1e909c86c4f.tar.gz
Making it buildable and working
-rw-r--r--.SRCINFO5
-rwxr-xr-x[-rw-r--r--]PKGBUILD62
-rw-r--r--jdk8-javadoc_disable-doclint.patch16
3 files changed, 57 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71027c375c14..a3b7e760ef51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = java-gnome
pkgdesc = Java bindings to the GNOME platform (including gtk, glib and glade)
pkgver = 4.1.3
- pkgrel = 1
+ pkgrel = 2
url = http://java-gnome.sourceforge.net
arch = i686
arch = x86_64
@@ -15,8 +15,11 @@ pkgbase = java-gnome
depends = libunique3
depends = libnotify
depends = enchant
+ depends = gtkspell3
source = http://ftp.gnome.org/pub/gnome/sources/java-gnome/4.1/java-gnome-4.1.3.tar.xz
+ source = jdk8-javadoc_disable-doclint.patch
sha256sums = 060b2b249bad918b91a55a82b8a2ed085bec5734defaf31e6c8c5ad006532373
+ sha256sums = baee2777041531b6e6ce9e2b176ed27f89afe2c35f5f913ba377d7027d6dc039
pkgname = java-gnome
diff --git a/PKGBUILD b/PKGBUILD
index fc101a382193..4303375c2041 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,56 @@
-# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Maintainer: Giovanni Santini <giovannisantini93@yahoo.it>
+# Previous Maintainer: Balló György <ballogyor+arch at gmail dot com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Timm Preetz <timm@preetz.us>
+# Almost as the original one, just fixed for building
+
pkgname=java-gnome
pkgver=4.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Java bindings to the GNOME platform (including gtk, glib and glade)"
arch=('i686' 'x86_64')
url="http://java-gnome.sourceforge.net"
license=('GPL')
-depends=('java-runtime' 'gtksourceview3' 'librsvg' 'libunique3' 'libnotify' 'enchant')
+depends=('java-runtime' 'gtksourceview3' 'librsvg' 'libunique3' 'libnotify' 'enchant' 'gtkspell3')
makedepends=('java-environment' 'junit' 'python2')
-source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/4.1/$pkgname-$pkgver.tar.xz)
-sha256sums=('060b2b249bad918b91a55a82b8a2ed085bec5734defaf31e6c8c5ad006532373')
+source=(
+ http://ftp.gnome.org/pub/gnome/sources/$pkgname/4.1/$pkgname-$pkgver.tar.xz
+ jdk8-javadoc_disable-doclint.patch
+ )
+sha256sums=('060b2b249bad918b91a55a82b8a2ed085bec5734defaf31e6c8c5ad006532373'
+ 'baee2777041531b6e6ce9e2b176ed27f89afe2c35f5f913ba377d7027d6dc039')
+
+prepare() {
+ # Fix Javadoc 8 doclint annoying behaviour by disabling it
+ # Actually, you've to add a line in the script'$srcdir/build/faster'
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np2 -i "$srcdir/jdk8-javadoc_disable-doclint.patch"
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- # Python2 fix
- sed -i 's@^#!.*python$@#!/usr/bin/python2@' build/faster src/util/demux/demux.py
-
- # Adapt to the new build-system
- unset CLASSPATH
- if [ -d "$J2SDKDIR" ]; then
- ./configure jdk=$J2SDKDIR prefix=/usr
- else
- ./configure prefix=/usr
- fi
- make
- DISPLAY= make doc
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # Python2 fix
+ sed -i 's@^#!.*python$@#!/usr/bin/python2@' build/faster src/util/demux/demux.py
+
+ # Adapt to the new build-system
+ unset CLASSPATH
+
+ # Ok, this had to be updated
+ ./configure jdk="/usr/lib/jvm/$(archlinux-java get)" prefix=/usr
+ make
+ DISPLAY= make doc
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
- make -j1 DESTDIR=$pkgdir install
+ make -j1 DESTDIR=$pkgdir install
- install -d "$pkgdir/usr/share/gtk-doc/html/$pkgname"
- cp -R "$srcdir"/$pkgname-$pkgver/doc/api/* "$pkgdir/usr/share/gtk-doc/html/$pkgname"
+ install -d "$pkgdir/usr/share/gtk-doc/html/$pkgname"
+ cp -R "$srcdir"/$pkgname-$pkgver/doc/api/* "$pkgdir/usr/share/gtk-doc/html/$pkgname"
- # Fix permissions
- chmod 644 "$pkgdir/usr/share/java/gtk-4.1.jar"
+ # Fix permissions
+ chmod 644 "$pkgdir/usr/share/java/gtk-4.1.jar"
}
diff --git a/jdk8-javadoc_disable-doclint.patch b/jdk8-javadoc_disable-doclint.patch
new file mode 100644
index 000000000000..1a5294e1bfb8
--- /dev/null
+++ b/jdk8-javadoc_disable-doclint.patch
@@ -0,0 +1,16 @@
+# Patch written from Giovanni Santini <giovannisantini93@yahoo.it>
+# Feel free to use it, just give proper credits writing in your patch:
+# Original patch written from Giovanni Santini <giovannisantini93@yahoo.it>
+# See: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=java-gnome
+# Disable doclint, see: http://blog.joda.org/2014/02/turning-off-doclint-in-jdk-8-javadoc.html
+diff -ur a/java-gnome-4.1.3/build/faster b/java-gnome-4.1.3/build/faster
+--- a/java-gnome-4.1.3/build/faster 2013-05-05 03:08:23.000000000 +0200
++++ b/java-gnome-4.1.3/build/faster 2015-07-13 11:33:55.207518811 +0200
+@@ -650,6 +650,7 @@
+ cmd += "-d doc/api "
+ cmd += "-public "
+ cmd += "-nodeprecated "
++ cmd += "-Xdoclint:none "
+ cmd += "-source 1.5 "
+ cmd += "-notree "
+ cmd += "-noindex "