summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikita Bobko2019-03-02 16:19:20 +0300
committerNikita Bobko2019-03-02 16:19:20 +0300
commita2372ff7b59289b2d2c4a0e42e2b6dd690e48e93 (patch)
treed8bec6dd7f71a7d8f8be2ffd29179cba5a3890d1
downloadaur-a2372ff7b59289b2d2c4a0e42e2b6dd690e48e93.tar.gz
v4.1.3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52b2f3328424
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = java-gnome-bin
+ pkgdesc = Binaries of Java bindings to the GNOME platform (including gtk, glib and glade)
+ pkgver = 4.1.3
+ pkgrel = 1
+ url = https://github.com/nikitabobko/${pkgname}
+ arch = x86_64
+ license = GPL
+ depends = java-runtime<9
+ depends = gtksourceview3
+ depends = librsvg
+ depends = libnotify
+ depends = enchant
+ depends = gtkspell3
+ conflicts = java-gnome
+ source = https://github.com/nikitabobko/java-gnome-bin/releases/download/v4.1.3/java-gnome-bin-v4.1.3.tar
+ sha256sums = e173bbec8bc2640cf8e137c851a747fb23fab0a2657b6da06ae4e3e76eeafaea
+
+pkgname = java-gnome-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c0003a35287
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Nikita Bobko <nikitabobko (at) gmail (dot) com>
+
+pkgname=java-gnome-bin
+pkgver=4.1.3
+pkgrel=1
+pkgdesc='Binaries of Java bindings to the GNOME platform (including gtk, glib and glade)'
+arch=('x86_64')
+url='https://github.com/nikitabobko/${pkgname}'
+license=('GPL')
+depends=('java-runtime<9' 'gtksourceview3' 'librsvg' 'libnotify' 'enchant' 'gtkspell3')
+conflicts=("java-gnome")
+source=("https://github.com/nikitabobko/${pkgname}/releases/download/v${pkgver//_/-}/${pkgname}-v${pkgver//_/-}.tar")
+sha256sums=("e173bbec8bc2640cf8e137c851a747fb23fab0a2657b6da06ae4e3e76eeafaea")
+
+package() {
+ cd ${srcdir}/${pkgname}-v${pkgver}
+ cp -r --no-dereference * ${pkgdir}
+}