summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2019-12-18 15:32:46 +0330
committerMohammadreza Abdollahzadeh2019-12-18 15:32:46 +0330
commit208ddc5a91fe4ee38331750be6f3a327a0747bd6 (patch)
tree7c8addf59ce6676f8e75a07f5250b28be6d1a86f
parentd9cc6bbb0ee60b77641dbeaa11d913252b18e0e2 (diff)
downloadaur-208ddc5a91fe4ee38331750be6f3a327a0747bd6.tar.gz
update to v14rc4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 496b1afc8c30..fd6de523df4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = java-openjfx-ea-bin
pkgdesc = Java OpenJFX 14 Early-Access Build.
- pkgver = 14rc1
+ pkgver = 14rc4
pkgrel = 1
url = https://openjfx.io/
arch = x86_64
@@ -11,10 +11,12 @@ pkgbase = java-openjfx-ea-bin
depends = webkit2gtk
depends = ffmpeg
depends = qt5-base
- source = https://download2.gluonhq.com/openjfx/14/openjfx-14-ea+1_linux-x64_bin-sdk.zip
- source = https://download2.gluonhq.com/openjfx/14/openjfx-14-ea+1_linux-x64_bin-jmods.zip
- sha256sums = 9e60fff5fe550b3a7d97c39be0239764582647f5e1ba143ba44bef94cab7b441
- sha256sums = 827e49f70c4269f73eaf3a2aab51222679da839f4b76d35f928c2ed8730268b9
+ source = https://download2.gluonhq.com/openjfx/14/openjfx-14-ea+4_linux-x64_bin-sdk.zip
+ source = https://download2.gluonhq.com/openjfx/14/openjfx-14-ea+4_linux-x64_bin-jmods.zip
+ source = https://download2.gluonhq.com/openjfx/14/openjfx-14-ea+4-javadoc.zip
+ sha256sums = 8c3525c85598a9afa11ed0915331188ac3bafa0828d1e8f02a15e1c94d59d892
+ sha256sums = efa4b70ced3ec41856484748cae21d27c99b7aaa67b3c67928a3cac154db01d7
+ sha256sums = e9f557e24ee2c7f8f5c22a9585b20799e9f503510c7956eb2adc9163aaef020e
pkgname = java-openjfx-ea-bin
diff --git a/PKGBUILD b/PKGBUILD
index 075b0479b191..765235ebeaf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jamie Magee <jamie dot magee at gmail dot com>
pkgname=java-openjfx-ea-bin
_majorver=14
-_buildver=1
+_buildver=4
pkgver=${_majorver}rc${_buildver}
pkgrel=1
pkgdesc="Java OpenJFX ${_majorver} Early-Access Build."
@@ -11,9 +11,11 @@ url='https://openjfx.io/'
license=('GPL2')
depends=('java-openjdk-ea-bin' 'gstreamer' 'libxtst' 'webkit2gtk' 'ffmpeg' 'qt5-base')
source=("https://download2.gluonhq.com/openjfx/${_majorver}/openjfx-${_majorver}-ea+${_buildver}_linux-x64_bin-sdk.zip"
- "https://download2.gluonhq.com/openjfx/${_majorver}/openjfx-${_majorver}-ea+${_buildver}_linux-x64_bin-jmods.zip")
-sha256sums=('9e60fff5fe550b3a7d97c39be0239764582647f5e1ba143ba44bef94cab7b441'
- '827e49f70c4269f73eaf3a2aab51222679da839f4b76d35f928c2ed8730268b9')
+ "https://download2.gluonhq.com/openjfx/${_majorver}/openjfx-${_majorver}-ea+${_buildver}_linux-x64_bin-jmods.zip"
+ "https://download2.gluonhq.com/openjfx/${_majorver}/openjfx-${_majorver}-ea+${_buildver}-javadoc.zip")
+sha256sums=('8c3525c85598a9afa11ed0915331188ac3bafa0828d1e8f02a15e1c94d59d892'
+ 'efa4b70ced3ec41856484748cae21d27c99b7aaa67b3c67928a3cac154db01d7'
+ 'e9f557e24ee2c7f8f5c22a9585b20799e9f503510c7956eb2adc9163aaef020e')
_jvmdir=usr/lib/jvm/java-${_majorver}-openjdk
@@ -28,4 +30,8 @@ package() {
# Jmods
install -d "${pkgdir}/${_jvmdir}/jmods"
cp -a "javafx-jmods-${_majorver}/"* "${pkgdir}/${_jvmdir}/jmods/"
+ # Docs
+ install -d "${pkgdir}/usr/share/doc/java-openjfx-ea"
+ cp -a "javafx-${_majorver}-javadoc/"* "${pkgdir}/usr/share/doc/java-openjfx-ea/"
}
+# vim:set ts=2 sw=2 et: