summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-11-30 22:05:34 +0330
committerMohammadreza Abdollahzadeh2018-11-30 22:05:34 +0330
commit96b6bc2670b7bce4c7c857f79f85f9642ab61957 (patch)
treedfc1ca388713091333cdc554fb00b35a6da20b5b
parentb6ee2e473c0ced5e82f43c239557a3ea88fdaef4 (diff)
downloadaur-96b6bc2670b7bce4c7c857f79f85f9642ab61957.tar.gz
update to v12b3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 16 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e981ef8342da..8456d2f3a701 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = java-openjfx-ea-bin
- pkgdesc = Java OpenJFX 11 Early-Access Build from Oracle.
- pkgver = 11b25
+ pkgdesc = Java OpenJFX 12 Early-Access Build.
+ pkgver = 12b3
pkgrel = 1
url = http://jdk.java.net/openjfx/
arch = x86_64
@@ -11,12 +11,10 @@ pkgbase = java-openjfx-ea-bin
depends = webkit2gtk
depends = ffmpeg
depends = qt5-base
- source = https://download.java.net/java/early_access/openjfx11/25/binaries/openjfx-11-ea+25_linux-x64_bin-sdk.zip
- source = https://download.java.net/java/early_access/openjfx11/25/binaries/openjfx-11-ea+25_linux-x64_bin-jmods.zip
- source = https://download.java.net/java/early_access/openjfx11/25/binaries/openjfx-11-ea+25_doc-api.zip
- sha256sums = c149c4e346377fca1e474a915479d60774cad00b05048397dd2c62675a4f68ea
- sha256sums = a0147e4c919cecc89479a387a47ec289c2fd909d8278a3e379a6bef53a9e0e6c
- sha256sums = 52e38f360fd0e5665e858ac4681164c0162338a17f1ed1a4b3b91111cfe8be80
+ source = https://download2.gluonhq.com/openjfx/12/openjfx-12-ea+3_linux-x64_bin-sdk.zip
+ source = https://download2.gluonhq.com/openjfx/12/openjfx-12-ea+3_linux-x64_bin-jmods.zip
+ sha256sums = 297b56b130a12f29367aed2095f393482eef6a5cb9b7e6dd740a7fa9c71f3153
+ sha256sums = bf29e79e8f36416456806992465f4dab34e92fd9671d52ca2193a0cc2d100464
pkgname = java-openjfx-ea-bin
diff --git a/PKGBUILD b/PKGBUILD
index 19640ddd8405..b48e357e6331 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,21 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=java-openjfx-ea-bin
-_majorver=11
-_buildver=25
+_majorver=12
+_buildver=3
pkgver=${_majorver}b${_buildver}
pkgrel=1
-pkgdesc="Java OpenJFX ${_majorver} Early-Access Build from Oracle."
+pkgdesc="Java OpenJFX ${_majorver} Early-Access Build."
arch=('x86_64')
url='http://jdk.java.net/openjfx/'
license=('GPL2')
depends=('java-openjdk-ea-bin' 'gstreamer' 'libxtst' 'webkit2gtk' 'ffmpeg' 'qt5-base')
-_srcurl="https://download.java.net/java/early_access/openjfx${_majorver}/${_buildver}/binaries/openjfx-${_majorver}-ea+${_buildver}"
-source=("${_srcurl}_linux-x64_bin-sdk.zip"
- "${_srcurl}_linux-x64_bin-jmods.zip"
- "${_srcurl}_doc-api.zip"
-)
-sha256sums=('c149c4e346377fca1e474a915479d60774cad00b05048397dd2c62675a4f68ea'
- 'a0147e4c919cecc89479a387a47ec289c2fd909d8278a3e379a6bef53a9e0e6c'
- '52e38f360fd0e5665e858ac4681164c0162338a17f1ed1a4b3b91111cfe8be80')
+source=("https://download2.gluonhq.com/openjfx/${_majorver}/openjfx-${_majorver}-ea+${_buildver}_linux-x64_bin-sdk.zip"
+ "https://download2.gluonhq.com/openjfx/${_majorver}/openjfx-${_majorver}-ea+${_buildver}_linux-x64_bin-jmods.zip")
+sha256sums=('297b56b130a12f29367aed2095f393482eef6a5cb9b7e6dd740a7fa9c71f3153'
+ 'bf29e79e8f36416456806992465f4dab34e92fd9671d52ca2193a0cc2d100464')
-_jvmdir=usr/lib/jvm/java-${_majorver}-openjdk-ea
+_jvmdir=usr/lib/jvm/java-${_majorver}-openjdk
package() {
# Install
@@ -28,13 +24,10 @@ package() {
cp -a "javafx-sdk-${_majorver}/lib" "${pkgdir}/${_jvmdir}/"
mv "${pkgdir}/${_jvmdir}/lib/src.zip" "${pkgdir}/${_jvmdir}/lib/javafx-src.zip"
# Legal
- install -d "${pkgdir}/usr/share/licenses/java${_majorver}-openjdk-ea"
- cp -a "javafx-sdk-${_majorver}/legal" "${pkgdir}/usr/share/licenses/java${_majorver}-openjdk-ea/"
+ install -d "${pkgdir}/usr/share/licenses/java${_majorver}-openjdk"
+ cp -a "javafx-sdk-${_majorver}/legal" "${pkgdir}/usr/share/licenses/java${_majorver}-openjdk/"
# Jmods
install -d "${pkgdir}/${_jvmdir}/jmods"
cp -a "javafx-jmods-${_majorver}/"* "${pkgdir}/${_jvmdir}/jmods/"
- # Docs
- install -d "${pkgdir}/usr/share/doc/openjfx-ea"
- cp -a "javafx-docs-${_majorver}/"* "${pkgdir}/usr/share/doc/openjfx-ea/"
}
# vim:set ts=2 sw=2 et: