summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2024-01-19 13:43:20 +0100
committerFrederik “Freso” S. Olesen2024-01-19 13:43:20 +0100
commit08667cde99597039ba7e7800bdf3634fe88ce2b3 (patch)
treeabcc7c3ae3dcba36e7d3055709328d2fc355c546
parent152061030b69f84fb118af9b782f529fda3342dd (diff)
downloadaur-08667cde99597039ba7e7800bdf3634fe88ce2b3.tar.gz
Workaround build breaking without set C or LDFLAGS
Included java-openjfx-flags.patch makes calls to CFLAGS and LDFLAGS which will cause the build to break if they’re not set in a user’s makepkg.conf or otherwise.
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a500c856addc..3728d97306b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -72,6 +72,11 @@ prepare() {
build() {
cd $_jfxdir
+ # Workaround for users without set $CFLAGS and $LDFLAGS causing
+ # build to fail because of included java-openjfx-flags.patch
+ export CFLAGS=${CFLAGS:=}
+ export LDFLAGS=${LDFLAGS:=}
+
# Build with openjdk-17
export PATH="/usr/lib/jvm/java-17-openjdk/bin/:$PATH"