summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2024-04-21 08:40:30 +0200
committerFrederik “Freso” S. Olesen2024-04-21 08:40:30 +0200
commit215b70a8ff9dab50164cbd4fb71b7e846a9871fc (patch)
tree5b923a681ec1b465da6e423898929bab2fe736d9
parent63c4c9c0bf90cc7cc3a68c21e89b2f5cb1fc7222 (diff)
parent62829ecd24f10937ff1c0a28a0fa7be45c56c4db (diff)
downloadaur-215b70a8ff9dab50164cbd4fb71b7e846a9871fc.tar.gz
Merge (some) changes from java-openjfx
Notably: - $LDFLAGS whitespace normalisation - Disabling LTO - Updated maintainer line
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15ff71321ff7..be2f0830c7af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = java21-openjfx
pkgdesc = Java OpenJFX client application platform (open-source implementation of JavaFX) - latest version
pkgver = 21.0.3.u2
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.openjdk.java.net/display/OpenJFX/Main
arch = x86_64
arch = x86_64_v3
@@ -30,6 +30,7 @@ pkgbase = java21-openjfx
makedepends = unzip
makedepends = webkit2gtk
makedepends = zip
+ options = !lto
source = java-openjfx-21.0.3+2.tar.gz::https://github.com/openjdk/jfx21u/archive/refs/tags/21.0.3+2.tar.gz
source = gradle.properties
source = java-openjfx-flags.patch
diff --git a/PKGBUILD b/PKGBUILD
index 98bdea273af3..d0e1b4acf775 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
-# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
-# Maintainer: Frederik Schwan <freswa at archlinux dot org>
+# Maintainer: Frederik “Freso” S. Olesen <archlinux@freso.dk>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Frederik Schwan <freswa at archlinux dot org>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Guillaume Alaux <guillaume@archlinux.org>
# Contributor: William Gathoye <william + archlinux at gathoye dot be>
@@ -16,7 +17,7 @@ pkgname=(
java21-openjfx-src
)
pkgver=21.0.3.u2
-pkgrel=2
+pkgrel=3
pkgdesc="Java OpenJFX client application platform (open-source implementation of JavaFX) - latest version"
arch=(x86_64 x86_64_v3)
url=https://wiki.openjdk.java.net/display/OpenJFX/Main
@@ -47,6 +48,7 @@ makedepends=(
webkit2gtk
zip
)
+options=(!lto)
source=(
"${pkgbase/${pkgver%%.*}/}-${pkgver//.u/+}.tar.gz::https://github.com/openjdk/jfx${pkgver%%.*}u/archive/refs/tags/${pkgver//.u/+}.tar.gz"
gradle.properties
@@ -63,6 +65,11 @@ _jfxdir=jfx${pkgver%%.*}u-${pkgver//.u/-}
prepare() {
cd $_jfxdir
+ # Clean from potential previous runs
+ gradle --stop
+ rm -rf build
+ #gradle clean
+
ln -sf ../gradle.properties .
patch -Np1 -i ../java-openjfx-flags.patch
patch -Np1 -i ../java-openjfx-no-xlocale.patch
@@ -78,6 +85,9 @@ build() {
# build against ffmpeg4.4
export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
+ # Workaround for situation where the linker treats whitespace as arguments
+ export LDFLAGS="${LDFLAGS//+([[:space:]]|[[:blank:]])/ }"
+
gradle zips
}