summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Schwan2022-02-17 00:58:02 +0000
committerFrederik Schwan2022-02-17 00:58:02 +0000
commit84d56932f7b501092677deb74cea9b85f8ae0700 (patch)
tree8ec59df670bc1b1f877eb2451239f00d29bfc8e2
parent78f35029c2c607a875b37e7ca3277ae096bf488c (diff)
downloadaur-84d56932f7b501092677deb74cea9b85f8ae0700.tar.gz
rebuild against ffmpeg4.4 for ffmpeg5 release
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 260c2a2a3591..4c12f963f159 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Frederik Schwan <freswa at archlinux dot org>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Guillaume Alaux <guillaume@archlinux.org>
# Contributor: William Gathoye <william + archlinux at gathoye dot be>
# Contributor: Emanuel Couto <emanuel dot amaral dot couto at gmail dot com>
@@ -21,7 +22,7 @@ _patchver=1
_updatever=1
pkgver=${_majorver}.${_minorver}.${_securityver}.${_patchver}.u${_updatever}
#pkgver=${_majorver}.u${_updatever}
-pkgrel=1
+pkgrel=2
pkgdesc="Java OpenJFX ${_majorver} client application platform (open-source implementation of JavaFX)"
arch=(x86_64)
url=https://wiki.openjdk.java.net/display/OpenJFX/Main
@@ -31,7 +32,7 @@ makedepends=(
ant
cairo
cmake
- ffmpeg
+ ffmpeg4.4
freetype2
gradle
gdk-pixbuf2
@@ -60,7 +61,7 @@ source=(
)
sha256sums=('7398a87b1c1b593a2610ef84dd8b0fc31fc9a87dc5185ea4d1ef71b560920a5d'
'2622aa35d733cc69f4421f1cd053bf425e89f93141cb52c9f016a9b425fc0cb6'
- '26a11b7f9bdba382de16fea691d01de270e79b055f765f7475294dd69605604c'
+ 'c5a39e6782c952d346935e49ea08c723cc06e0347c486459d0bdeaf097a1ce51'
'220c63396561867a6d07ae81b6390160d8f91502587e4873998e3b7a83793a1c'
'd7f9db86854b1cb8ab973c2ff255e51a637b9c24af30144182202d33f01a9434')
@@ -77,6 +78,9 @@ prepare() {
build() {
cd jfx-${pkgver//.u/-}
+ # build against ffmpeg4.4
+ export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
+
gradle zips
}
@@ -84,7 +88,7 @@ package_java-openjfx() {
depends=(
alsa-lib
cairo
- ffmpeg
+ ffmpeg4.4
gdk-pixbuf2
glib2
gtk2