summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2019-06-03 20:29:52 +0000
committerMaxime Gauduin2019-06-03 20:29:52 +0000
commitf997fec90b76fc1f282fc7af6ede2282b29a052b (patch)
treee27eecc029bd03586fe0909430ebff960353989c
parent07cec961d32feabdd776610e5dc93b8de7bf45e2 (diff)
downloadaur-f997fec90b76fc1f282fc7af6ede2282b29a052b.tar.gz
upgpkg: 11.0.3.u1-1
-rw-r--r--17-gcc-compatibility.patch25
-rw-r--r--PKGBUILD184
-rw-r--r--gradle.properties5
-rw-r--r--java-openjfx-flags.patch227
-rw-r--r--java-openjfx-no-xlocale.patch16
5 files changed, 341 insertions, 116 deletions
diff --git a/17-gcc-compatibility.patch b/17-gcc-compatibility.patch
deleted file mode 100644
index 80015372e14a..000000000000
--- a/17-gcc-compatibility.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Description: Fixes a build error with GCC 6
-Author: Emmanuel Bourg <ebourg@apache.org>
-Forwarded: no
-Bug-Debian: https://bugs.debian.org/837021
-diff --git a/modules/fxpackager/src/main/native/library/common/PosixPlatform.cpp b/modules/fxpackager/src/main/native/library/common/PosixPlatform.cpp
-index 5c8f4b9..7c35213 100644
---- a/modules/fxpackager/src/main/native/library/common/PosixPlatform.cpp
-+++ b/modules/fxpackager/src/main/native/library/common/PosixPlatform.cpp
-@@ -46,6 +46,7 @@
- #include <iostream>
- #include <dlfcn.h>
- #include <signal.h>
-+#include <sys/wait.h>
-
-
- PosixPlatform::PosixPlatform(void) {
-@@ -232,7 +233,7 @@ bool PosixProcess::Wait() {
-
- //TODO Use waitpid instead of wait
- #ifdef LINUX
-- wait();
-+ wait(&status);
- #endif
- #ifdef MAC
- wpid = wait(&status);
diff --git a/PKGBUILD b/PKGBUILD
index 59a5ccffbdb6..7751e1df9e76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
+# Maintainer: Guillaume Alaux <guillaume@archlinux.org>
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: William Gathoye <william + archlinux at gathoye dot be>
# Contributor: Emanuel Couto <emanuel dot amaral dot couto at gmail dot com>
# Contributor: Richard Jackson <rdjack21 at gmail dot com>
@@ -6,109 +7,116 @@
# Contributor: Jens Kapitza <j dot kapitza at schwarze-allianz dot de>
# Contributor: Olli <olli at coderkun dot de>
-# Demos available in ``
-# To build and test this pakcage:
-# - install this version of java-openjfx
-# - cd apps/samples
-# - ant -Dplatforms.JDK_1.8.home=/usr/lib/jvm/default jar
-# - java -jar ./Ensemble8/dist/Ensemble8.jar
-# - java -jar ./Modena/dist/Modena.jar
-# - java -jar ./3DViewer/dist/3DViewer.jar
-
pkgbase=java-openjfx
-pkgname=('java-openjfx' 'java-openjfx-doc' 'java-openjfx-src')
-_java_ver=8
-_jdk_update=172
-_jdk_build=00
-_hgtag=${_java_ver}u${_jdk_update}-b${_jdk_build}
-pkgver=${_java_ver}.u${_jdk_update}
-pkgrel=2
-pkgdesc='Java OpenJFX 8 client application platform (open-source implementation of JavaFX)'
-arch=('x86_64')
-url='https://wiki.openjdk.java.net/display/OpenJFX/Main'
-license=('GPL')
-makedepends=('java-environment-openjdk=8' 'bison' 'gperf' 'gtk2'
- 'libxtst' 'ffmpeg' 'python2' 'qt5-base' 'webkit2gtk' 'ruby' 'cmake' 'unzip')
- # TODO add junit antlr3 swt so that they are not downloaed during the build
-source=(http://hg.openjdk.java.net/openjfx/8u-dev/rt/archive/${_hgtag}.tar.bz2
- gradle.properties
- https://services.gradle.org/distributions/gradle-1.8-bin.zip
- # https://anonscm.debian.org/cgit/pkg-java/openjfx.git/tree/debian/patches/17-gcc-compatibility.patch
- 17-gcc-compatibility.patch)
-
-sha256sums=('7d6aa064c1368dcba9c781083440368f835823e41b98ef61c4f0b6818484eb5a'
- '1d09385ac23d755aec079954247365de3875507641f5ecd7bd3511ebf3fa9e3c'
- 'a342bbfa15fd18e2482287da4959588f45a41b60910970a16e6d97959aea5703'
- '864967467efeaffdabe1e60b7cfd0a27ce93be55ef45ef9993790219ad164554')
-
-_openjdk8dir="/usr/lib/jvm/java-8-openjdk"
-
-case $CARCH in
- 'i686') _CARCH='i386' ;;
- 'x86_64')_CARCH='amd64' ;;
-esac
+pkgname=(
+ java-openjfx
+ java-openjfx-doc
+ java-openjfx-src
+)
+pkgver=11.0.3.u1
+pkgrel=1
+pkgdesc='Java OpenJFX 11 client application platform (open-source implementation of JavaFX)'
+arch=(x86_64)
+url=https://wiki.openjdk.java.net/display/OpenJFX/Main
+license=(custom)
+makedepends=(
+ alsa-lib
+ ant
+ cairo
+ cmake
+ ffmpeg
+ freetype2
+ gdk-pixbuf2
+ glib2
+ gperf
+ gtk2
+ gtk3
+ java-environment-openjdk=11
+ libgl
+ libx11
+ libxtst
+ pango
+ python2
+ qt5-base
+ ruby
+ unzip
+ webkit2gtk
+ zip
+)
+source=(
+ https://hg.openjdk.java.net/openjfx/11/rt/archive/${pkgver//.u/+}.tar.bz2
+ gradle.properties
+ https://services.gradle.org/distributions/gradle-4.8-bin.zip
+ java-openjfx-flags.patch
+ java-openjfx-no-xlocale.patch
+)
+sha256sums=('c4a42e9f7ac94ca3b05b363375f782bc79be9446bee23eb94e6175a97b5262ae'
+ '2622aa35d733cc69f4421f1cd053bf425e89f93141cb52c9f016a9b425fc0cb6'
+ 'f3e29692a8faa94eb0b02ebf36fa263a642b3ae8694ef806c45c345b8683f1ba'
+ '62d7356654b541a9f868cc7beb185e64a1375d9a734b906ba00eacbee258d16e'
+ '220c63396561867a6d07ae81b6390160d8f91502587e4873998e3b7a83793a1c')
prepare() {
- cd "rt-${_hgtag}"
- patch -p1 < "${srcdir}/17-gcc-compatibility.patch"
+ cd rt-${pkgver//.u/+}
+
+ ln -sf ../gradle.properties .
+ patch -Np1 -i ../java-openjfx-flags.patch
+ patch -Np1 -i ../java-openjfx-no-xlocale.patch
}
build() {
- cd "rt-${_hgtag}"
-
- ln -sf "${srcdir}/gradle.properties" .
- export GRADLE_USER_HOME="${srcdir}/gradle_home"
- mkdir -p ${GRADLE_USER_HOME}
+ cd rt-${pkgver//.u/+}
- "${srcdir}"/gradle-1.8/bin/gradle
+ ../gradle-4.8/bin/gradle zips
}
package_java-openjfx() {
- pkgdesc='Java OpenJFX 8 client application platform (open-source implementation of JavaFX)'
- depends=('java-runtime-openjdk=8' 'gstreamer' 'libxtst' 'webkit2gtk' 'ffmpeg' 'qt5-base')
- conflicts=('openjfx')
- replaces=('openjfx')
-
- local _builddir="${srcdir}/rt-${_hgtag}/build"
- local _sdkdir="${_builddir}/sdk"
-
- install -d "${pkgdir}${_openjdk8dir}/jre/lib/${_CARCH}"
- install -m755 "${_sdkdir}/rt/lib/${_CARCH}"/*.* "${pkgdir}${_openjdk8dir}/jre/lib/${_CARCH}"
-
- install -d "${pkgdir}${_openjdk8dir}/jre/lib/ext"
- install -m644 "${_sdkdir}/rt/lib/ext"/*.* "${pkgdir}${_openjdk8dir}/jre/lib/ext"
- install -m644 "${_sdkdir}/rt/lib"/*.* "${pkgdir}${_openjdk8dir}/jre/lib"
-
- install -d "${pkgdir}${_openjdk8dir}/lib"
- install -m644 "${_sdkdir}/lib"/*.* "${pkgdir}${_openjdk8dir}/lib"
-
- install -d "${pkgdir}${_openjdk8dir}/bin"
- install -m755 "${_sdkdir}/bin"/* "${pkgdir}${_openjdk8dir}/bin"
-
- install -m644 -D "${_sdkdir}/man/man1/javapackager.1" "${pkgdir}/usr/share/man/man1/javapackager.1"
+ depends=(
+ alsa-lib
+ cairo
+ ffmpeg
+ gdk-pixbuf2
+ glib2
+ gtk2
+ gtk3
+ java-runtime-openjdk=11
+ libavcodec.so
+ libavformat.so
+ libfreetype.so
+ libgl
+ libx11
+ libxtst
+ pango
+ python2
+ qt5-base
+ ruby
+ unzip
+ webkit2gtk
+ )
+
+ cd rt-${pkgver//.u/+}
+
+ install -dm 755 "${pkgdir}"/usr/{lib/jvm/java-11-openjdk,share/licenses}
+ cp -dr --no-preserve=ownership build/sdk/lib "${pkgdir}"/usr/lib/jvm/java-11-openjdk/
+ rm "${pkgdir}"/usr/lib/jvm/java-11-openjdk/lib/src.zip
+ cp -dr --no-preserve=ownership build/jmods "${pkgdir}"/usr/lib/jvm/java-11-openjdk/
+ cp -dr --no-preserve=ownership build/sdk/legal "${pkgdir}"/usr/share/licenses/java-openjfx
}
package_java-openjfx-doc() {
- pkgdesc='Java OpenJFX 8 client application platform (open-source implementation of JavaFX) - documentation'
- conflicts=('openjfx-doc')
- replaces=('openjfx-doc')
+ cd rt-${pkgver//.u/+}
- local _builddir="${srcdir}/rt-${_hgtag}/build"
- local _sdkdir="${_builddir}/sdk"
- local docdir="/usr/share/doc"
-
- install -d "${pkgdir}${docdir}/openjfx"
- cp -dr --no-preserve=ownership "${_builddir}/javadoc"/* "${pkgdir}${docdir}/openjfx"
+ install -dm 755 "${pkgdir}"/usr/share/{doc,licenses}
+ cp -dr --no-preserve=ownership build/javadoc "${pkgdir}"/usr/share/doc/java-openjfx
+ ln -s java-openjfx "${pkgdir}"/usr/share/licenses/java-openjfx-doc
}
package_java-openjfx-src() {
- pkgdesc='Java OpenJFX 8 client application platform (open-source implementation of JavaFX) - sources'
- conflicts=('openjfx-src')
- replaces=('openjfx-src')
-
- local _builddir="${srcdir}/rt-${_hgtag}/build"
- local _sdkdir="${_builddir}/sdk"
+ cd rt-${pkgver//.u/+}
- install -d "${pkgdir}${_openjdk8dir}"
- install -m644 "${_builddir}/javafx-src.zip" "${pkgdir}${_openjdk8dir}"
+ install -dm 755 "${pkgdir}"/usr/{lib/jvm/java-11-openjdk,share/licenses}
+ install -m 644 build/sdk/lib/src.zip "${pkgdir}"/usr/lib/jvm/java-11-openjdk/javafx-src.zip
+ ln -s java-openjfx "${pkgdir}"/usr/share/licenses/java-openjfx-src
}
+
+# vim: ts=2 sw=2 et:
diff --git a/gradle.properties b/gradle.properties
index c9d679838074..56d468493e61 100644
--- a/gradle.properties
+++ b/gradle.properties
@@ -1,4 +1,3 @@
-COMPILE_WEBKIT = true
COMPILE_MEDIA = true
-BUILD_JAVADOC = true
-BUILD_SRC_ZIP = true
+COMPILE_WEBKIT = true
+CONF = Release
diff --git a/java-openjfx-flags.patch b/java-openjfx-flags.patch
new file mode 100644
index 000000000000..2339f905b7fa
--- /dev/null
+++ b/java-openjfx-flags.patch
@@ -0,0 +1,227 @@
+From a28f9aaab759d82384279c16d86bb98ab47412a3 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Sat, 1 Jun 2019 00:12:55 -0700
+Subject: [PATCH] respect user cflags
+
+---
+ buildSrc/linux.gradle | 7 ++++++-
+ .../gstreamer/projects/linux/avplugin/Makefile | 16 ++++++----------
+ .../gstreamer/projects/linux/fxplugins/Makefile | 17 ++++++-----------
+ .../projects/linux/gstreamer-lite/Makefile | 16 ++++++----------
+ .../native/jfxmedia/projects/linux/Makefile | 16 ++++++----------
+ 5 files changed, 30 insertions(+), 42 deletions(-)
+
+diff --git a/buildSrc/linux.gradle b/buildSrc/linux.gradle
+index 7a7cbc72..6705a0f3 100644
+--- a/buildSrc/linux.gradle
++++ b/buildSrc/linux.gradle
+@@ -44,8 +44,11 @@ LINUX.library = { name -> return "lib${name}.so" as String }
+ def commonFlags = [
+ "-fno-strict-aliasing", "-fPIC", "-fno-omit-frame-pointer", // optimization flags
+ "-fstack-protector",
++ "-Wno-error=cast-function-type",
+ "-Wextra", "-Wall", "-Wformat-security", "-Wno-unused", "-Wno-parentheses", "-Werror=implicit-function-declaration"] // warning flags
+
++commonFlags.addAll(System.getenv("CFLAGS").trim().split(" "))
++
+ if (!IS_64) {
+ commonFlags += "-m32"
+ }
+@@ -61,6 +64,8 @@ def linkFlags = ["-static-libgcc", "-static-libstdc++", "-shared", commonFlags,
+ "-z", "relro",
+ "-Wl,--gc-sections"].flatten()
+
++linkFlags.addAll(System.getenv("LDFLAGS").trim().split(" "))
++
+ if (IS_DEBUG_NATIVE) {
+ linkFlags += "-g"
+ }
+@@ -294,7 +299,7 @@ LINUX.iio.nativeSource = [
+ LINUX.iio.compiler = compiler
+ LINUX.iio.ccFlags = [ccFlags].flatten()
+ LINUX.iio.linker = linker
+-LINUX.iio.linkFlags = [linkFlags].flatten()
++LINUX.iio.linkFlags = [linkFlags, "-ljpeg"].flatten()
+ LINUX.iio.lib = "javafx_iio"
+
+ LINUX.prismES2 = [:]
+diff --git a/modules/javafx.media/src/main/native/gstreamer/projects/linux/avplugin/Makefile b/modules/javafx.media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
+index 450b55d3..f27b9479 100644
+--- a/modules/javafx.media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
++++ b/modules/javafx.media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
+@@ -17,7 +17,7 @@ TARGET = $(BUILD_DIR)/lib$(BASE_NAME).so
+ OBJBASE_DIR = $(BUILD_DIR)/obj/plugins/avplugin
+ endif
+
+-CFLAGS = -fPIC \
++CFLAGS := -fPIC \
+ -Wformat \
+ -Wextra \
+ -Wformat-security \
+@@ -29,13 +29,8 @@ CFLAGS = -fPIC \
+ -DLINUX \
+ -DGST_DISABLE_LOADSAVE \
+ -DGSTREAMER_LITE \
+- -ffunction-sections -fdata-sections
+-
+-ifeq ($(BUILD_TYPE), Release)
+- CFLAGS += -Os
+-else
+- CFLAGS += -g -Wall
+-endif
++ -ffunction-sections -fdata-sections \
++ ${CFLAGS}
+
+ PACKAGES_INCLUDES := $(shell pkg-config --cflags glib-2.0)
+ PACKAGES_LIBS := $(shell pkg-config --libs glib-2.0 gobject-2.0)
+@@ -46,11 +41,12 @@ INCLUDES= -I../../../plugins \
+ -I../../../gstreamer-lite/gstreamer/libs \
+ $(PACKAGES_INCLUDES)
+
+-LDFLAGS = -L$(BUILD_DIR) \
++LDFLAGS := -L$(BUILD_DIR) \
+ -lgstreamer-lite \
+ $(PACKAGES_LIBS) \
+ -z relro \
+- -static-libgcc -static-libstdc++ -Wl,--gc-sections
++ -static-libgcc -static-libstdc++ -Wl,--gc-sections \
++ ${LDFLAGS}
+
+ ifneq ($(strip $(LIBAV_DIR)),)
+ INCLUDES += -I$(LIBAV_DIR)/include
+diff --git a/modules/javafx.media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile b/modules/javafx.media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
+index 1e58d4d3..627865f9 100644
+--- a/modules/javafx.media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
++++ b/modules/javafx.media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
+@@ -14,7 +14,7 @@ DIRLIST = progressbuffer \
+
+ TARGET = $(BUILD_DIR)/lib$(BASE_NAME).so
+
+-CFLAGS = -fPIC \
++CFLAGS := -fPIC \
+ -Wformat \
+ -Wextra \
+ -Wformat-security \
+@@ -30,14 +30,8 @@ CFLAGS = -fPIC \
+ -DGST_DISABLE_LOADSAVE \
+ -DGST_DISABLE_GST_DEBUG \
+ -DGSTREAMER_LITE \
+- -ffunction-sections -fdata-sections
+-
+-ifeq ($(BUILD_TYPE), Release)
+- CFLAGS += -Os
+-else
+- CFLAGS += -g -Wall
+-endif
+-
++ -ffunction-sections -fdata-sections \
++ ${CFLAGS}
+
+ INCLUDES = -I$(SRCBASE_DIR) \
+ $(addprefix -I$(SRCBASE_DIR)/,$(DIRLIST)) \
+@@ -47,9 +41,10 @@ INCLUDES = -I$(SRCBASE_DIR) \
+ PACKAGES_INCLUDES := $(shell pkg-config --cflags glib-2.0)
+ PACKAGES_LIBS := $(shell pkg-config --libs glib-2.0 gobject-2.0)
+
+-LDFLAGS = -L$(BUILD_DIR) -lgstreamer-lite $(PACKAGES_LIBS) \
++LDFLAGS := -L$(BUILD_DIR) -lgstreamer-lite $(PACKAGES_LIBS) \
+ -z relro \
+- -static-libgcc -static-libstdc++ -Wl,--gc-sections
++ -static-libgcc -static-libstdc++ -Wl,--gc-sections \
++ ${LDFLAGS}
+
+ ifeq ($(ARCH), x32)
+ CFLAGS += -m32
+diff --git a/modules/javafx.media/src/main/native/gstreamer/projects/linux/gstreamer-lite/Makefile b/modules/javafx.media/src/main/native/gstreamer/projects/linux/gstreamer-lite/Makefile
+index 5baa30a1..ddf0e521 100644
+--- a/modules/javafx.media/src/main/native/gstreamer/projects/linux/gstreamer-lite/Makefile
++++ b/modules/javafx.media/src/main/native/gstreamer/projects/linux/gstreamer-lite/Makefile
+@@ -37,7 +37,7 @@ DIRLIST = gstreamer/gst \
+
+ TARGET = $(BUILD_DIR)/lib$(BASE_NAME).so
+
+-CFLAGS =-fPIC \
++CFLAGS :=-fPIC \
+ -Wformat \
+ -Wextra \
+ -Wformat-security \
+@@ -51,13 +51,8 @@ CFLAGS =-fPIC \
+ -DLINUX \
+ -DGST_DISABLE_GST_DEBUG \
+ -DGST_DISABLE_LOADSAVE \
+- -ffunction-sections -fdata-sections
+-
+-ifeq ($(BUILD_TYPE), Release)
+- CFLAGS += -Os
+-else
+- CFLAGS += -g -Wall
+-endif
++ -ffunction-sections -fdata-sections \
++ ${CFLAGS}
+
+ INCLUDES = -I$(BASE_DIR)/plugins \
+ -I$(SRCBASE_DIR)/projects/build/linux/common \
+@@ -75,9 +70,10 @@ INCLUDES = -I$(BASE_DIR)/plugins \
+ PACKAGES_INCLUDES := $(shell pkg-config --cflags alsa glib-2.0)
+ PACKAGES_LIBS := $(shell pkg-config --libs alsa glib-2.0 gobject-2.0 gmodule-2.0 gthread-2.0)
+
+-LDFLAGS = -L$(BUILD_DIR) -lm $(PACKAGES_LIBS) \
++LDFLAGS := -L$(BUILD_DIR) -lm $(PACKAGES_LIBS) \
+ -z relro \
+- -static-libgcc -static-libstdc++ -Wl,--gc-sections
++ -static-libgcc -static-libstdc++ -Wl,--gc-sections \
++ ${LDFLAGS}
+
+ ifeq ($(ARCH), x32)
+ CFLAGS += -m32
+diff --git a/modules/javafx.media/src/main/native/jfxmedia/projects/linux/Makefile b/modules/javafx.media/src/main/native/jfxmedia/projects/linux/Makefile
+index ecbd859f..5881cf53 100644
+--- a/modules/javafx.media/src/main/native/jfxmedia/projects/linux/Makefile
++++ b/modules/javafx.media/src/main/native/jfxmedia/projects/linux/Makefile
+@@ -17,7 +17,7 @@ DIRLIST = jni \
+
+ TARGET = $(BUILD_DIR)/lib$(BASE_NAME).so
+
+-CFLAGS = -DTARGET_OS_LINUX=1 \
++CFLAGS := -DTARGET_OS_LINUX=1 \
+ -D_GNU_SOURCE \
+ -DGST_REMOVE_DEPRECATED \
+ -DGST_DISABLE_GST_DEBUG \
+@@ -26,7 +26,8 @@ CFLAGS = -DTARGET_OS_LINUX=1 \
+ -DHAVE_CONFIG_H \
+ -DJFXMEDIA_JNI_EXPORTS \
+ -DLINUX \
+- -ffunction-sections -fdata-sections
++ -ffunction-sections -fdata-sections \
++ ${CFLAGS}
+
+ CPPFLAGS = -fno-rtti -ffunction-sections -fdata-sections
+
+@@ -56,21 +57,16 @@ ifdef HOST_COMPILE
+ -I$(GSTREAMER_LITE_DIR)/gstreamer/libs \
+ $(PACKAGES_INCLUDES)
+
+- LDFLAGS = -Wl,-rpath,\$$ORIGIN -L$(BUILD_DIR) -lgstreamer-lite $(PACKAGES_LIBS) \
++ LDFLAGS := -Wl,-rpath,\$$ORIGIN -L$(BUILD_DIR) -lgstreamer-lite $(PACKAGES_LIBS) \
+ -z relro \
+- -static-libgcc -static-libstdc++ -Wl,--gc-sections
++ -static-libgcc -static-libstdc++ -Wl,--gc-sections \
++ ${LDFLAGS}
+ else
+ CFLAGS += $(EXTRA_CFLAGS)
+ INCLUDES = $(BASE_INCLUDES)
+ LDFLAGS = -Wl,-rpath,\$$ORIGIN -L$(BUILD_DIR) $(EXTRA_LDFLAGS)
+ endif
+
+-ifeq ($(BUILD_TYPE), Release)
+- CFLAGS += -Os
+-else
+- CFLAGS += -g -Wall -D_DEBUG
+-endif
+-
+ ifeq ($(ARCH), x32)
+ CFLAGS += -m32
+ LDFLAGS += -m32
+--
+2.21.0
+
diff --git a/java-openjfx-no-xlocale.patch b/java-openjfx-no-xlocale.patch
new file mode 100644
index 000000000000..da3ac418836f
--- /dev/null
+++ b/java-openjfx-no-xlocale.patch
@@ -0,0 +1,16 @@
+Description: Fixes the compatibility with the version of glibc in Debian
+Author: Emmanuel Bourg <ebourg@apache.org>
+Forwarded: https://bugs.openjdk.java.net/browse/JDK-8211399
+--- a/modules/javafx.web/src/main/native/Source/ThirdParty/libxslt/src/libxslt/xsltlocale.h
++++ b/modules/javafx.web/src/main/native/Source/ThirdParty/libxslt/src/libxslt/xsltlocale.h
+@@ -25,9 +25,6 @@
+ #ifdef HAVE_LOCALE_H
+ #include <locale.h>
+ #endif
+-#ifdef HAVE_XLOCALE_H
+-#include <xlocale.h>
+-#endif
+
+ typedef locale_t xsltLocale;
+ typedef xmlChar xsltLocaleChar;
+