summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Pronko2023-01-25 16:40:53 +0400
committerPlaton Pronko2023-01-25 16:40:53 +0400
commitec5bb42a623929552a5e1e0cc6a4ad147b47f08c (patch)
tree6a501e4e454f52735bdf2fecfb9870f7806cd318
parentb38363c8e95a9407622766b10a8ef3412565d5c3 (diff)
downloadaur-ec5bb42a623929552a5e1e0cc6a4ad147b47f08c.tar.gz
fix build (thanks to @hawath)
- add dependency on python2 - add patch to include iterator
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--java8-openjfx-include-iterator.patch23
3 files changed, 33 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4b2e5fa1bca..c3b504af525e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = java8-openjfx
pkgdesc = Java OpenJFX 8 client application platform (open-source implementation of JavaFX)
pkgver = 8.u202
- pkgrel = 4
+ pkgrel = 5
url = https://wiki.openjdk.java.net/display/OpenJFX/Main
arch = x86_64
license = GPL
@@ -33,6 +33,7 @@ pkgbase = java8-openjfx
source = java8-openjfx-no-sys-sysctl.patch
source = java8-openjfx-CVE-2021-3517-fix.patch::https://gitlab.gnome.org/GNOME/libxml2/-/commit/bf22713507fe1fc3a2c4b525cf0a88c2dc87a3a2.patch
source = java8-openjfx-CVE-2021-3522-fix.patch::https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/commit/8a88e5c1db05ebadfd4569955f6f47c23cdca3c4.patch
+ source = java8-openjfx-include-iterator.patch
sha256sums = 12b0538d04c4bd451e4692ee06357ac36233ff4ec2af9fa3b9bbdbab48c3f2fc
sha256sums = d1c2255893e5ec6268d7c92bb6539cde629d325872f26cffb5f1f616c9d5f30d
sha256sums = f3e29692a8faa94eb0b02ebf36fa263a642b3ae8694ef806c45c345b8683f1ba
@@ -41,6 +42,7 @@ pkgbase = java8-openjfx
sha256sums = cd1a2bd60f636662e4f3334217b3e14f1d51cf30b77b9ca3eff8d030312fd26a
sha256sums = 4db6e995d46f5ab29c4169dab5dbbe367ebd01dee66ef1750abe5cf0c8364d42
sha256sums = 3487eb180fff9866c8b8b08be45f13fa9e8edd04e5719bc867e59b09b81954b4
+ sha256sums = bd69e8a3363f9b3ade50fb29d4c9e3d7e59b42472ae00d425d20ddcda720b919
pkgname = java8-openjfx
depends = java-runtime-openjdk=8
@@ -52,7 +54,3 @@ pkgname = java8-openjfx
optdepends = gtk3: GTK3 support,
optdepends = webkit2gtk: Web support
provides = java-openjfx=8
-
-pkgname = java8-openjfx-doc
-
-pkgname = java8-openjfx-src
diff --git a/PKGBUILD b/PKGBUILD
index b566ba25988f..3a1e389fc0b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,11 +12,11 @@
pkgbase=java8-openjfx
pkgname=(
java8-openjfx
- java8-openjfx-doc
- java8-openjfx-src
+ # java8-openjfx-doc
+ # java8-openjfx-src
)
pkgver=8.u202
-pkgrel=4
+pkgrel=5
pkgdesc='Java OpenJFX 8 client application platform (open-source implementation of JavaFX)'
arch=(x86_64)
url=https://wiki.openjdk.java.net/display/OpenJFX/Main
@@ -52,6 +52,7 @@ source=(
java8-openjfx-no-sys-sysctl.patch
java8-openjfx-CVE-2021-3517-fix.patch::https://gitlab.gnome.org/GNOME/libxml2/-/commit/bf22713507fe1fc3a2c4b525cf0a88c2dc87a3a2.patch
java8-openjfx-CVE-2021-3522-fix.patch::https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/-/commit/8a88e5c1db05ebadfd4569955f6f47c23cdca3c4.patch
+ java8-openjfx-include-iterator.patch
)
sha256sums=('12b0538d04c4bd451e4692ee06357ac36233ff4ec2af9fa3b9bbdbab48c3f2fc'
'd1c2255893e5ec6268d7c92bb6539cde629d325872f26cffb5f1f616c9d5f30d'
@@ -60,7 +61,8 @@ sha256sums=('12b0538d04c4bd451e4692ee06357ac36233ff4ec2af9fa3b9bbdbab48c3f2fc'
'b21f6b254acc7aa2124521b6521d3bdfdfcfd9b062624a84ef73608120957d0d'
'cd1a2bd60f636662e4f3334217b3e14f1d51cf30b77b9ca3eff8d030312fd26a'
'4db6e995d46f5ab29c4169dab5dbbe367ebd01dee66ef1750abe5cf0c8364d42'
- '3487eb180fff9866c8b8b08be45f13fa9e8edd04e5719bc867e59b09b81954b4')
+ '3487eb180fff9866c8b8b08be45f13fa9e8edd04e5719bc867e59b09b81954b4'
+ 'bd69e8a3363f9b3ade50fb29d4c9e3d7e59b42472ae00d425d20ddcda720b919')
prepare() {
cd rt-${pkgver//./}-ga
@@ -72,6 +74,7 @@ prepare() {
# loose match the following patch due to whitespace differences
patch -Np1 -l -i "$srcdir"/java8-openjfx-CVE-2021-3517-fix.patch -d modules/web/src/main/native/Source/ThirdParty/libxml/src
patch -Np1 -i "$srcdir"/java8-openjfx-CVE-2021-3522-fix.patch -d modules/media/src/main/native/gstreamer/gstreamer-lite/gst-plugins-base
+ patch -Np1 -i ../java8-openjfx-include-iterator.patch
}
build() {
diff --git a/java8-openjfx-include-iterator.patch b/java8-openjfx-include-iterator.patch
new file mode 100644
index 000000000000..20923d119ce8
--- /dev/null
+++ b/java8-openjfx-include-iterator.patch
@@ -0,0 +1,23 @@
+# This patch resolves missing <iterator> header for std::begin and std::end methods
+diff --color -Naur orig/modules/web/src/main/native/Source/WTF/wtf/text/IntegerToStringConversion.h modi/modules/web/src/main/native/Source/WTF/wtf/text/IntegerToStringConversion.h
+--- orig/modules/web/src/main/native/Source/WTF/wtf/text/IntegerToStringConversion.h 2018-12-10 11:30:22.000000000 -0500
++++ modi/modules/web/src/main/native/Source/WTF/wtf/text/IntegerToStringConversion.h 2022-11-25 00:47:42.329008410 -0500
+@@ -22,6 +22,7 @@
+ #ifndef IntegerToStringConversion_h
+ #define IntegerToStringConversion_h
+
++#include <iterator>
+ #include <wtf/text/LChar.h>
+
+ namespace WTF {
+diff --color -Naur orig/modules/web/src/main/native/Source/WTF/wtf/Vector.h modi/modules/web/src/main/native/Source/WTF/wtf/Vector.h
+--- orig/modules/web/src/main/native/Source/WTF/wtf/Vector.h 2018-12-10 11:30:22.000000000 -0500
++++ modi/modules/web/src/main/native/Source/WTF/wtf/Vector.h 2022-11-25 00:46:29.669026912 -0500
+@@ -22,6 +22,7 @@
+ #define WTF_Vector_h
+
+ #include <initializer_list>
++#include <iterator>
+ #include <limits>
+ #include <string.h>
+ #include <type_traits>