summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-08-19 08:57:53 +0200
committerJ5lx2015-08-19 08:57:53 +0200
commit774ab5a01afc8e97da1956ecf31390aafc7f9969 (patch)
tree93cff18eb55eb54e29f9fe3f865f924014b0741d
downloadaur-774ab5a01afc8e97da1956ecf31390aafc7f9969.tar.gz
r840-1: Initial package release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
-rw-r--r--install-lib.patch12
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54b24914b456
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = jazz
+ pkgdesc = A fairly standard chess program
+ pkgver = r840
+ pkgrel = 1
+ url = http://www.eglebbk.dds.nl/program/chess-index.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ source = http://www.eglebbk.dds.nl/program/download/jazz-840-src.tar.gz
+ source = install-lib.patch
+ md5sums = 0a5cfb8b90aca975ab651f53a12f78bc
+ md5sums = c9027d0eb853221601ad0d4886c1699e
+
+pkgname = jazz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fa678dd2779
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=jazz
+pkgver=r840
+pkgrel=1
+pkgdesc="A fairly standard chess program"
+arch=('i686' 'x86_64')
+url="http://www.eglebbk.dds.nl/program/chess-index.html"
+license=('GPL3')
+makedepends=('cmake')
+source=("http://www.eglebbk.dds.nl/program/download/${pkgname}-${pkgver#r}-src.tar.gz"
+ "install-lib.patch")
+md5sums=('0a5cfb8b90aca975ab651f53a12f78bc'
+ 'c9027d0eb853221601ad0d4886c1699e')
+
+prepare() {
+ cd "${srcdir}/Jazz"
+
+ patch -Np1 -i "${srcdir}/install-lib.patch"
+}
+
+build() {
+ cd "${srcdir}/Jazz"
+
+ [ -d build ] && rm -rf build
+ mkdir build && cd build
+ # GUI requires at least Allegro 5.1 which is still unstable atm
+ # UCI just fails, need to find out why
+ cmake .. \
+ -DWANT_DYNAMIC=ON \
+ -DWANT_GUI=OFF \
+ -DWANT_UCI=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/Jazz/build"
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/install-lib.patch b/install-lib.patch
new file mode 100644
index 000000000000..281c50c3db9e
--- /dev/null
+++ b/install-lib.patch
@@ -0,0 +1,12 @@
+diff -aur package.pristine/CMakeLists.txt package.new/CMakeLists.txt
+--- package.pristine/CMakeLists.txt 2015-08-19 08:30:39.696261908 +0200
++++ package.new/CMakeLists.txt 2015-08-19 08:51:24.487169332 +0200
+@@ -324,7 +324,7 @@
+ endif(WANT_RELEASE)
+
+ # Installation targets
+-install (TARGETS "xbjazz" RUNTIME DESTINATION "bin")
++install (TARGETS "jazz" "xbjazz" LIBRARY DESTINATION "lib" RUNTIME DESTINATION "bin")
+ install (FILES "${CMAKE_SOURCE_DIR}/misc/jazz.eng" DESTINATION "share/games/plugins/xboard/")
+ install (FILES "${CMAKE_SOURCE_DIR}/misc/jazz_logo0.png" DESTINATION "share/games/plugins/logos/")
+