summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormyself6002022-11-29 13:39:10 +0100
committermyself6002022-11-29 13:39:10 +0100
commiteb8bb970c5b81eee44bc3dc70929df96d93c6fb0 (patch)
tree1c921484b8cd2f088dd1ac95309af18727e0b600
parent4eb84c95feb03722aa472f278f977a0af96be0cc (diff)
downloadaur-eb8bb970c5b81eee44bc3dc70929df96d93c6fb0.tar.gz
Add shareware demo
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
-rwxr-xr-xjazz2.desktop2
-rw-r--r--jazz2.install2
-rw-r--r--jazz2.pngbin444 -> 439 bytes
-rw-r--r--jazz2.sh5
6 files changed, 32 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8370cb69c68..d347b8811af9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jazz2-git
pkgdesc = Jazz² Resurrection - Open-source Jazz Jackrabbit 2 reimplementation
- pkgver = 1.0.0+r18.ff65dae
+ pkgver = 1.2.0+r9.49bb290
pkgrel = 1
url = http://deat.tk/jazz2/
install = jazz2.install
@@ -15,10 +15,14 @@ pkgbase = jazz2-git
depends = openal
conflicts = jazz2-bin
source = git+https://github.com/deathkiller/jazz2-native.git
+ source = https://archive.org/download/j2r_demo/Games.7z
+ source = jazz2.sh
source = jazz2.png
source = jazz2.desktop
md5sums = SKIP
- md5sums = 4f9c50d3c78231f459481eab9d654919
- md5sums = f603149c956a00b03f28fc7215a460b6
+ md5sums = 434cf49487f0995d4d42aecc6e85d966
+ md5sums = d569f65a05b3fc80bfcf036cc2ef6cc8
+ md5sums = 10883cc01ae3a287a5804153092af9dd
+ md5sums = da8320edf25369c409cb98f662b04db2
pkgname = jazz2-git
diff --git a/PKGBUILD b/PKGBUILD
index bf560d39fe22..acd54a99cef3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=jazz2-git
-pkgver=1.0.0+r18.ff65dae
+pkgver=1.2.0+r9.49bb290
pkgrel=1
pkgdesc="Jazz² Resurrection - Open-source Jazz Jackrabbit 2 reimplementation"
arch=(x86_64 aarch64)
@@ -10,24 +10,27 @@ makedepends=(mesa cmake glfw)
conflicts=(jazz2-bin)
install=jazz2.install
source=(
- git+https://github.com/deathkiller/jazz2-native.git
- jazz2.{png,desktop})
+ git+https://github.com/deathkiller/jazz2-native.git
+ https://archive.org/download/j2r_demo/Games.7z # https://www.pukenukem.com/downloads/tsfdemo.exe, https://archive.org/download/JazzJackrabbit2Demo/J2swc123.exe
+ jazz2.{sh,png,desktop})
md5sums=(
- SKIP
- 4f9c50d3c78231f459481eab9d654919
- f603149c956a00b03f28fc7215a460b6)
+ SKIP
+ 434cf49487f0995d4d42aecc6e85d966
+ d569f65a05b3fc80bfcf036cc2ef6cc8
+ 10883cc01ae3a287a5804153092af9dd
+ da8320edf25369c409cb98f662b04db2)
pkgver(){
- cd jazz2-native
- git describe --tags|sed 's/-\(.*\)-g/+r\1./'
+ cd jazz2-native
+ git describe --tags|sed 's/-\(.*\)-g/+r\1./'
}
build(){
- cd jazz2-native
- sh BuildLinuxGcc.sh
+ cd jazz2-native
+ sh BuildLinuxGcc.sh
}
package(){
- install Jazz2-LinuxGcc-Release/jazz2 -Dt $pkgdir/usr/bin
- mkdir -p "$pkgdir/usr/share/Jazz² Resurrection"
- cp -r jazz2-native/Content "$pkgdir/usr/share/Jazz² Resurrection"
- install jazz2.png -Dt $pkgdir/usr/share/pixmaps
- install jazz2.desktop -Dt $pkgdir/usr/share/applications
+ install Jazz2-LinuxGcc-Release/jazz2 jazz2.sh -Dt "$pkgdir"/usr/bin
+ install "Games/Jazz2 Secret Files Demo/"* -Dt "$pkgdir/usr/share/Jazz² Resurrection/Source"
+ cp -r jazz2-native/Content Games/Jazz2Sw/* "$pkgdir/usr/share/Jazz² Resurrection"
+ install jazz2.png -Dt "$pkgdir"/usr/share/pixmaps
+ install jazz2.desktop -Dt "$pkgdir"/usr/share/applications
}
diff --git a/jazz2.desktop b/jazz2.desktop
index 5cd3dae7daac..81173d3cad94 100755
--- a/jazz2.desktop
+++ b/jazz2.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Type=Application
Name=Jazz² Resurrection
-Exec=jazz2
+Exec=sh jazz2.sh
Icon=jazz2
Comment=Open-source Jazz Jackrabbit 2 reimplementation
Categories=Game
diff --git a/jazz2.install b/jazz2.install
index a16152071025..a63f8fb3f4f5 100644
--- a/jazz2.install
+++ b/jazz2.install
@@ -1,3 +1,3 @@
post_install(){
- echo -e '\e[93mPlace your game data into "~/.local/share/Jazz² Resurrection/Source" folder\e[m'
+ echo -e '\e[93mPlace your game data into "~/.local/share/Jazz² Resurrection/Source" folder\e[m'
}
diff --git a/jazz2.png b/jazz2.png
index a03ffb0c0b76..46f7f1af63af 100644
--- a/jazz2.png
+++ b/jazz2.png
Binary files differ
diff --git a/jazz2.sh b/jazz2.sh
new file mode 100644
index 000000000000..e2982571391d
--- /dev/null
+++ b/jazz2.sh
@@ -0,0 +1,5 @@
+DIR=/share/Jazz²\ Resurrection/Source
+mkdir -p ~/.local"$DIR"
+cp -n /usr"$DIR"/* ~/.local"$DIR"
+[ -f ~/.local"$DIR"/Anims.j2a ] && rm ~/.local"$DIR"/AnimsSw.j2a || cp -n /usr"$DIR"/../AnimsSw.j2a ~/.local"$DIR"
+jazz2