summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustbrowsing2015-07-08 00:17:35 -0700
committerjustbrowsing2015-07-08 00:17:35 -0700
commit4ca62929c7d09870a3a18816c98570169716d540 (patch)
tree1921482d8f5caa5c94c79779f815a07e38873210
downloadaur-4ca62929c7d09870a3a18816c98570169716d540.tar.gz
Imported to AUR4
-rw-r--r--.AURINFO21
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
3 files changed, 78 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..7e47af39e1c9
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,21 @@
+pkgbase = jbxkb
+ pkgdesc = A pygtk keyboard layout switcher tray applet (inspired by gxkb) for JustBrowsing
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://github.com/justbrowsing/jbxkb
+ arch = any
+ groups = justbrowsing
+ license = GPL3
+ depends = python2
+ depends = pygtk
+ depends = procps-ng
+ depends = xorg-setxkbmap
+ depends = xkb-switch-git
+ optdepends = ibus-lite: Special input methods without python3 dependency
+ optdepends = ibus-m17n: Variety pack of input methods
+ optdepends = ibus-pinyin: Popular Chinese input method
+ optdepends = ibus-skk: Popular Japanese input method
+ source = https://github.com/justbrowsing/jbxkb/archive/master.zip
+
+pkgname = jbxkb
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a133272767fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = jbxkb
+ pkgdesc = A pygtk keyboard layout switcher tray applet (inspired by gxkb) for JustBrowsing
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://github.com/justbrowsing/jbxkb
+ arch = any
+ groups = justbrowsing
+ license = GPL3
+ depends = python2
+ depends = pygtk
+ depends = procps-ng
+ depends = xorg-setxkbmap
+ depends = xkb-switch-git
+ optdepends = ibus-lite: Special input methods without python3 dependency
+ optdepends = ibus-m17n: Variety pack of input methods
+ optdepends = ibus-pinyin: Popular Chinese input method
+ optdepends = ibus-skk: Popular Japanese input method
+ source = https://github.com/justbrowsing/jbxkb/archive/master.zip
+ md5sums = 4131ce5ac97ab0e802cdf20a15a3911a
+
+pkgname = jbxkb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49cdf9d0b489
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: justbrowsing <developer4linux+aur@gmail.com>
+pkgname=jbxkb
+pkgver=0.7
+pkgrel=1
+pkgdesc="A pygtk keyboard layout switcher tray applet (inspired by gxkb) for JustBrowsing"
+arch=('any')
+url="https://github.com/justbrowsing/jbxkb"
+license=('GPL3')
+depends=('python2' 'pygtk' 'procps-ng' 'xorg-setxkbmap' 'xkb-switch-git')
+optdepends=('ibus-lite: Special input methods without python3 dependency'
+ 'ibus-m17n: Variety pack of input methods'
+ 'ibus-pinyin: Popular Chinese input method'
+ 'ibus-skk: Popular Japanese input method')
+groups=("justbrowsing")
+source=("https://github.com/justbrowsing/jbxkb/archive/master.zip")
+md5sums=('4131ce5ac97ab0e802cdf20a15a3911a')
+
+package() {
+ cd "$srcdir/${pkgname}-master"
+
+ # Install flag icons
+ install -d "$pkgdir/usr/share/jbxkb"
+ cp -a usr/share/jbxkb/*png "$pkgdir/usr/share/jbxkb"
+
+ # Desktop launcher
+ install -Dm644 "jbxkb.png" "$pkgdir/usr/share/pixmaps/jbxkb.png"
+ install -Dm644 "jbxkb.desktop" "$pkgdir/usr/share/applications/jbxkb.desktop"
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/jbxkb/LICENSE
+
+ # Executable
+ install -Dm555 jbxkb "$pkgdir/usr/bin/jbxkb"
+ chmod +x "$pkgdir/usr/bin/jbxkb"
+}
+
+