summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2020-07-01 13:41:54 -0400
committerJameson Pugh2020-07-01 13:41:54 -0400
commit0cab0bee3dc66f7ca2c60bb1ca4208e6e6a38472 (patch)
tree26bb95389c6689be7695144c98965161bd5aa05a
downloadaur-0cab0bee3dc66f7ca2c60bb1ca4208e6e6a38472.tar.gz
1.11.8
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2bca4e93d97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = jc
+ pkgdesc = serializes the output of command line tools to structured JSON
+ pkgver = 1.11.8
+ pkgrel = 1
+ url = https://github.com/kellyjonbrazil/jc
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-wheel
+ source = https://github.com/kellyjonbrazil/jc/archive/v1.11.8.tar.gz
+ sha256sums = 9ab5da16aedd06c77585e39e2062d5a730b9a66ea72df131eac65521cae92059
+
+pkgname = jc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..290b795a701d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=jc
+pkgver=1.11.8
+pkgrel=1
+pkgdesc="serializes the output of command line tools to structured JSON"
+arch=('any')
+url='https://github.com/kellyjonbrazil/jc'
+license=('MIT')
+depends=('python-wheel')
+makedepends=('python-setuptools')
+source=("https://github.com/kellyjonbrazil/jc/archive/v${pkgver}.tar.gz")
+sha256sums=('9ab5da16aedd06c77585e39e2062d5a730b9a66ea72df131eac65521cae92059')
+
+prepare(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py test
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root=${pkgdir}
+}
+
+# vim:set ts=2 sw=2 et: