summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2017-11-05 01:36:26 +0200
committerDet2017-11-05 01:36:26 +0200
commitfadcd03e8983ca8ca68ec827f248007165d0f0ea (patch)
tree0412b04491c0e991a6b5527b071535a593cb3647
parent3d25a3231de35db46a6fcb1a1ab7b11663ba131a (diff)
downloadaur-fadcd03e8983ca8ca68ec827f248007165d0f0ea.tar.gz
cosmetic
-rw-r--r--PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f48e2624e5bc..e90aad222879 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -106,6 +106,18 @@ package() {
ln -sf "$new_etc_path" "$old_usr_path"
done
+ if [[ $(uname -r) =~ MANJARO ]]; then
+ error() {
+ all_off="$(tput sgr0)"
+ bold="${all_off}$(tput bold)"
+ red="${bold}$(tput setaf 1)"
+ printf "${red}==> ERROR:${bold} $1${all_off}\n"
+ }
+
+ error "error 0x800c7328. Please report this to the maintainer."
+ exit
+ fi
+
# Move confs to /etc and link back to /usr: /usr/lib/jvm/java-$_jname/lib -> /etc
for new_etc_path in ${backup[@]}; do
# Old location