summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-14 04:13:27 +0300
committerDet2015-06-14 04:14:15 +0300
commite6edee6f005eefe815dfa5eaba3f5e9f4d4048fa (patch)
tree66058d5e2713d79d3a892f167ff603441e0ee22e
downloadaur-e6edee6f005eefe815dfa5eaba3f5e9f4d4048fa.tar.gz
Initial import: 8u45-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffbe8396d726
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = jdk-demos
+ pkgdesc = Demos and samples of common tasks and new functionality in Oracle Java 8 Development Kit
+ pkgver = 8u45
+ pkgrel = 1
+ url = http://www.oracle.com/technetwork/java/javase/downloads/index.html
+ arch = i686
+ arch = x86_64
+ license = custom:Oracle
+ makedepends = pacman>=4.2.0
+ optdepends = java-runtime>=8: Run the examples
+ optdepends = java-environment>=8: Compile and run the examples
+ options = !strip
+ source_i686 = http://download.oracle.com/otn-pub/java/jdk/8u45-b14-demos/jdk-8u45-linux-i586-demos.tar.gz
+ md5sums_i686 = d3840d4bb5bba1efc1de139faae8efd1
+ source_x86_64 = http://download.oracle.com/otn-pub/java/jdk/8u45-b14-demos/jdk-8u45-linux-x64-demos.tar.gz
+ md5sums_x86_64 = 003e3ed2cd19e3be7f94964a4d694492
+
+pkgname = jdk-demos
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abdce72148bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Det <nimetonmaili g-mail>
+
+pkgname=jdk-demos
+_major=8
+_minor=45
+_build=b14
+pkgver=${_major}u${_minor}
+pkgrel=1
+pkgdesc="Demos and samples of common tasks and new functionality in Oracle Java $_major Development Kit"
+arch=('i686' 'x86_64')
+url="http://www.oracle.com/technetwork/java/javase/downloads/index.html"
+license=('custom:Oracle')
+optdepends=("java-runtime>=$_major: Run the examples"
+ "java-environment>=$_major: Compile and run the examples")
+makedepends=('pacman>=4.2.0')
+options=('!strip')
+source_i686=("http://download.oracle.com/otn-pub/java/jdk/$pkgver-$_build-demos/jdk-$pkgver-linux-i586-demos.tar.gz")
+source_x86_64=("http://download.oracle.com/otn-pub/java/jdk/$pkgver-$_build-demos/jdk-$pkgver-linux-x64-demos.tar.gz")
+md5sums_i686=('d3840d4bb5bba1efc1de139faae8efd1')
+md5sums_x86_64=('003e3ed2cd19e3be7f94964a4d694492')
+
+DLAGENTS=('http::/usr/bin/curl -LC - -b oraclelicense=a -O')
+
+package() {
+ cd jdk1.$_major.0_$_minor
+
+ # Install
+ install -d "$pkgdir"/usr/lib/jvm/java-$_major-jdk/demos/
+ mv demo/ sample/ "$pkgdir"/usr/lib/jvm/java-$_major-jdk/demos/
+
+ # README
+ mv "$pkgdir"/usr/lib/jvm/java-$_major-jdk/demos/demo/README \
+ "$pkgdir"/usr/lib/jvm/java-$_major-jdk/demos/README
+
+ # License
+ install -Dm644 "$pkgdir"/usr/lib/jvm/java-$_major-jdk/demos/demo/DEMOS_LICENSE \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ # Clean up
+ rm "$pkgdir"/usr/lib/jvm/java-$_major-jdk/demos/demo/DEMOS_LICENSE
+ rm "$pkgdir"/usr/lib/jvm/java-$_major-jdk/demos/sample/README
+ rm "$pkgdir"/usr/lib/jvm/java-$_major-jdk/demos/sample/SAMPLES_LICENSE
+}