summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2024-01-24 16:46:41 +0330
committerMohammadreza Abdollahzadeh2024-01-24 16:46:41 +0330
commit291dc47d38cfdd319e5c01302c123d19af9c2e29 (patch)
treec2a03a4bf2ed12fd949411e0a2c14bfead7eac01
parenta162275f7d6893d3600db5f83100467d5ebc2220 (diff)
downloadaur-291dc47d38cfdd319e5c01302c123d19af9c2e29.tar.gz
upgpkg: jdk-openj9-bin 21.0.1b12_openj9_0.42.0-1
upstream release
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD16
2 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b10cc3d423c0..8394cc253f6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdk-openj9-bin
- pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk18
- pkgver = 18.0.2b9_openj9_0.33.1
+ pkgdesc = IBM Semeru OpenJ9 with openjdk21
+ pkgver = 21.0.1b12_openj9_0.42.0
pkgrel = 1
url = https://developer.ibm.com/languages/java/semeru-runtimes/downloads
arch = x86_64
@@ -8,16 +8,16 @@ pkgbase = jdk-openj9-bin
depends = java-environment-common
depends = ca-certificates-utils
depends = nss
- provides = java-environment=18
- provides = java-environment-openjdk=18
- provides = java-runtime=18
- provides = java-runtime-openjdk=18
- provides = java-runtime-headless=18
- provides = java-runtime-headless-openjdk=18
- conflicts = jdk18-openj9-bin
- conflicts = jdk18-openj9
+ provides = java-environment=21
+ provides = java-environment-openjdk=21
+ provides = java-runtime=21
+ provides = java-runtime-openjdk=21
+ provides = java-runtime-headless=21
+ provides = java-runtime-headless-openjdk=21
+ conflicts = jdk21-openj9-bin
+ conflicts = jdk21-openj9
options = !strip
- source = https://github.com/ibmruntimes/semeru18-binaries/releases/download/jdk-18.0.2%2B9_openj9-0.33.1/ibm-semeru-open-jdk_x64_linux_18.0.2_9_openj9-0.33.1.tar.gz
- sha256sums = b694d47666035b1f7870bc3749aa7c1903d50976eab3772fd81c32dab2aa8e64
+ source = https://github.com/ibmruntimes/semeru21-binaries/releases/download/jdk-21.0.1%2B12_openj9-0.42.0/ibm-semeru-open-jdk_x64_linux_21.0.1_12_openj9-0.42.0.tar.gz
+ sha256sums = ad575bc4b1fa9e9fa56661444b6153abfa147ec155845afa054472fa6357f026
pkgname = jdk-openj9-bin
diff --git a/PKGBUILD b/PKGBUILD
index 92e30f904ad7..a792810e19e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-# Maintainer: David Wu <xdavidwuph@gmail.com>
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Contributor: David Wu <xdavidwuph@gmail.com>
# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: M A <morealaz at gmail dot com>
# Contributor: Mariell Hoversholm <proximyst at proximyst dot com>
# Contributor: Schrodinger Zhu <i at zhuyi dot fan>
# Contributor: Davide Depau <davide at depau dot eu>
-# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=jdk-openj9-bin
-_jdkver=18
+_jdkver=21
_jdkminor=0
-_jdkpatch=2
+_jdkpatch=1
_jdksubpatch=1
_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch} #.${_jdksubpatch}
-_openj9ver=0.33.1
-_buildvershort=9
+_openj9ver=0.42.0
+_buildvershort=12
_buildver=${_buildvershort}_openj9-${_openj9ver}
pkgver=${_jdkfullver}b${_buildver//-/_}
pkgrel=1
-pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk${_jdkver}"
+pkgdesc="IBM Semeru OpenJ9 with openjdk${_jdkver}"
arch=('x86_64')
url="https://developer.ibm.com/languages/java/semeru-runtimes/downloads"
license=('custom')
@@ -34,7 +34,7 @@ conflicts=("jdk${_jdkver}-openj9-bin" "jdk${_jdkver}-openj9")
options=(!strip)
source=("https://github.com/ibmruntimes/semeru${_jdkver}-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}/ibm-semeru-open-jdk_x64_linux_${_jdkfullver}_${_buildver}.tar.gz")
-sha256sums=('b694d47666035b1f7870bc3749aa7c1903d50976eab3772fd81c32dab2aa8e64')
+sha256sums=('ad575bc4b1fa9e9fa56661444b6153abfa147ec155845afa054472fa6357f026')
_jvmdir=usr/lib/jvm/java-${_jdkver}-j9