summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2024-01-24 17:42:04 +0330
committerMohammadreza Abdollahzadeh2024-01-24 17:42:04 +0330
commit118000eda5eba3f9751795821a744623f776785f (patch)
tree9a8585a22caed8f6a92c345e03a9563749643c55
parente9ba3ce902a488dc6841aaa2f981197024fe090b (diff)
downloadaur-118000eda5eba3f9751795821a744623f776785f.tar.gz
upgpkg: jdk11-openj9-bin 11.0.21b9_openj9_0.41.0-1
upstream release
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD29
2 files changed, 15 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a5e98d40c0e..7bbe0627849d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,9 @@
pkgbase = jdk11-openj9-bin
- pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk11
- pkgver = 11.0.16.1b1_openj9_0.33.1
+ pkgdesc = IBM Semeru OpenJ9 with openjdk11
+ pkgver = 11.0.21b9_openj9_0.41.0
pkgrel = 1
url = https://developer.ibm.com/languages/java/semeru-runtimes/downloads
arch = x86_64
- arch = s390x
- arch = ppc64le
- arch = aarch64
license = custom
depends = java-environment-common
depends = ca-certificates-utils
@@ -19,19 +16,7 @@ pkgbase = jdk11-openj9-bin
provides = java-runtime-headless-openjdk=11
conflicts = jdk11-openj9
options = !strip
-
- source_x86_64 = https://github.com/ibmruntimes/semeru11-binaries/releases/download/jdk-11.0.16.1%2B1_openj9-0.33.1/ibm-semeru-open-jdk_x64_linux_11.0.16.1_1_openj9-0.33.1.tar.gz
-
- source_s390x = https://github.com/ibmruntimes/semeru11-binaries/releases/download/jdk-11.0.16.1%2B1_openj9-0.33.1/ibm-semeru-open-jdk_s390x_linux_11.0.16.1_1_openj9-0.33.1.tar.gz
-
- source_ppc64le = https://github.com/ibmruntimes/semeru11-binaries/releases/download/jdk-11.0.16.1%2B1_openj9-0.33.1/ibm-semeru-open-jdk_ppc64le_linux_11.0.16.1_1_openj9-0.33.1.tar.gz
-
- source_aarch64 = https://github.com/ibmruntimes/semeru11-binaries/releases/download/jdk-11.0.16.1%2B1_openj9-0.33.1/ibm-semeru-open-jdk_aarch64_linux_11.0.16.1_1_openj9-0.33.1.tar.gz
-
- sha256sums_x86_64 = 4eb9dc86bf92e144d7a2c8d6c2a6beac28c17b7348f2f0524e715548f52fd8f1
- sha256sums_s390x = df4b746a0fc51bbab38aa86822a5f8e5587ed2b997cdd764de1c349d8caaa784
- sha256sums_ppc64le = d71e5d26b7240d0e8a80499221ab79e5eed30ab1d985a5316bcfd240148435f8
- sha256sums_aarch64 = fad70f5bd615d08d9b3e6222ce738be713050eedc8dce4b57bdccc85747d9ff6
+ source = https://github.com/ibmruntimes/semeru11-binaries/releases/download/jdk-11.0.21%2B9_openj9-0.41.0/ibm-semeru-open-jdk_x64_linux_11.0.21_9_openj9-0.41.0.tar.gz
+ sha256sums = d11ec92737b9f97bdd9bb553c3e476981f4ac38039963a15c2e1ca9ec163a304
pkgname = jdk11-openj9-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index b3ef7f662ec7..e4a5873b8f3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-# Maintainer: Leonardo Costa <leo95.uqhi2 at aleeas dot com>
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Contributor: Leonardo Costa <leo95.uqhi2 at aleeas dot com>
# Contributor: Davide Depau <davide@depau.eu>
# Contributor: Felix Golatofski <contact@xdfr.de>
-# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
-
pkgname=jdk11-openj9-bin
_jdkver=11
_jdkminor=0
-_jdkpatch=16
+_jdkpatch=21
_jdkpatchminor=1
-_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch}.${_jdkpatchminor}
-_openj9ver=0.33.1
-_buildvershort=1
+_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch} #.${_jdkpatchminor}
+_openj9ver=0.41.0
+_buildvershort=9
_buildver=${_buildvershort}_openj9-${_openj9ver}
_baseurl=https://github.com/ibmruntimes/semeru${_jdkver}-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}
-pkgver=${_jdkfullver}b${_buildver//-/_}
+pkgver="${_jdkfullver}b${_buildver//-/_}"
pkgrel=1
-pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk${_jdkver}"
-arch=('x86_64' 's390x' 'ppc64le' 'aarch64')
+pkgdesc="IBM Semeru OpenJ9 with openjdk${_jdkver}"
+arch=('x86_64')
url="https://developer.ibm.com/languages/java/semeru-runtimes/downloads"
license=('custom')
depends=('java-environment-common' 'ca-certificates-utils' 'nss')
@@ -31,15 +30,9 @@ provides=(
)
conflicts=("jdk${_jdkver}-openj9")
options=(!strip)
-source_x86_64=("${_baseurl}/ibm-semeru-open-jdk_x64_linux_${_jdkfullver}_${_buildver}.tar.gz")
-source_s390x=("${_baseurl}/ibm-semeru-open-jdk_s390x_linux_${_jdkfullver}_${_buildver}.tar.gz")
-source_ppc64le=("${_baseurl}/ibm-semeru-open-jdk_ppc64le_linux_${_jdkfullver}_${_buildver}.tar.gz")
-source_aarch64=("${_baseurl}/ibm-semeru-open-jdk_aarch64_linux_${_jdkfullver}_${_buildver}.tar.gz")
+source=("${_baseurl}/ibm-semeru-open-jdk_x64_linux_${_jdkfullver}_${_buildver}.tar.gz")
-sha256sums_x86_64=('4eb9dc86bf92e144d7a2c8d6c2a6beac28c17b7348f2f0524e715548f52fd8f1')
-sha256sums_s390x=('df4b746a0fc51bbab38aa86822a5f8e5587ed2b997cdd764de1c349d8caaa784')
-sha256sums_ppc64le=('d71e5d26b7240d0e8a80499221ab79e5eed30ab1d985a5316bcfd240148435f8')
-sha256sums_aarch64=('fad70f5bd615d08d9b3e6222ce738be713050eedc8dce4b57bdccc85747d9ff6')
+sha256sums=('d11ec92737b9f97bdd9bb553c3e476981f4ac38039963a15c2e1ca9ec163a304')
_jvmdir=usr/lib/jvm/java-${_jdkver}-j9