summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2019-04-24 15:29:29 +0200
committerDavide Depau2019-04-24 15:29:29 +0200
commit6bd1ac8a157df1cce08a697a657a7d1023f7600c (patch)
treee32ea4d63076df8e9d740385fd70c17ef49ec863
parent14efe7ef992bedcbf076615817df89acbe812a69 (diff)
downloadaur-6bd1ac8a157df1cce08a697a657a7d1023f7600c.tar.gz
Fix package build issue
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD45
2 files changed, 25 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1458cad8ed8b..48ae07965c2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdk11-openj9-bin
pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk11
- pkgver = 11.0.3b7_openj9_0.14.0
+ pkgver = 11b0.3_7_openj9_0.14.0
pkgrel = 1
url = https://adoptopenjdk.net/index.html?variant=openjdk11&jvmVariant=openj9
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9e16f50557b6..2452fea96c9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,50 @@
-# $Id$
-# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Maintainer: Davide Depau <davide@depau.eu>
+# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
pkgname=jdk11-openj9-bin
+_jdkver=11
_openj9ver=0.14.0
-_majorver=11.0.3
-_buildver=7_openj9-${_openj9ver}
+_majorver=${_jdkver}
+_buildvershort=0.3_7
+_buildver=${_buildvershort}_openj9-${_openj9ver}
pkgver=${_majorver}b${_buildver//-/_}
pkgrel=1
-pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk11"
+pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk${_jdkver}"
arch=('x86_64')
-url="https://adoptopenjdk.net/index.html?variant=openjdk11&jvmVariant=openj9"
+url="https://adoptopenjdk.net/index.html?variant=openjdk${_jdkver}&jvmVariant=openj9"
license=('GPL2')
depends=('java-environment-common' 'ca-certificates-utils' 'nss')
provides=(
- "java-environment=11"
- "java-environment-openjdk=11"
- "java-runtime=11"
- "java-runtime-openjdk=11"
- "java-runtime-headless=11"
- "java-runtime-headless-openjdk=11"
+ "java-environment=${_jdkver}"
+ "java-environment-openjdk=${_jdkver}"
+ "java-runtime=${_jdkver}"
+ "java-runtime-openjdk=${_jdkver}"
+ "java-runtime-headless=${_jdkver}"
+ "java-runtime-headless-openjdk=${_jdkver}"
)
-source=("https://github.com/AdoptOpenJDK/openjdk11-binaries/releases/download/jdk-${_majorver}%2B${_buildver}/OpenJDK11U-jdk_x64_linux_openj9_${_majorver}_${_buildver}.tar.gz")
+source=("https://github.com/AdoptOpenJDK/openjdk${_jdkver}-binaries/releases/download/jdk-${_majorver}.0.3%2B7_openj9-${_openj9ver}/OpenJDK${_jdkver}U-jdk_x64_linux_openj9_${_majorver}.${_buildver}.tar.gz")
sha256sums=('7012edd56fc958070bc4747073de14ea08eb43081eb6ea19bdbf4763186e2d17')
-_jvmdir=usr/lib/jvm/java-11-j9
+_jvmdir=usr/lib/jvm/java-${_jdkver}-j9
package() {
# Install
install -d "${pkgdir}/${_jvmdir}"
- cd jdk-${_majorver}+${_buildver}
+ cd jdk-${_majorver}.0.3+7
cp -a bin demo include jmods lib release "${pkgdir}/${_jvmdir}/"
# Link JKS keystore from ca-certificates-utils
rm -f "${pkgdir}/${_jvmdir}/lib/security/cacerts"
ln -sf /etc/ssl/certs/java/cacerts "${pkgdir}/${_jvmdir}/lib/security/cacerts"
# Legal
- install -d "${pkgdir}/usr/share/licenses/java11-j9"
- cp -a legal "${pkgdir}/usr/share/licenses/java11-j9/"
- ln -s /usr/share/licenses/java11-j9 "${pkgdir}/${_jvmdir}/legal"
+ install -d "${pkgdir}/usr/share/licenses/java${_jdkver}-j9"
+ cp -a legal "${pkgdir}/usr/share/licenses/java${_jdkver}-j9/"
+ ln -s /usr/share/licenses/java${_jdkver}-j9 "${pkgdir}/${_jvmdir}/legal"
# Conf
install -d "${pkgdir}/etc"
- cp -r conf "${pkgdir}/etc/java11-j9"
- ln -s /etc/java11-j9 "${pkgdir}/${_jvmdir}/conf"
+ cp -r conf "${pkgdir}/etc/java${_jdkver}-j9"
+ ln -s /etc/java${_jdkver}-j9 "${pkgdir}/${_jvmdir}/conf"
# Man pages
- for f in man/man1/* man/ja/man1/*; do
+ for f in man/man1/*; do
install -Dm 644 "${f}" "${pkgdir}/usr/share/${f/\.1/-openjdk11-j9.1}"
done
ln -s /usr/share/man "${pkgdir}/${_jvmdir}/man"