summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2019-02-18 13:13:07 +0330
committerMohammadreza Abdollahzadeh2019-02-18 13:13:07 +0330
commite14395182c83b5f423ce71c156c16afe53d68d17 (patch)
treebc6a2a92bafc3a95779075ba86172bbaa53c3e6b
parentcde10aa7f99cf5927ab8e20f3ed9fdf424396550 (diff)
downloadaur-e14395182c83b5f423ce71c156c16afe53d68d17.tar.gz
update to v11.0.2b9_openj9_0.12.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33a5549b2edf..65c4757f4792 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdk11-openj9-bin
pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk11
- pkgver = 11.0.1b13
+ pkgver = 11.0.2b9_openj9_0.12.1
pkgrel = 1
url = https://adoptopenjdk.net/index.html?variant=openjdk11&jvmVariant=openj9
arch = x86_64
@@ -14,8 +14,8 @@ pkgbase = jdk11-openj9-bin
provides = java-runtime-openjdk=11
provides = java-runtime-headless=11
provides = java-runtime-headless-openjdk=11
- source = https://github.com/AdoptOpenJDK/openjdk11-binaries/releases/download/jdk-11.0.1%2B13/OpenJDK11U-jdk_x64_linux_openj9_jdk-11.0.1_13_openj9-0.11.0_11.0.1_13.tar.gz
- sha256sums = ef9bf07cba79082285a9d426ea4eb3e8df57561ce2afe07cc5f299a8fa203279
+ source = https://github.com/AdoptOpenJDK/openjdk11-binaries/releases/download/jdk-11.0.2%2B9_openj9-0.12.1/OpenJDK11U-jdk_x64_linux_openj9_11.0.2_9_openj9-0.12.1_openj9-0.12.1.tar.gz
+ sha256sums = a9b298391dc0baf49e935683fb13b1b18ef5fd5b1d0e1a1318c8e425ffdbcbcd
pkgname = jdk11-openj9-bin
diff --git a/PKGBUILD b/PKGBUILD
index 81ff3d08f522..791256741081 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# $Id$
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
-
pkgname=jdk11-openj9-bin
-_majorver=11.0.1
-_buildver=13
-pkgver=${_majorver}b${_buildver}
+_openj9ver=0.12.1
+_majorver=11.0.2
+_buildver=9_openj9-${_openj9ver}
+pkgver=${_majorver}b${_buildver//-/_}
pkgrel=1
pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk11"
arch=('x86_64')
@@ -12,15 +12,15 @@ url="https://adoptopenjdk.net/index.html?variant=openjdk11&jvmVariant=openj9"
license=('GPL2')
depends=('java-environment-common' 'ca-certificates-utils' 'nss')
provides=(
- "java-environment=11"
+ "java-environment=11"
"java-environment-openjdk=11"
- "java-runtime=11"
+ "java-runtime=11"
"java-runtime-openjdk=11"
"java-runtime-headless=11"
"java-runtime-headless-openjdk=11"
)
-source=("https://github.com/AdoptOpenJDK/openjdk11-binaries/releases/download/jdk-${_majorver}%2B${_buildver}/OpenJDK11U-jdk_x64_linux_openj9_jdk-${_majorver}_${_buildver}_openj9-0.11.0_${_majorver}_${_buildver}.tar.gz")
-sha256sums=('ef9bf07cba79082285a9d426ea4eb3e8df57561ce2afe07cc5f299a8fa203279')
+source=("https://github.com/AdoptOpenJDK/openjdk11-binaries/releases/download/jdk-${_majorver}%2B${_buildver}/OpenJDK11U-jdk_x64_linux_openj9_${_majorver}_${_buildver}_openj9-${_openj9ver}.tar.gz")
+sha256sums=('a9b298391dc0baf49e935683fb13b1b18ef5fd5b1d0e1a1318c8e425ffdbcbcd')
_jvmdir=usr/lib/jvm/java-11-j9