summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2019-04-15 01:07:30 +0200
committerDavide Depau2019-04-15 01:07:30 +0200
commit450d5661b503eadfc9c989fbe3980c035546d0c4 (patch)
treed6e72e6d5b97cca03139dee42a14f4a909824382
parente14395182c83b5f423ce71c156c16afe53d68d17 (diff)
downloadaur-450d5661b503eadfc9c989fbe3980c035546d0c4.tar.gz
Update JDK11 PKGBUILD to JDK12
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD53
2 files changed, 41 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65c4757f4792..6aa07d0f0f0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
-pkgbase = jdk11-openj9-bin
- pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk11
- pkgver = 11.0.2b9_openj9_0.12.1
+pkgbase = jdk12-openj9-bin
+ pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk12
+ pkgver = 12b33_openj9_0.13.0
pkgrel = 1
- url = https://adoptopenjdk.net/index.html?variant=openjdk11&jvmVariant=openj9
+ url = https://adoptopenjdk.net/index.html?variant=openjdk12&jvmVariant=openj9
arch = x86_64
license = GPL2
depends = java-environment-common
depends = ca-certificates-utils
depends = nss
- provides = java-environment=11
- provides = java-environment-openjdk=11
- provides = java-runtime=11
- provides = java-runtime-openjdk=11
- provides = java-runtime-headless=11
- provides = java-runtime-headless-openjdk=11
- source = https://github.com/AdoptOpenJDK/openjdk11-binaries/releases/download/jdk-11.0.2%2B9_openj9-0.12.1/OpenJDK11U-jdk_x64_linux_openj9_11.0.2_9_openj9-0.12.1_openj9-0.12.1.tar.gz
- sha256sums = a9b298391dc0baf49e935683fb13b1b18ef5fd5b1d0e1a1318c8e425ffdbcbcd
+ provides = java-environment=12
+ provides = java-environment-openjdk=12
+ provides = java-runtime=12
+ provides = java-runtime-openjdk=12
+ provides = java-runtime-headless=12
+ provides = java-runtime-headless-openjdk=12
+ source = https://github.com/AdoptOpenJDK/openjdk12-binaries/releases/download/jdk-12%2B33_openj9-0.13.0/OpenJDK12U-jdk_x64_linux_openj9_12_33_openj9-0.13.0.tar.gz
+ sha256sums = d61a7a211b314aab9d79bc003b8ce86d5651e705912a24e369a44ae5206afed5
-pkgname = jdk11-openj9-bin
+pkgname = jdk12-openj9-bin
diff --git a/PKGBUILD b/PKGBUILD
index 791256741081..66851805a8ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,51 @@
-# $Id$
-# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
-pkgname=jdk11-openj9-bin
-_openj9ver=0.12.1
-_majorver=11.0.2
-_buildver=9_openj9-${_openj9ver}
+# Maintainer: Davide Depau <davide@depau.eu>
+# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=jdk12-openj9-bin
+_jdkver=12
+_openj9ver=0.13.0
+_majorver=${_jdkver}
+_buildvershort=33
+_buildver=${_buildvershort}_openj9-${_openj9ver}
pkgver=${_majorver}b${_buildver//-/_}
pkgrel=1
-pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk11"
+pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk${_jdkver}"
arch=('x86_64')
-url="https://adoptopenjdk.net/index.html?variant=openjdk11&jvmVariant=openj9"
+url="https://adoptopenjdk.net/index.html?variant=openjdk${_jdkver}&jvmVariant=openj9"
license=('GPL2')
depends=('java-environment-common' 'ca-certificates-utils' 'nss')
provides=(
- "java-environment=11"
- "java-environment-openjdk=11"
- "java-runtime=11"
- "java-runtime-openjdk=11"
- "java-runtime-headless=11"
- "java-runtime-headless-openjdk=11"
+ "java-environment=${_jdkver}"
+ "java-environment-openjdk=${_jdkver}"
+ "java-runtime=${_jdkver}"
+ "java-runtime-openjdk=${_jdkver}"
+ "java-runtime-headless=${_jdkver}"
+ "java-runtime-headless-openjdk=${_jdkver}"
)
-source=("https://github.com/AdoptOpenJDK/openjdk11-binaries/releases/download/jdk-${_majorver}%2B${_buildver}/OpenJDK11U-jdk_x64_linux_openj9_${_majorver}_${_buildver}_openj9-${_openj9ver}.tar.gz")
-sha256sums=('a9b298391dc0baf49e935683fb13b1b18ef5fd5b1d0e1a1318c8e425ffdbcbcd')
+source=("https://github.com/AdoptOpenJDK/openjdk${_jdkver}-binaries/releases/download/jdk-${_majorver}%2B${_buildver}/OpenJDK${_jdkver}U-jdk_x64_linux_openj9_${_majorver}_${_buildver}.tar.gz")
+sha256sums=('d61a7a211b314aab9d79bc003b8ce86d5651e705912a24e369a44ae5206afed5')
-_jvmdir=usr/lib/jvm/java-11-j9
+_jvmdir=usr/lib/jvm/java-${_jdkver}-j9
package() {
# Install
install -d "${pkgdir}/${_jvmdir}"
- cd jdk-${_majorver}+${_buildver}
+ cd jdk-${_majorver}+${_buildvershort}
cp -a bin demo include jmods lib release "${pkgdir}/${_jvmdir}/"
# Link JKS keystore from ca-certificates-utils
rm -f "${pkgdir}/${_jvmdir}/lib/security/cacerts"
ln -sf /etc/ssl/certs/java/cacerts "${pkgdir}/${_jvmdir}/lib/security/cacerts"
# Legal
- install -d "${pkgdir}/usr/share/licenses/java11-j9"
- cp -a legal "${pkgdir}/usr/share/licenses/java11-j9/"
- ln -s /usr/share/licenses/java11-j9 "${pkgdir}/${_jvmdir}/legal"
+ install -d "${pkgdir}/usr/share/licenses/java${_jdkver}-j9"
+ cp -a legal "${pkgdir}/usr/share/licenses/java${_jdkver}-j9/"
+ ln -s /usr/share/licenses/java${_jdkver}-j9 "${pkgdir}/${_jvmdir}/legal"
# Conf
install -d "${pkgdir}/etc"
- cp -r conf "${pkgdir}/etc/java11-j9"
- ln -s /etc/java11-j9 "${pkgdir}/${_jvmdir}/conf"
+ cp -r conf "${pkgdir}/etc/java${_jdkver}-j9"
+ ln -s /etc/java${_jdkver}-j9 "${pkgdir}/${_jvmdir}/conf"
# Man pages
- for f in man/man1/* man/ja/man1/*; do
- install -Dm 644 "${f}" "${pkgdir}/usr/share/${f/\.1/-openjdk11-j9.1}"
+ for f in man/man1/*; do
+ install -Dm 644 "${f}" "${pkgdir}/usr/share/${f/\.1/-openjdk12-j9.1}"
done
ln -s /usr/share/man "${pkgdir}/${_jvmdir}/man"
}