summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-16 13:42:36 +0200
committerGoliathLabs2020-05-16 13:42:36 +0200
commit5f17e4313ed4a040e690884deeadbe7793c80d80 (patch)
treec49327a53f048cab7c9b759679347aaea94fd466
parent944f4711d4c208a26210592248756e148f1f85f8 (diff)
downloadaur-5f17e4313ed4a040e690884deeadbe7793c80d80.tar.gz
Updated: 13.0.2_8_openj9-0.18.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fb56d92e501..cfa797ddbdea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdk13-openj9-bin
pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk13
- pkgver = 13b33_openj9_0.16.0
+ pkgver = 13.0.2b8_openj9_0.18.0
pkgrel = 1
url = https://adoptopenjdk.net/index.html?variant=openjdk13&jvmVariant=openj9
arch = x86_64
@@ -14,9 +14,11 @@ pkgbase = jdk13-openj9-bin
provides = java-runtime-openjdk=13
provides = java-runtime-headless=13
provides = java-runtime-headless-openjdk=13
+ conflicts = jdk13-openj9-bin
+ conflicts = jdk13-openj9
options = !strip
- source = https://github.com/AdoptOpenJDK/openjdk13-binaries/releases/download/jdk-13%2B33_openj9-0.16.0/OpenJDK13U-jdk_x64_linux_openj9_13_33_openj9-0.16.0.tar.gz
- sha256sums = 68ebab0021c719694be8fc868478725a69c5c515cdb62e2933eefe87ba6437df
+ source = https://github.com/AdoptOpenJDK/openjdk13-binaries/releases/download/jdk-13.0.2%2B8_openj9-0.18.0/OpenJDK13U-jdk_x64_linux_openj9_13.0.2_8_openj9-0.18.0.tar.gz
+ sha256sums = aeecf6d30d0c847db81d07793cf97e5dc44890c29366d7d9f8f9f397f6c52590
pkgname = jdk13-openj9-bin
diff --git a/PKGBUILD b/PKGBUILD
index 07b5d88512f9..c4855d0bf7f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,17 @@
-# Maintainer: Schrodinger Zhu <i at zhuyi dot fan>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Schrodinger Zhu <i at zhuyi dot fan>
# Contributor: Davide Depau <davide at depau dot eu>
# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=jdk13-openj9-bin
_jdkver=13
-_openj9ver=0.16.0
-_buildvershort=33
+_jdkminor=0
+_jdkpatch=2
+_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch}
+_openj9ver=0.18.0
+_buildvershort=8
_buildver=${_buildvershort}_openj9-${_openj9ver}
-pkgver=${_jdkver}b${_buildver//-/_}
+pkgver=${_jdkfullver}b${_buildver//-/_}
pkgrel=1
pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk${_jdkver}"
arch=('x86_64')
@@ -22,17 +26,18 @@ provides=(
"java-runtime-headless=${_jdkver}"
"java-runtime-headless-openjdk=${_jdkver}"
)
+conflicts=("jdk${_jdkver}-openj9-bin" "jdk${_jdkver}-openj9")
options=(!strip)
-source=("https://github.com/AdoptOpenJDK/openjdk${_jdkver}-binaries/releases/download/jdk-${_jdkver}%2B${_buildver}/OpenJDK${_jdkver}U-jdk_x64_linux_openj9_${_jdkver}_${_buildver}.tar.gz")
-sha256sums=('68ebab0021c719694be8fc868478725a69c5c515cdb62e2933eefe87ba6437df')
+source=("https://github.com/AdoptOpenJDK/openjdk${_jdkver}-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}/OpenJDK${_jdkver}U-jdk_x64_linux_openj9_${_jdkfullver}_${_buildver}.tar.gz")
+sha256sums=('aeecf6d30d0c847db81d07793cf97e5dc44890c29366d7d9f8f9f397f6c52590')
_jvmdir=usr/lib/jvm/java-${_jdkver}-j9
package() {
# Install
install -d "${pkgdir}/${_jvmdir}"
- cd jdk-${_jdkver}+${_buildvershort}
- cp -a bin demo include jmods lib release "${pkgdir}/${_jvmdir}/"
+ cd jdk-${_jdkfullver}+${_buildvershort}
+ cp -a bin include jmods lib release "${pkgdir}/${_jvmdir}/"
# Link JKS keystore from ca-certificates-utils
rm -f "${pkgdir}/${_jvmdir}/lib/security/cacerts"
ln -sf /etc/ssl/certs/java/cacerts "${pkgdir}/${_jvmdir}/lib/security/cacerts"
@@ -46,7 +51,7 @@ package() {
ln -s /etc/java${_jdkver}-j9 "${pkgdir}/${_jvmdir}/conf"
# Man pages
for f in man/man1/*; do
- install -Dm 644 "${f}" "${pkgdir}/usr/share/${f/\.1/-openjdk13-j9.1}"
+ install -Dm 644 "${f}" "${pkgdir}/usr/share/${f/\.1/-openjdk14-j9.1}"
done
ln -s /usr/share/man "${pkgdir}/${_jvmdir}/man"
}