summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMariell Hoversholm2020-03-19 14:38:54 +0100
committerMariell Hoversholm2020-03-19 14:38:54 +0100
commit49f7558408cabf5b88b7a22d5d4687bc62435981 (patch)
tree18a4981f4b29ed58a2c0ff52f0316bf836a59687
downloadaur-49f7558408cabf5b88b7a22d5d4687bc62435981.tar.gz
Port https://aur.archlinux.org/packages/jdk13-openj9-bin/ for Java 14
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD54
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faaa62dc43d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = jdk14-openj9-bin
+ pkgdesc = Eclipse (former IBM) OpenJ9 with openjdk14
+ pkgver = 14b36_openj9_0.19.0
+ pkgrel = 1
+ url = https://adoptopenjdk.net/index.html?variant=openjdk14&jvmVariant=openj9
+ arch = x86_64
+ license = GPL2
+ depends = java-environment-common
+ depends = ca-certificates-utils
+ depends = nss
+ provides = java-environment=14
+ provides = java-environment-openjdk=14
+ provides = java-runtime=14
+ provides = java-runtime-openjdk=14
+ provides = java-runtime-headless=14
+ provides = java-runtime-headless-openjdk=14
+ options = !strip
+ source = https://github.com/AdoptOpenJDK/openjdk14-binaries/releases/download/jdk-14%2B36_openj9-0.19.0/OpenJDK14U-jdk_x64_linux_openj9_14_36_openj9-0.19.0.tar.gz
+ sha256sums = e5536df914af2a36f3612658827a3ed9fa041ea747ae9ea48c7c91da218dbc6a
+
+pkgname = jdk14-openj9-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..537456b75082
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Mariell Hoversholm <proximyst at proximyst dot com>
+# Contributor: Schrodinger Zhu <i at zhuyi dot fan>
+# Contributor: Davide Depau <davide at depau dot eu>
+# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=jdk14-openj9-bin
+_jdkver=14
+_openj9ver=0.19.0
+_buildvershort=36
+_buildver=${_buildvershort}_openj9-${_openj9ver}
+pkgver=${_jdkver}b${_buildver//-/_}
+pkgrel=1
+pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk${_jdkver}"
+arch=('x86_64')
+url="https://adoptopenjdk.net/index.html?variant=openjdk${_jdkver}&jvmVariant=openj9"
+license=('GPL2')
+depends=('java-environment-common' 'ca-certificates-utils' 'nss')
+provides=(
+ "java-environment=${_jdkver}"
+ "java-environment-openjdk=${_jdkver}"
+ "java-runtime=${_jdkver}"
+ "java-runtime-openjdk=${_jdkver}"
+ "java-runtime-headless=${_jdkver}"
+ "java-runtime-headless-openjdk=${_jdkver}"
+)
+options=(!strip)
+source=("https://github.com/AdoptOpenJDK/openjdk${_jdkver}-binaries/releases/download/jdk-${_jdkver}%2B${_buildver}/OpenJDK${_jdkver}U-jdk_x64_linux_openj9_${_jdkver}_${_buildver}.tar.gz")
+sha256sums=('e5536df914af2a36f3612658827a3ed9fa041ea747ae9ea48c7c91da218dbc6a')
+
+_jvmdir=usr/lib/jvm/java-${_jdkver}-j9
+
+package() {
+ # Install
+ install -d "${pkgdir}/${_jvmdir}"
+ cd jdk-${_jdkver}+${_buildvershort}
+ cp -a bin demo include jmods lib release "${pkgdir}/${_jvmdir}/"
+ # Link JKS keystore from ca-certificates-utils
+ rm -f "${pkgdir}/${_jvmdir}/lib/security/cacerts"
+ ln -sf /etc/ssl/certs/java/cacerts "${pkgdir}/${_jvmdir}/lib/security/cacerts"
+ # Legal
+ install -d "${pkgdir}/usr/share/licenses/java${_jdkver}-j9"
+ cp -a legal "${pkgdir}/usr/share/licenses/java${_jdkver}-j9/"
+ ln -s /usr/share/licenses/java${_jdkver}-j9 "${pkgdir}/${_jvmdir}/legal"
+ # Conf
+ install -d "${pkgdir}/etc"
+ cp -r conf "${pkgdir}/etc/java${_jdkver}-j9"
+ ln -s /etc/java${_jdkver}-j9 "${pkgdir}/${_jvmdir}/conf"
+ # Man pages
+ for f in man/man1/*; do
+ install -Dm 644 "${f}" "${pkgdir}/usr/share/${f/\.1/-openjdk13-j9.1}"
+ done
+ ln -s /usr/share/man "${pkgdir}/${_jvmdir}/man"
+}
+# vim:set ts=2 sw=2 et: