summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPinghigh2023-08-07 14:59:06 +0800
committerPinghigh2023-08-07 14:59:06 +0800
commit1c27925241bc0cf094165a1846e0ce044358b4c0 (patch)
treefd7167cc651ee4e8d5a1c6593620cf69d20a8905
parentf1f6d67dec43a6f9adfb435831a0eaaa5d0bfe6f (diff)
downloadaur-1c27925241bc0cf094165a1846e0ce044358b4c0.tar.gz
Update to 17.0.7+7 && Switch to the certified version
-rw-r--r--PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9332972554d4..e42ff6544511 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
-# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Maintainer: Pinghigh Dai <pinghigh24678@outlook.com>
+# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=jdk17-openj9-bin
_jdkver=17
_jdkminor=0
-_jdkpatch=6
-#_jdksubpatch=1
+_jdkpatch=7
+#_jdksubpatch=0
+_jdkfixpack=0
_jdkfullver=${_jdkver}.${_jdkminor}.${_jdkpatch}
-_openj9ver=0.36.0
-_buildvershort=10
-_buildver=${_buildvershort}_openj9-${_openj9ver}
+_openj9ver=0.38.0
+_patchver=7
+_buildver=${_patchver}_openj9-${_openj9ver}
+pkgrel=7
+pkgdesc="IBM® Semeru Runtime Certified Edition, Version ${_jdkver}"
pkgver=${_jdkfullver}b${_buildver//-/_}
-pkgrel=1
-pkgdesc="Eclipse (former IBM) OpenJ9 with openjdk${_jdkver}"
arch=('x86_64')
url="https://developer.ibm.com/languages/java/semeru-runtimes/downloads"
license=('custom')
@@ -25,16 +27,16 @@ provides=(
)
conflicts=("jdk${_jdkver}-openj9-bin" "jdk${_jdkver}-openj9")
options=(!strip)
-source=("https://github.com/ibmruntimes/semeru${_jdkver}-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}/ibm-semeru-open-jdk_x64_linux_${_jdkfullver}_${_buildver}.tar.gz")
+source=("https://github.com/ibmruntimes/semeru${_jdkver}-certified-binaries/releases/download/jdk-${_jdkfullver}%2B${_buildver}/ibm-semeru-certified-jdk_x64_linux_${_jdkfullver}.${_jdkfixpack}.tar.gz")
-sha256sums=('ce39a4f7c2e08e56083f17f3e44c05e0fbbeba775e670f015a337679c99c54c6')
+b2sums=('b94c8bf5a171914b715cc9aa0fa7c3b30b7419d541cc0d41b1089eb041c80f04861601af17caf7caa7090d4f4bc69dbf4c16b4100518efb3aa25d57611a7c025')
_jvmdir=usr/lib/jvm/java-${_jdkver}-j9
package() {
# Install
install -d "${pkgdir}/${_jvmdir}"
- cd jdk-${_jdkfullver}+${_buildvershort}
+ cd jdk-${_jdkfullver}+${_patchver}
cp -a bin include jmods lib release "${pkgdir}/${_jvmdir}/"
# Link JKS keystore from ca-certificates-utils
rm -f "${pkgdir}/${_jvmdir}/lib/security/cacerts"